Tool changer commands



  • Hi! please I need some help with the new tool changer printer I made (I setup four macros that are ready for use).

    How can I do the following please?

    Starting Script (when print job is started)

    if new tool is T0 then call M98 P/macros/selectT0

    if new tool is T1 then call M98 P/macros/selectT1

    Tool Change Script (during print job)

    {if new tool is T0 then call M98 P/macros/parkT1

    if new tool is T0 then call M98 P/macros/selectT0

    if new tool is T1 then call M98 P/macros/parkT0

    if new tool is T1 then call M98 P/macros/selectT1

    Ending Script (after print job is finished)

    if current tool is T0 then call M98 P/macros/parkT0

    if current tool is T1 then call M98 P/macros/parkT1

    It's very important for me in order to make my tool changer work automatically.
    Hopefully you can be clear and easy with me so I understand exactly how and where to put everything.
    Thank you very much in advance!



  • Did you read the "Tool change" section in the documentation?



  • @whosrdaddy
    Thanks, yes I've read them but they got me very confused unfortunately.
    Also seems that I can use them "during the print" but I also need separate sections for "starting a print" and "ending a print".
    So for example: when the print starts; the firmware selects the correct tool (without parking anything because everything is already parked at the end of the previous print).
    But during a print the firmware should park the current tool then select the new one.



  • the slicer will call the Tx commands and subsequently the firmware will call the 3 tool related macro's.
    I don't see the problem?


  • administrators

    @rajaakahel

    Put the selectT0 or selectT1 in your start gcode, the parkT0/T1 in the end gcode then use the tool change macros (pre, post etc) to call the relavent park and selects on tool change.



  • @whosrdaddy
    If I write in tpre0 to park T1 then select T0 during a print that's ok. But then at the beginning of a print it will also do the same (to park T1 then select T0) but T1 is already parked, That will be horrible crash.
    As I said I'm pretty confused, so please if you can't explain with simple steps don't confuse me more 🙂
    Thanks for the input 🙂



  • Actually parking T1 should be done in TFree1.g, don't touch other tools in the Txxxx Macro's


  • administrators

    @RajaaKahel the Duet does not know that a particular T0 command is at the start of a print, or part way through a print, which is why i am suggesting having the appropraite pick up command in your start gcode as included in the slicer.

    Alternatively always have the printer have T0 picked up when its in an idle state.



  • @t3p3tony and @whosrdaddy
    Thank you for your input! I'll try to figure this out with a new cup of coffee 🙂



  • @rajaakahel : I don't know if you read this one too: https://duet3d.dozuki.com/Wiki/Gcode#Section_T_Select_Tool?
    This is the most informative doc about tools and the sequence followed on tool changes.



  • @whosrdaddy
    Thank you, I started to make progress finally, after some painful crashes especially with the interference from S3D..



  • Ok, so I removed any parking or picking commands from Simplify3D, and did the following:
    ; tfree0.g
    ; called when tool 0 is freed
    M98 P/macros/parkT0

    ; tfree1.g
    ; called when tool 1 is freed
    M98 P/macros/parkT1

    ; tpre0.g
    ; called before tool 0 is selected
    M98 P/macros/selectT0

    ; tpre1.g
    ; called before tool 1 is selected
    M98 P/macros/selectT1

    It works fine during a print, but at the beginning it doesn't pick any tool, and at the end it doesn't park any tool. Is there a way to fix this?
    I noticed that I don't have files such as start.g or end.g in the files section, anyway is there such a start file for T0 and another one for T1? (same for the end?)


  • administrators

    @rajaakahel glad you got it working on tool change!

    start and end gcodes are normally configured in you slicer so you can add the relevant macro calls to your slicer.

    One thing I note it that if you don't always start with tool 0 for every print then its probably better to have the "default state " of your printer with the tool changer with tool 1 selected.



  • @t3p3tony Thank you!
    Unfortunately Starting Script and Ending Script in Simplify3D don't allow IF commands such as {IF NEWTOOL=0}
    It's only allowed in Tool Change Script section.
    And as you know each print is different, one time you start with a tool and another time you start with another tool (same for finishing). So I would love to make it automatic..


  • administrators

    @rajaakahel in that case you are going to have to have a default state of the printer with always having T0 (or T1) selected. So your end script always selects T0 so you know at the start that T0 is selected. That way when the printer changes to T1 it will park T0 and then pickup T1. That should work even if the printer start with T1, as long as S3d explicitly chooses the tool every time.



  • @t3p3tony Thank you very much for your time! I'll look into this closely. I also submitted a request to S3D to allow IF commands in start and end scripts. I hope it can be added later in the Duet firmware as well.
    Please can you check my other post whenever you have time?
    https://forum.duet3d.com/topic/6517/setting-z-offset-for-t1


  • administrators

    @rajaakahel, make sure you start with no tool selected. You probably have T0 at the end of config.g, if so then remove that. Also include T-1 in your slicer end script to deselect and park the active tool.



  • @dc42 Thank you! I'm still trying to work it out to be full automatic. Will get back to you with the results 🙂



  • @dc42 Hello again, I managed to
    park any nozzle at the end of a print by putting the following Ending Script in my slicer:

    G1 E-15 F4000
    M104 S0 ; turn off extruder
    M140 S0 ; turn off bed
    T0
    M98 P/macros/parkT0
    G28 X ; home x and y axes
    G28 Y ; home x and y axes
    M84 ; disable motors
    M107
    M1

    In Duet firmware I have the following:

    ; tfree0.g
    ; called when tool 0 is freed
    M98 P/macros/parkT0

    ; tfree1.g
    ; called when tool 1 is freed
    M98 P/macros/parkT1

    ; tpost0.g
    ; called after tool 0 is selected
    M98 P/macros/selectT0

    ; tpost1.g
    ; called after tool 1 is selected
    M98 P/macros/selectT1

    But the problem is when I start a print, Duet is always activating T0 (even if the first tool to run is T1) when starting to heat up, but it does not actually go and pick T0 tool (so it thinks T0 is already picked up).

    I can work this around by picking T0 at the end of each print without parking it. But I want both nozzles to be parked to prevent oozing and stuff.

    So the question is: how can I tell the duet to start a print (heat up) without activating any tool until the print gcode tells it to activate (thus pick up) the right tool?

    *I don't have T0 or T1 at the end of config.g
    *I tried to include T-1 or M1 at the Starting Script of my slicer, but it didn't work. (Duet is always activating T0 regardless of what tool gonna start).
    *I tried sending M1 manually before I start a print (to deactivate tools) but same thing happens when a print is started by heating up (activating T0).



  • @rajaakahel Make sure that all axes are referenced before the tool command!
    Only then will the tool script be triggered!

    @rajaakahel said in Tool changer commands:

    But the problem is when I start a print, Duet is always activating T0 (even if the first tool to run is T1) when starting to heat up, but it does not actually go and pick T0 tool (so it thinks T0 is already picked up).

    Do you have a start.g file? With me the duet does not select a tool at the print start, so you have somewhere a tool command.

    @rajaakahel said in Tool changer commands:

    I can work this around by picking T0 at the end of each print without parking it. But I want both nozzles to be parked to prevent oozing and stuff.

    Does not T-1 work? There must be no M84, M18, M1 before.

    G1 E-15 F4000 
    M104 S0; Extruder 
    M140 S0 ausschalten; Bett ausschalten 
    T-1
    G28 X; home x und y Achsen 
    G28 Y; home x und y Achsen 
    M84; Deaktivieren Sie die Motoren 
    M107 
    M1
    

    @rajaakahel said in Tool changer commands:

    So the question is: how can I tell the duet to start a print (heat up) without activating any tool until the print gcode tells it to activate (thus pick up) the right tool?

    You can activate tools with T# P0 (# = Tool Number) without changing the tool

    https://duet3d.dozuki.com/Wiki/Multiple_tools_and_Tool_change_macros



  • @zerspaner_gerd
    "Make sure that all axes are referenced before the tool command!
    Only then will the tool script be triggered!"
    You mean by "referenced" homed? if so, then yes they are homed.

    "Do you have a start.g file? With me the duet does not select a tool at the print start, so you have somewhere a tool command."
    No I don't have a start.g file in the Duet. And in my slicer only G28 is included in the Start Script. I don't find any tool command..

    "Does not T-1 work? There must be no M84, M18, M1 before."
    I tried T-1 and M1 in the Start Script of my slicer, they do nothing. After I upload a print to the Duet, it immediately choose T0 (but doesn't activate the tpost1.g (same if I manually send T-1 or M1 before I start a print).

    You can activate tools with T# P0 (# = Tool Number) without changing the tool
    Where should I put T# P0?
    Again, Duet is always activating T0 (even if the first tool to run is T1) when starting to heat up, but it does not activate the tpost1.g.




  • administrators

    @rajaakahel said in Tool changer commands:

    But the problem is when I start a print, Duet is always activating T0 (even if the first tool to run is T1) when starting to heat up, but it does not actually go and pick T0 tool (so it thinks T0 is already picked up).

    That probably means you have either a T0 command or a M109 command near the start of your GCode file before the printer has been homed. M109 or M109 T0 will select T0 implicitly if no tool is selected, and if the printer hasn't been homed than the tool change macros won't be run.



  • @dc42 said in Tool changer commands:

    M109

    This is my Start and Ending Scripts in Simplify3D, nothing else is there in between:
    Start Script:
    G1 E15 F3000
    G28 ; home all axes
    G1 Y37
    Ending Script
    G1 E-15 F4000
    M104 S0 ; turn off extruder
    M140 S0 ; turn off bed
    T0
    ;M98 P/macros/parkT0
    G28 X ; home x and y axes
    G28 Y ; home x and y axes
    M84 ; disable motors
    M107
    M1

    I can't find any M109. Where in the Duet I can look for what is causing this? You see I attached all the files in my last post, I can't either find anything in them, please check them yourself too. Maybe my firmware is bad somehow? especially that I have another problem that I have to fix in order for my printer to function! (G10 Z offset for T1 simply doesn't work) as you see here:
    https://forum.duet3d.com/topic/6517/setting-z-offset-for-t1/15

    Any suggestions please? (at least I have to fix the T1 Z offset issue).

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 1.21 (2018-03-21)
    WiFi Server Version: 1.21RC4(08b3)
    Web Interface Version: 1.21-RC4


  • administrators

    Please post the first 50 or so lines (not counting comment lines) of the GCode file generated by your slicer. You may find that it has inserted a M109 command before your start GCode.


Log in to reply