Pressure Advance Calibration



  • So if I want to have gcode for printer with 0,0 on the corner I need to change to this?
    curr_x = 110
    curr_y = 110



  • Very very nice approach. I helped writing the marlin test generator, and I think it is useful here also, but that test generates a bunch of side-by-side lines, and the visual results are not as pleasing as this one.

    Just for reference, the marlin test is this one:

    http://marlinfw.org/tools/lin_advance/k-factor.html



  • @obeliks said in Pressure Advance Calibration:

    So if I want to have gcode for printer with 0,0 on the corner I need to change to this?
    curr_x = 110
    curr_y = 110

    Plus the one hardcoded G1 line at line 32. Not strictly necessary but this would have better been parameterized also.

    Instead I just switched my printer to having 0,0 in the bed center. I wanted to do this for a while now. 😁 Now I need to find all places to adjust macros. 😂



  • Hah. Well I'll probably do the same for this test.



  • oh thanks!!!!

    Thet is jut great 😄



  • Just ran the test and found a value of 0.144 best for me. But then a question formed: is PA set for the extruder or the filament? I mean do I put it into config.g or the filament's config? I think the latter but I am not sure.



  • @wilriker It's up to you. If you find you need different values for different filaments, put it in a macro or even the start gcode. If you always use the same value, put it in config.g.



  • Here's another example on a different printer with a different extruder. Holding the print up to the light clearly shows the inverted color gradients showing differences in extrusion volumes.
    0_1535998086477_IMG_6349.JPG

    @deckingman said in Pressure Advance Calibration:

    @digitalvision Did you really mean extrusion rate between 5 and 100mm/s or did you mean print speed? I suspect the latter as an extrusion rate of 100mm/sec is nowhere near attainable and would relate to a print speed in the order of 5,000 mm/sec.

    Yes, I meant print speed – thanks for pointing that out. The theory being that with proper pressure advance the extrusion width should remain constant independent of print speed and acceleration/deceleration.

    @wilriker said in Pressure Advance Calibration:

    @digitalvision Might be relevant to other trying to test: this is python2 syntax and won't run with python3.

    Thanks – updated the script to be python 2/3 compatible. Apologies for the messy script too – this was literally a 15 minute hack.

    @obeliks said in Pressure Advance Calibration:

    So if I want to have gcode for printer with 0,0 on the corner I need to change to this?
    curr_x = 110
    curr_y = 110

    I updated the script to allow a bed center setting.



  • @digitalvision Thanks.
    Now can someone explain my stupid ass how to output the result to a file? 😊



  • @obeliks said in Pressure Advance Calibration:

    @digitalvision Thanks.
    Now can someone explain my stupid ass how to output the result to a file? 😊

    Try:

    python advance_cal.py > advance_cal.gcode


  • @wilriker said in Pressure Advance Calibration:

    Just ran the test and found a value of 0.144 best for me. But then a question formed: is PA set for the extruder or the filament? I mean do I put it into config.g or the filament's config? I think the latter but I am not sure.

    It will vary a lot for different materials (i.e. PLA vs ABS) and may vary between different brands of the same materials even. I consider the value valid for the specific filment the test was made on and created macros to change the value when changing the filament.



  • I will be putting it in to the filament gcode. I will also split it per nozzle, since I have "quickchange" print head.



  • Thanks to everyone, I decided to put it in the filament's config. 🙂



  • @token47 said in Pressure Advance Calibration:

    It will vary a lot for different materials (i.e. PLA vs ABS) and may vary between different brands of the same materials even. I consider the value valid for the specific filment the test was made on and created macros to change the value when changing the filament.

    Thinking about the mechanisms at work which cause pressure to build up, it's likely to depend on the viscosity of the filament if everything else (Bowden tube length, melt chamber size and nozzle diameter) remain the same. In my own experiments, I've found that print temperature can have a small effect as it changes the viscosity but I can't say that I've noticed any difference between brands of the same filament. In fact, I can't say that I've notice any difference between PETG at 220 and PLA at 195. Maybe the difference in temperature cancels out the different viscosity characteristics of the materials. I can't print ABS so cannot say if that behaves differently.



  • This is not completely on-topic but still fits here I hope:
    Linear Advance and Non-Linear Extrusion. Are they mutual exclusive or can they be used complementary? If the latter what would need to be tuned first?


  • administrators

    @wilriker said in Pressure Advance Calibration:

    This is not completely on-topic but still fits here I hope:
    Linear Advance and Non-Linear Extrusion. Are they mutual exclusive or can they be used complementary? If the latter what would need to be tuned first?

    They can both be used together. I don't think they should interact much, but if in doubt I suggest you tune nonlinear extrusion first.



  • What the? Even at S0.996 I am still seeing a step between the slow and fast part. Why?



  • @obeliks What kind of extruder are you using? The Bowden setup of the P3sTE Mk2? AFAIK Bowden setups use larger PA values - and my original Anet MK8 direct extruder even needs 0.144 apparently. 😁



  • I know, but this is a bit silly.
    I am using a cloned Titan extruder. A bad clone.
    But still, long bowdens are supposed to have around 0.2, and I have a 40cm long bowden



  • @obeliks I haven't looked at the file but I'd have thought with that test, that acceleration and instantaneous speed change (jerk) will play a big part in the results. Forget the 100mm/sec speed unless you have a genuine E3D volcano - even then, you might struggle depending on nozzle size and layer height.

    Maybe your clone just has a very low melt rate or maybe it's got a partial blockage or the filament is bulging in the heat break area causing a restriction. Suggest you try something like a test cube without any pressure advance, just to check what speed you can print at (i.e how fast can melt filament). If the melt rate equates to (say) 60mm/sec or less, then trying to print at 100mm/sec ain't gonna work - no matter what you do with pressure advance.


Log in to reply