Ringing at 20-70mm/s, mostly during acceleration/deceleration



  • Hi,
    I've been building a modified version of Hypercube Evolution CoreXY for a while now, but one thing that I can't get rid of is heavy ringing at around 20-75mm/s. 90mm/s and upwards barely exhibit this problem. It's a belt system and I've tried tightening or loosening the belt already.

    If I feel the top of the motor pulley with my finger during phases which exhibit the most ringing I can feel the motor accelerating and decelerating jerkily. I can also hear it if I put my head close to the motor. Moreover the ringing pattern is in sync with both motors and they are on separate belts and pulleys. Smooth curves exhibit the most ringing at the mentioned speed.

    I've read threads like https://forum.duet3d.com/topic/5319/strange-ringing-artifacts-on-corexy and a few others, but mostly they're about higher speeds or belt and pulley problems which I don't seem to have. I'm almost thinking this is resonance and simply how these steppers work, but I lack expertise on this.

    Here's some pics:
    0_1545246503967__IMG0900.jpg

    0_1545246157960__IMG0903.jpg

    0_1545245773613__IMG0904.jpg

    STL: 0_1545247967367__40x10.STL

    One ripple on the curve is somewhere between 1.4-1.6mm in width. The object was printed at 0.2 layer, 150% scale, 2000mm/min jerk and 10000mm/min acceleration . I've already tried changing acceleration, current, jerk, microstepping and driver settings (which I only partly understand - a few crashes later...). I've found some stepper settings for M569 to be somewhat more silent, but all otherwise they seemed to change nothing and some of them made the motors skip steps violently, so I decided to ask here before I try anything else.

    Some of these values below may seem like overkill, but I've tried lesser values too and they didn't help. With a print volume of around 500x500x500 the printer must travel way faster than it's printing otherwise it's losing too much time. I've slapped active cooling on everything.

    Motor relevant config.g:
    M584 X0 Y1 Z5:6:7:8 E3:4
    M569 P0 S1 B0 F6 Y0:14:0
    M569 P1 S1 B0 F6 Y0:14:0
    M569 P3 S1 B0 F6 Y0:14:0
    M569 P4 S1 B0 F6 Y0:14:0
    M569 P5 S0 B0 F6 Y0:14:0
    M569 P6 S0 B0 F6 Y0:14:0
    M569 P7 S0 B0 F6 Y0:14:0
    M569 P8 S0 B0 F6 Y0:14:0

    M350 X16 Y16 E16:16 Z16 I1
    M92 X80 Y80 Z2126,73195730232 E88.208871:88.208871 ; Set steps per mm

    M566 X9000 Y9000 Z600 E4500:4500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X96000 Y96000 Z800 E2500:2500 ; Set maximum speeds (mm/min)
    M201 X24000 Y24000 Z1200 E6000:6000 ; Set accelerations (mm/s^2)
    M906 X2500 Y2500 Z2500 E2500:2500 I40 ; Set motor currents (mA) and motor idle factor in per cent

    Tried to no avail:
    M566 X4000 Y4000 Z600 E4500:4500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X24000 Y24000 Z800 E2500:2500 ; Set maximum speeds (mm/min)
    M201 X6000 Y6000 Z1200 E6000:6000 ; Set accelerations (mm/s^2)
    M906 X1600 Y1600 Z2500 E2500:2500 I40 ; Set motor currents (mA) and motor idle factor in per cent

    I'm using these motors: https://www.omc-stepperonline.com/download/17HS24-2104S.pdf @ 24V

    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02RC4(RTOS) running on Duet WiFi 1.02 or later + DueX5

    No suspicious error messages during printing.

    I read that I might need to increase steps per mm, but this sort of ringing seems excessive, especially at under 70mm/s which is what a lot of people use to print. I have a gut feeling that this ringing has been giving me headaches all along. I attributed this to some slack in the axes and rebuilt them, but it turns out it's been dominating the prints all along.

    Any thoughts would be much appreciated.


  • Moderator

    I don't believe that's ringing. I've seen similar ridges on curves on my Dbot CoreXY. I'm using similar motors to yours (2004s I believe). Also 24v.

    My steps per mm on X and Y are 200 though compared to your 80. (16 tooth pulleys and 0.9 degree motors).

    I've found that it's highly dependant on the resolution of the STL file being printed. If I export a circle from fusion 360 at low resolution it's noticeable, but if I use high resolution setting it's not.

    I've printed that very same STL and seen the same results, so it's not just you.

    One thing that you may want to try is to increase your extruder steps per mm. 88 is pretty low. Try using x128 microstepping and see if it makes a difference for you. Try increasing microsteps for X and Y as well and see if it makes a difference.



  • @phaedrux I've already tried changing X, Y and E microstepping, no difference.

    I've now remade that STL and exported it in very high detail. Interestingly, it got a bit better, but it's still there.

    It can't be related to any single axis, as this would produce same artifacts regardless of speed. There must be some other constant, independent factor in the system. The only one that I can think of right now is resonance and ringing, but it doesn't correspond to what I'm hearing during the straight segments.

    On the left is higher resolution STL, on the right - old one; both at 128 extruder microstepping:
    0_1546038395743_174ad8fe-e947-4837-9bec-64daa908c562-grafik.png

    I increased the print speed from 60 to around 170 in 6mm/s increments roughly every 4 layers, starting from the blue line.


  • Moderator

    Interesting findings and close to what I've noticed myself. Not sure what to make of it all though.



  • @phaedrux It turns out the ridges on straight segments as visible at the blue line were caused by improperly assembled axis. Some ball bearings were misaligned and I also used a bad carbon fibre rod. Needless to say, the bearings rubbed through the epoxy coatings of the rods and were running on the fibers, which caused the whole thing to vibrate. They were hollow rods, so with some pressure and higher speeds the problem "masked" itself.

    Straight segments are now good. The slight ringing on the round segment as in the left print in the pic above is still there though and I'm still not sure why.


Log in to reply