H1 giving erratic reads while printing.



  • i already replaced the pt100 but from old to new its the same.
    after printing 2 big parts its now like that, and i already did tuning (down to P0.4) and test printing but same output.
    im not sure what caused it to be like that. Kindly advise. 😞

    0_1549941991737_be89e95d-a256-4787-8024-f6807492f123-image.png

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DDM-9FAM2-LW4SD-6JKD2-3S86N-KLWBX
    Used output buffers: 3 of 20 (12 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98596 of which 12 recycled
    Exception stack ram used: 512
    Never used ram: 6428
    Tasks: NETWORK(ready,544) HEAT(blocked,1232) MAIN(running,3852) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:26:23 ago, cause: software
    Last software reset at 2019-02-12 11:00, reason: User, spinning module GCodes, available RAM 6148 bytes (slot 2)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 9
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 10.7ms, max retries 0
    MCU temperature: min 52.4, current 58.5, max 58.7
    Supply voltage: min 0.4, current 23.1, max 25.4, under voltage events: 1, over voltage events: 0, power good: yes
    Driver 0: ok, SG min/max 0/104
    Driver 1: ok, SG min/max 0/77
    Driver 2: ok, SG min/max 0/246
    Driver 3: ok, SG min/max 0/93
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-02-12 11:26:45
    Cache data hit count 4294967295
    Slowest loop: 59.32ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 228, MinFreeDm: 126, MaxWait: 513013ms, Underruns: 0, 0
    Scheduled moves: 1725, completed moves: 1722
    Bed compensation in use: mesh
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.0
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 1
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is doing "G1 X216.053 Y137.457 E10.8569" in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 51.05ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.22
      WiFi MAC address 2c:3a:e8:0a:f9:74
      WiFi Vcc 3.31, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 29472
      WiFi IP address 192.168.1.10
      WiFi signal strength -47dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0


  • can it be a heater problem?


  • administrators

    Does the noise on the graph only start when the printer starts moving/extruding? If so it looks like noise from your stepper motors as a potential cause. look at your wire routing to avoid routing the wires in a bundle with stepper wires.


  • administrators

    Your oscillating hot end temperature suggests that heater tuning hasn't worked very well. Try increasing the D parameter in the M307 command for heater 1 by 20% to 50%.

    The sharp downward excursions suggest a possible short in the wiring, or perhaps static discharge. Try grounding the hot end metalwork.



  • will try it, currently retuning.



  • tried the D to 20-50% same thing..will rewire as i think there is probably a bad grounding.



  • seems like it was heavily grounded. not sure why still..
    but i added a grounding on the hotend heatsink then loosen up the cable ties.
    seems to be the same. managed to have the temp to be stable before print but while printing the erratic temps starts to act up.

    not sure if the psu as when it acts up when the motors move.



  • replaced the heater cause i think its busted.
    M563 P0 D0 H2

    still seeing the wobbling, checking the image i think my psu is not giving the current it needs?

    0_1550215200291_0af0cf16-1042-4042-817c-f841f010cc28-image.png


  • administrators

    Do the hot end temperature oscillations stop if you turn the bed heater off?



  • seems like the oscillations start at 200degrees, brought the bed down and still the same.

    0_1550221531305_7e49a50f-1753-4f70-bd22-60a4c27913cb-image.png


  • administrators

    Looks like you changed from using heater 1 output to heater 2. Did you run auto tuning on heater 2, with a target temperature around 200C or a little higher?

    What type of hot end do you have, and what are your M307 parameters for heater 2? Send M307 H2 to report them.



  • @dc42 said in H1 giving erratic reads while printing.:

    M307 H2

    tuned to 260, should i tune to a little lower value?

    M307 H2
    Heater 2 model: gain 347.5, time constant 196.2, dead time 6.2, max PWM 0.50, calibration voltage 24.1, mode PID, inverted no, frequency default
    Computed PID parameters for setpoint change: P16.2, I0.462, D70.5
    Computed PID parameters for load change: P16.


  • administrators

    260C should be Ok for tuning. But why have you set a PWM limit of 0.5?



  • @dc42
    it gives the overpowered error during tuning.
    im using a 24V 50W heater



  • @pao_wikhan said in H1 giving erratic reads while printing.:

    @dc42
    it gives the overpowered error during tuning.
    im using a 24V 50W heater

    Ahhh. That's most likely the root cause of the problem. I once tried to "tame" an overpowered heater and never did have much success in reducing the oscillations. The solution for me was to use a more appropriately sized heater cartridge.



  • @deckingman

    i think my issue is more than that..while printing it gives out erratic values from 210 down to 160-140, stopping the print



  • @pao_wikhan said in H1 giving erratic reads while printing.:

    @deckingman

    i think my issue is more than that..while printing it gives out erratic values from 210 down to 160-140, stopping the print

    I'd say, looking at the graph you posted, that you have two issues. The general +/- 2 to5 deg or so oscillation is likely just the heater being too powerful. The rapid drops in temperature can't be "real". That is to say, the temperature can't really drop by 50 degrees in such short a time unless you actually remove the hot end and drop it into dry ice or some such ☺ So that must be a wiring issue or electrical noise.



  • thats the thing. it was working for the past few month, didnt touch anything print print print. now this giving me that erratic motion is weird. so i replaced the sensor same output, and did the stuff recommended here.
    just finished rewiring really, so im testing.



  • @deckingman
    rewiring is the same..oscillations..will try using e3d generic 24v 30W heater..then tune to max P1



  • Thanks @dc42 @deckingman @T3P3Tony
    i fixed it, seems like the thermistor is getting pulled and something was shorting the 5v rail. still using the new cartridge and ntc sensor (the pt100 was giving 2000degrees, but rtc1 is working when i place a 100ohm resistor) will troubleshoot that in a new chapter.
    oh and a new psu too, seems like the psu was heavily grounded.
    0_1550296538601_70f39bd6-45d9-49be-852d-d05853d37330-image.png


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.