After every power-off, I lose my Z zero.



  • Every time I turn my printer on, I have to run another auto-calibration (the old school paper way) because otherwise the prints begin a little over 15mm above the bed.

    I'm also having an underextrusion issue. My Bontech Mini was 141 steps/mm on the Rambo, and I assumed it should directly translate to the Duet setting, but now I'm not sure.

    The printer is a Rostock Metal Max (converted from a Rostock Max v2).
    It has:

    • Duet 2 Wifi
      Bondtech mini extruder (hanging configuration)
      29a 12v PSU from SeeMeCNC's conversion kit
      Tricklaser metal frame
      Tricklaser carbon 325mm delta arms
      Tricklaser Trick Trucks
      713maker hotend mount
      Prometheus v2 0.4mm hot end.

    I don't imagine any of that should matter, but just in case..



  • are you saving the values from the auto calibration?



  • @layerslayer said in After every power-off, I lose my Z zero.:

    I'm also having an underextrusion issue. My Bontech Mini was 141 steps/mm on the Rambo, and I assumed it should directly translate to the Duet setting, but now I'm not sure.

    I'm not familiar with the Bondtech mini - indeed it isn't listed on their web site. But 141 steps/mm seem very low. I've looked through the specs of all the other extruders on Bondtechs' site and they all list much higher steps per mm. The only exception is the V2 for which there is no immediately obvious specification but as it uses a geared stepper motor, I'd expect that to be higher as well.

    Steps per mm are usually quoted using micro-stepping at 16x. Did you Rambo board also use the 16x micro-stepping?

    By coincidence, my Bondtech BMGs use 411 step per mm. The 141 that you are using is an "anagram" of 411. Might there be a typo somewhere?



  • @layerslayer said in After every power-off, I lose my Z zero.:

    Bontech Mini

    https://www.3djake.com/bondtech/extruder-mini-for-wanhao-i3
    here it says 140

    what thermistor are you using and what values did you configure?



  • @veti OK.I stand corrected. I just looked on the Bondtech web site under "Extruders" https://www.bondtech.se/en/product-category/extruders/

    Wonder why they don't list the mini.............

    Edit - I didn't think to look under "Upgrade kits"

    (Note to self - mention this to Martin next time I speak with him).



  • @veti I'm using the thermistor that came with the Prometheus V2, a 100KOhm Semitec 104GT2 NTC thermistor according to the documentation. I haven't changed any thermistor values anywhere - should I have?

    It could be that I'm mistaken and the issue isn't under-extrusion. The sides of the print don't look under-extruded now that I'm looking at the print with fresh eyes. It's just the top and the fact that infill isn't always connecting to the shells. Here are some pictures from a test print. I think the bottom issue is likely because I need to lower my zero a bit, but when I autocalibrate (with paper, no probe) the hotend has a decent grab on the paper. I mean I can still move it back and forth, but there's significant friction, so Idk.

    Regarding the losing my zero after power-offs, doesn't autocalibrate save the settings once you finish the routine?



  • @deckingman I noticed that the Bondtech Mini isn't up anymore, too. I wonder if he discontinued it.



  • Can you post your config file?

    What firmware are you running?

    How fast are you printing that?

    Have you tried printing something larger? The tiny calibration objects aren't the greatest indicators.

    The steps per mm of your extruder is very low. I think you may benefit from running a higher microstepping value on the E axis.

    The first layer definitely looks like it's a bit too far away from the bed. You can baby step down a bit and see if it improves.



  • @layerslayer said in After every power-off, I lose my Z zero.:

    @deckingman I noticed that the Bondtech Mini isn't up anymore, too. I wonder if he discontinued it.

    No it's there. But it's listed under "Upgrade kits" then "Wanahao" which is why I didn't see it under "Extruders" (where I would have expected it to be). Anyway, once I found it I see that the steps per mm are listed as 140 so your setting should be right (providing you are using 16x micro-stepping).



  • So before submitting this comment, I took a closer look at my slicer and realized I hadn't set it up properly. I had always used my laptop for slicing and printing, but this installation is on my desktop now that I can wirelessly send my G-code. Anyway, my nozzle was set to 0.5mm because that was the OEM hotend nozzle size and I had never changed it after installing a while back. That said, I still have a little underextrusion, but it's improved a lot.

    @deckingman Oh you're right. I had only seen the bracket last I looked. But yeah that's it.

    @Phaedrux

    Speeds

    I suppose it's a little fast for the calibration part, but I've run pretty fast in the past without these issues. I'll reprint it right now with slower speeds and a fresh auto-calibration.

    I'm running RepRap Firmware 2.02

    I have printed something larger, although I didn't complete it (Had to leave and didn't want to leave my first run on the Duet while I was out of the house lol). The thing is that I used to get some really good results on this test piece with my Rambo. The Duet is clearly superior, but I'm missing something in my calibration or configuration.

    The steps/mm was perfect on the Rambo and it's 1 step/mm above what is called for by Bondtech for this extruder.

    And here's my config.g:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Mon Mar 11 2019 18:54:24 GMT-0700 (Pacific Daylight Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M665 R132.65 L325 B132.65 H311 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; Put your endstop adjustments here, or let auto calibration find them

    ; Network
    M550 P"Rostock Max" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E141.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z900.00 E1100.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; Set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00 ; Set accelerations (mm/s^2)
    M906 X1200.00 Y1200.00 Z1200.00 E1200.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; Set minimum Z

    ; Endstops
    M574 X2 Y2 Z2 S1 ; Set active low and disabled endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 R132.65 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S105 ; Set temperature limit for heater 0 to 105C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.8 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured



  • Try adding 'M350 E128' below you existing M350 and M92 entries. This will put the extruder on x128 microstepping. The duet will auto calculate the new steps per mm, so don't change those. See if that helps with extrusion.

    Having the nozzle size set lower could definitely be a factor.

    Your speeds looks reasonable.


  • administrators

    @layerslayer said in After every power-off, I lose my Z zero.:

    Every time I turn my printer on, I have to run another auto-calibration (the old school paper way) because otherwise the prints begin a little over 15mm above the bed.

    Have you solved this issue yet? If not then see the second post in this thread.



  • @dc42 If you mean the bit about saving the auto-calibration after running it, I haven't had a chance to try and figure that out yet. It always worked after the calibration so I assumed the values had already been saved, but I guess maybe not. I'll look into it when I get a chance tonight. Thanks!



  • there is a section about saving in the documentation about delta calibration.
    https://duet3d.dozuki.com/Wiki/Calibrating_a_delta_printer



  • @veti Thanks, I was actually just browsing that page on my phone. Somehow I overlooked the part about saving it with those commands when I first went through it. I don't have access to my printer right now, but I have to assume that's why I'm having the issue. Now I just have to do some tuning. I'll tentatively call this one resolved.

    Thanks for all the help, everyone.



  • if you looking for a cheap easy alternative to leveling your delta search aliexpress for
    Automatic Leveling Module Film Pressure Probe
    can be bought for around 2 euro.
    you just put it on the nozzle for the leveling


Log in to reply