Troubleshooting connection issues with a Maestro



  • I'm having trouble connecting to my new Maestro over serial.

    With everything unplugged but the usb cable and sd card, the 5V+, 3.3v, USB, and DIAG LEDs come on. The device appears as /dev/tty.usbmodem1421, but when I try to connect with the screen command, the Arduino serial monitor, or Pronterface, I get no response from the device.

    I've verified that the SD card is uncorrupted. I've also tried attaching it to my network via ethernet, and wiring it to my power supply. The appropriate LEDs come on, but still no response over serial.

    Any advice? I'm using a Mac if that's relevant.



  • whats the device name that is being registered. check dmesg.



  • I borrowed a Windows machine and I'm getting "Bossa port", so it is indeed the firmware. I'll proceed to Fallback #3.

    FYI, it failed to show up on dmesg on my mac, and showed up under System Profiler as "Communication Device: Product ID: 0x6124; Vendor ID: 0x03eb (Atmel Corporation)." I'm not sure what a better process to diagnose firmware faults under OSX would be.



  • That got it working! Thanks for the suggestion.

    BTW: flashing the firmware with BOSSA on a Mac worked without a hitch.