problem with the Mesh?second print start in the air



  • Hi

    when i made the Mesh Compensation alls works fine the first print after Mesh is perfect but the second print start to print in the air,why ?

    i hope you can help me

    thats my config.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Apr 11 2019 17:51:12 GMT+0200 (Mitteleuropäische Sommerzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 P"AM8" ; Set machine name
    M552 S1 ; Enable network
    M587 S"WLAN-110ff5" P"395fff710671ffff90" ; Configure access point. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards X
    M569 P1 S0 ; Drive 1 goes forwards Y
    M569 P2 S1 ; Drive 2 goes backwards Z
    M569 P3 S0 ; Drive 3 goes forwards Extruder
    M569 P4 S1 ; Drive 4 2nd Z-motor - Normally used as Extruder 1

    ; Motor Remapping
    M584 X0 Y1 Z2:4 E3 ; two Z motors connected to driver outputs Z and E1

    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X100.00 Y100.00 Z400.00 E107.16 ; Set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z400.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; Set accelerations (mm/s^2)
    M906 X1400.00 Y1400.00 Z1400.00 E1600.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    ;M671 X-15:205:205 Y105:205:15 P0.5 ; für manual bed levelling
    M671 X-33:220 Y0:0 S0.5 ; leadscrews at left and right of X axis für 2 motoren
    M208 X-33 Y-10 Z0 S1 ; Set axis minima
    M208 X220 Y210 Z200 S0 ; Set axis maxima
    ;M208 X-33:210 Y-10:210 ; X carriage moves from -5 to 205, Y bed goes from 0 to 200

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P5 I1 R0.4 F350 X0 Y0 Z0 ; Set Z probe type to effector and the dive height + speeds
    G31 X0 Y0 Z0.320 P100 ; Set Z probe trigger value, offset and trigger height
    M557 X10:210 Y10:210 S40 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; Set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S275 ; Set temperature limit for heater 1 to 275C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool

    bed.g

    ; bed.g
    ; called to perform automatic bed compensation via G32
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Mon Apr 29 2019 10:01:00 GMT+0200 (Mitteleuropäische Sommerzeit)
    M561 ; clear any bed transform
    ;G29 ; probe the bed and enable compensation

    G28 ; home
    M401 ; deploy Z probe (omit if using bltouch)
    G30 P0 X10 Y110 Z-99999 ; probe near a leadscrew, half way along Y axis
    G30 P1 X210 Y110 Z-99999 S2 ; probe near a leadscrew and calibrate 2 motors
    M402 ; retract probe (omit if using bltouch)
    G1 X110 Y110 ; Go to Bed Center
    G30 ; Probe Center
    G29 ; probe the bed and enable compensation



  • are you loading the mesh file in your homeall.g?



  • I dont have touch The homeall.g

    Do i need to change something in homeall.g ?

    this is my homeall.g

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Apr 11 2019 17:51:12 GMT+0200 (Mitteleuropäische Sommerzeit)
    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-258 Y-235 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-258 Y-235 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X10 Y10 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 S2 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • What firmware version are you using?

    What do you have in your slicer start and end gcode?



  • running a G28 will clear your bed mesh.
    if you want to use the stored heightmap you will need to run G29 S1 after every G28



  • Does g28 clear the mesh? I didn't think it does. But I'm really not sure come to think of it.



  • @phaedrux said in problem with the Mesh?second print start in the air:

    Does g28 clear the mesh? I didn't think it does. But I'm really not sure come to think of it.

    You are right it does not. i just checked.
    I must have confused it with marlin where it does.



  • @lui2004
    nevertheless you need a G29 S1 somewhere to load the mesh after powering up your printer.



  • Hi

    The heightmap ist Stored i can open it in my sd-card.

    Do i need do load G29 S1 every Print i started?if yes i dont have do it



  • @lui2004
    no but it is a good idea to do so.
    it is just a command and does not take up time.



  • Ok i will give it a try

    Or i insert the gcode in my bed.g to load automatic



  • Or put it in your Slicer 'Start GCode', easiest way I find.


  • administrators

    I have G29 S1 at the end of my config.g that way it's loaded every time on startup.



  • so the first print after mesh works perfectly but when i start the second the nozzle is to high

    i have try to send beofor i start the second print G29 S1 but always the nozzle to high

    Firmwarename: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Elektronik: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.6

    i hope you can help to solve it



  • you do home before each print?



  • yes in my slicer is this starting code

    G28 ; home all axes


  • administrators

    @lui2004 what is at the end of your files that the slicer is putting in there?



  • I have only G28 i my starting code nothing else



  • do check with m122 that mesh bed leveling is still active.



  • @veti said in problem with the Mesh?second print start in the air:

    m122

    seems active

    Bed compensation in use: mesh
    Bed probe heights: -0.052 -0.028 0.000 0.000 0.000


Log in to reply