bl touch not working



  • 0_1559150699004_duet config.g may two thousand nineteen.txt The probe deploys and retracts after board power on. However no response to and of the usually code like m280 p7 s10, s90, s160.
    I tried I1 in m588 and m280 lines to invert. nothing. Running 2.02 combined. I checked all 5 wires with .02 ohms each. I don't know how to measure the servo control output, but is I had to guess it's functional, just not being performed. I will try to up load my config.g and deployprobe.g
    Everything worked with 1.21 firmware. 2.01rc didn't work and this new stable 2.02a combined doesn't work either. If I revert back to 1.21 it works. It' a config firmware issue I can't overcome myself.[0_1559150508551_Duet2CombinedFirmware.bin](Uploading 100%)





  • Have you checked your config-override.g? So that the heater pin you've assigned for PWM isn't being derped with?



  • override.g is clean nothing interupting bl touch related command.
    And I believe I've read every piece of doc for the v2.0 bl touch.
    I know it works fine under older firmware. I've read all the changes since my first firmware version. Everything to my understanding is correct. I left 1.21 because that version won't run stable more than 5 hours or so. It was a confirmed bug. All newer version have an issue with something not working. The last 4 releases, leave the probe dead. I haven't had a single print run in a year with all the advertised functions working. It's been confirm 3 times that my machine isn't the issue. It's a config file/ firmware related issue. I know alot, but Im not an engineer of firmware and should need to be. This stuff just doesn't play nice.

    there will never be an actual fix. fix 1 and another 1 takes it's place. why can't we get a version where only bugs are fixed and nothing new added or changed. you know to calm the water and let people catch up stable.



  • now I can no longer connect. dwc opens but says it's not connected. usb doesn't respond. it's a dead sick. this all happened trying to run 2.02 combined. It worked somewhat until I closed my browser. chrome. doesn't work with fire fox either. I removed the sd card and put the old stuff back on the card. still no way to communicate.



  • What board is this? Wifi? Maestro?

    What commands do you have in deploy probe and retract probe macros?

    In your config you have two different G31 lines. Which is correct?

    You also have M574 Z0 which would mean no endstop at all.

    Your Z probe and endstop configuration should look something more like this:

    ; Endstops
    M574 X1 Y1 S1 ; X and Y endstops
    M574 Z1 S2 ; z probe to low end
    M558 P9 H5 F100 T2000 ; BLTouch probe type
    G31 X-52 Y50 Z.9 P25 ; Probe offsets
    M557 X52:300 Y60:335 S40 ; Define mesh grid
    M307 H7 A-1 C-1 D-1      ;disable heater 7 to free up for servo signal for BLTouch
    

    Assuming you have a DuetWifi, and you are connected to heater pin 7 for servo control as your config file suggests, your deploy and retract macros should be

    ;Retract probe
    M280 P7 S90 I1
    
    ;Deploy probe
    M280 P7 S10 I1
    

  • administrators

    @phaedrux said in bl touch not working:

    You also have M574 Z0 which would mean no endstop at all.

    That's correct if the BLTouch is being used to home Z.


  • administrators

    @sir-printsalot said in bl touch not working:

    override.g is clean nothing interupting bl touch related command.

    The particular issue to watch for is config-override.g containing a M307 H7 line that re-enables it as a heater, which will prevent the M280 commands using it.



  • I removed config override and commented out m501 in config g for testing. no difference. and its an Ethernet with static ip and cat 6e tested with through put 897 mbps using Ethernet tester. Board wont connect any way I try. It's not a network issue, seeing as I upgraded firmware than close dwc it refused to connect again. I imported the combined firmware 2.02a plus the ip4e file listed and the dwc was instructed as combined. I received status update showing the firmware was correctly installed. However the dwc version did not reflect a change. I did hit the applied setting tab anyway. no luck. I'm stuck.



  • I think your DWC files may be out of date and will need to be manually updated.

    Download this file https://github.com/dc42/RepRapFirmware/releases/download/2.02/DuetWebControl-1.22.6.zip

    And unzip the contents into the /www folder on the SD card so that the contents of /www look like this:

    0_1559264418361_03-Commissioning-03-www.png



  • This is what I got 0_1559300949515_config.g 0_1559300965861_deployprobe.g 0_1559300977009_retractact probe.txt

    Ok so sd card copy of dwc worked to reconnect. Thanks much for that help! Now back to the probe issue. As a precaution I ordered a brand new bl touch v3.01 for the manufactures site. It's installed with factory wire and connectors pre made. With the files listed here it does not deploy,retract,reset,or self test. It does deploy and retract 2 cycles rapidly when board pwrs on. however through gcode nothing. m401 m280 p7 s10,90,120,160 i1 codes show up green fielded in gcode console lines but are unresponsive. And again it works with the older firmware and config.g. however longer prints fail because of so bug unknown to me. So my question is, have I made the correct alterations to these files? and if so why do these probes not work with this firmware version. again duet Ethernet, both bl touch v2.0 and v3.01 tested. and is the 2.02a combined firmware the correct version for second gen Ethernet board?


  • administrators

    Looking at your config.g file, I think you have a DueX5 connected, so I presume you have connected the BLTouch to the PWM_5 connector on the DueX5. Is that correct? If so, you need to remove the i1 parameter from the M280 commands (in deployprobe.g, retractprobe.g and anywhere else that you use M280 to command the BLTouch).



  • ok what was the i1 command? single inversion I guess? How does that relate to the expansion header?



  • ok that cleared it up. I still can't explain how it worked that way under older firmware? I'd like to say who care it works now, but finding a more true understanding is the only recipe for success with this stuff anymore. Thanks Phaedrux and dc42 for you efforts, they paid off. If you ever need any uccnc or deskproto cam knowledge I'm your guy! I'm a mechanism at my local power plant, but code understanding is still not my strong suit. Thanks!


  • administrators

    @sir-printsalot said in bl touch not working:

    ok what was the i1 command? single inversion I guess? How does that relate to the expansion header?

    The heater signals on the expansion header are active low - the reason is that the MCU enables pullup resistors on all its outputs at power up, and we didn't want that to turn the heaters on. So if you connect bltouch to the expansion header, you need i1. The DueX has a gate and buffer that inverts the signal to provide an active high signal to drive the heater mosfet and increase it to 5V, and that is the same signal provided on the PWM headers. So when connecting a bltouch to one of those PWM headers, you don't need i1. See https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe?revisionid=HEAD#Section_Software_setup_Duet_2_WiFi_Ethernet.



  • Hello again, Ok I got the bl touch working by removing the I1 from m280. However homing machine probe deploys turns blue like it show but dont stop when triggered. the probe pin draws up on contact, but firmware isn't stopping movement. machine properties indicates z not stopped before homing, and after probe contact end stop hit. its just not stoping and setting zero0_1559522906537_homeall.txt 0_1559522913353_config.g new.txt



  • M401
    G30                         ;lower probe set height
    M402
    

    Remove the M401 and M402. The G30 will take care of deploying and retracting the pin as needed.

    Have you gone through this process of testing the probe?
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe

    Can you supply a photo of how the probe is wired? We need to verify which pins you are using and that everything is connected as expected. If the probe isn't stopping movement it might indicate the signal wire isn't actually connected due to a bad crimp or broken wire.



  • I removed the m401 and 402 from homeall.g and homez. I used the factor 1 meter cable that comes with the new v3.0 bl touch. It's a 2 pin yeelow orange and black mounted at the heater 7 connector on my duex 5 expansion board. Then the 2 pin white and black sensor connectotr is mounted to the duet ethernet board probe in connector. looking at the board the top 2 of the 4 probe pins with ground being the top most pin. I have had the bl touch v2.0 for a year, but bought the newset version to rule out a bad probe. I used the supplied cables. I also ran them and all end stop cable in copper shielded cable covers with kapton sleeve . emi shielding. extremely low noise over senor wiring. And in machine properties I see z endstop state change when I touch probe pin during sensor testing. It's just not stopping or reflecting the position change. I had this happen a years ago with 2.00 rcos but forget what the fix was in config.



  • should there be a m564 s1 command line in homing files involving probe during intended triggering of probe or does the g30 and g31 cover the stop at switch event part?




 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.