Duet Ethernet with 24v fan



  • I have almost set everything up now, all I am unable to sort is the print cooling fan, the heat sink fan I have wired into the continuously powered fan pins and is working fine. However the print cooling fan I have is a 24v fan and I have it wired too fan0, I assumed I would be able to control it via these pins but I am new to the duet board, any help would be great




  • administrators

    Yes, the print cooling fan is best connected to the Fan0 output. Make sure you get the red and black wires the right way round.



  • @dc42 the wiring is 100% correct, what is the output voltage for those pins?, I am using a 24v fan. Also how do I assign the fan to the tool, I believe I have it assigned already but I am unsure as I am new to duet control boards



  • @deckingman what info do you require?



  • @bewaren said in Duet Ethernet with 24v fan:

    @deckingman what info do you require?

    What is the actual problem ? Saying "all I am unable to sort is the print cooling fan" doesn't actually tell me much.

    Are you having difficulty wiring it up? Are you having difficulty configuring it? Have you tried sending any commands to control it via the web console? If so, what commands have you sent and what happened when you sent them? Does all of that work but when you print something then fan does nor work as you expect? If not, what does happen?

    In a nutshell, can you provide more information as per the link I supplied.



  • @deckingman the fan is wired up correctly, I am unable to control it at all, I am unsure if its because I haven't got it allocated to the correct tool, or if a 24v fan can be powered via the fan0 pins.



  • @bewaren said in Duet Ethernet with 24v fan:

    @deckingman the fan is wired up correctly, I am unable to control it at all, I am unsure if its because I haven't got it allocated to the correct tool, or if a 24v fan can be powered via the fan0 pins.

    If it's a 24 v fan AND if your PSU is 24 V (you haven't told us) AND you have wired it correctly, AND that fan will work with pwm AND/ OR you have configure an appropriate PWM value AND you have disabled thermostatic mode AND you use the right command, THEN it should work.

    So, last time of asking. What commands have you tried? How have you got it configured?

    i.e. if you post your configuration file, then one of us will be able to help you. Otherwise we can only make guesses.



  • I am unsure as to the commands I need to entre to configure an appropriate PWM value and how to disable thermostatic mode. This is how my config.g file is setup currently.


    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Sun Jul 28 2019 00:07:37 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"My Printer" ; Set machine name
    M551 P"Printer" ; Set password
    M552 P0.0.0.0 S1 ; Enable network and acquire dynamic address via DHCP
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Physical drive 0 goes backwards
    M569 P1 S1 ; Physical drive 1 goes forwards
    M569 P2 S0 ; Physical drive 2 goes backwards
    M569 P3 S0 ; Physical drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E837.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z180.00 E3600.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y-38 Z0 S1 ; Set axis minima
    M208 X200 Y200 Z200 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Set active low and disabled endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:185 Y-23:195 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S80 ; Set temperature limit for heater 0 to 80C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0.1 I0 F500 H T45 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    M501



  • @deckingman The Power Supply is 24v yes, sorry forgot to note that.



  • @bewaren Now we are getting somewhere. That wasn't so hard was it?

    One problem that leaps out at me is this line M106 P0 S0.1 I0 F500 H T45

    P0 is the fan in question. That line sets it to come on thermostatically with a heater but you haven't defined a heater, just an "H" with no number. But for part cooling, we don't want it to run when a heater comes on. We want it to run when we enter an M106 Snn command (which is what the slicer does).

    So delete that line and try this to start with. ....

    M106 P0 S0 I0 F500 H-1

    Edit...........
    BTW - all the information is documented here https://duet3d.dozuki.com/Wiki/Gcode#Section_M106_Fan_On





  • @deckingman Replaced it with that line but I dont seem to be able to control it still, I can now see fan0 on the machine control tab but when turning it on and putting it to any % of power I get no movement still, any ideas?



  • Are you sure the fan is plugged into fan_0 and that the fan actually works?



  • @phaedrux Plugged into the 3rd one along which I assume is fan0 https://gyazo.com/2029dbbba084fd17447f1fcaa5dea01d as the last 2 are always on fans, almost certain the fan works, its brand new but I dont have a 24v power supply spare to test it on.



  • @bewaren how do you have the fan jumper set?

    If you plug the fan into an always on port does it work?



  • Just tested it, doesnt seem too no. Do I need to take off one of the jumpers??



  • @phaedrux Tested the heatsink cooler fan on all connectors and it works on them, so unsure if the issue is the voltage for the print fan



  • See the link above about connecting fans. It Explains.



  • Are you sure the fan is 24v?
    If it doesn't work on the always on port it may be dead.