Help Unable To Connect in Any Way



  • Hello
    I have a Duet Wifi v1.04b that I purchased 5 months ago in preperation to a new printer build. I am using this along with a PanelDue 5. One week ago I connected to it via the usb port and configured the wifi with no issues and everything worked great. On calibration print #4 I noticed the paneldue read 0 degrees celcius for both the hot end and bed. I was not overly concerned with this as I was controlling the printer via wifi. On print # 5 the printer shut down in mid print. I had lost my 3.3v output between pin3 and ps on that controls my mains SSR. I then wired my power supply directly to the Duet and powered thing up. I am unable to connect via wifi, control actions via PanelDue, or connect by USB.
    I then removed all connections and attempted to connect by USB with no luck using YAT, and device manager does not see the Duet ( as duet, bossa or unknown device ). Currently I have the following leds 5v - red, 3.3v - green, usb - red, and diag - red.
    I purchased this unit from Filastruder and was informed that I need an Administrators approval for a warranty return. I am hoping that I am overlooking some corrective action, but I tried everything in the troubleshooting guide except erasing the firmware. I do not feel comfortable doing that without an Administrators instruction to do so.

    Any ideas?



  • Check and see if you have any of the 3.3v or 5v connections shorted to ground, especially the endstops. I had a similar issue and experienced that when i accidentally connected an endstop the wrong way where it shorted the 3.3v to ground.



  • Hello
    All connections are currently disconnected from my Duet, so no chance of that.
    Thanks



  • I have the same issue with a Maestro board, but mu U10 chip also gets incredibly hot within 1-2 seconds of connecting USB power. Check that in case you have the same issue as me [unresolved].



  • Assuming that the board isn't fried (and it may well be) I think a permanently on diag light on the Duet means one of two things; either the firmware has been erased/corrupted, or the reset switch is stuck in so it is stuck in a permanent reset loop (this can happen on Maestro boards, not sure if it can on Duet Wifi). It would be worth plugging in to USB and seeing if it shows up as a bossac port, or indeed jumpering the erase pins, and attempt to flash fresh firmware onto it. See https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware#Section_Fallback_procedure_Num_3
    In the case of a stuck reset switch, manually depress the switch (pull it back out) with a thin tool (fingernail or similar).

    Ian



  • I erased and reloaded the firmware to v2.03 using Bossa. The weird part is that it would not show up until after the erase. After loading firmware I was able to connect via wireless and did not have to reconfigure. Tomorrow I will reinstall the board and check function and if all is well I will change status as solved.

    Could someone explain to me why tthe firmware needed to be reloaded and why I did not have to reconfigure my wifi settings.

    Thanks.



  • Probably the main firmware on the Duet got borked... somehow. Possibly something to do with the original problem, which seems related to PanelDue connectivity. Check connections are firmly seated this time? I'd think the firmware getting corrupted caused the loss of control of the SSR, too.

    You didn't have to reconfigure the Wifi, because the settings are stored on the SD Card, which is unaffected by flashing the firmware! That's one of the good things about storing the settings independently of the firmware. If the controller dies, you don't lose your settings, you just put in a new controller, pop in the SD card, and you're back where you left off.

    Ian


  • administrators

    @droftarts said in Help Unable To Connect in Any Way:

    You didn't have to reconfigure the Wifi, because the settings are stored on the SD Card, which is unaffected by flashing the firmware!

    Actually, the WiFi settings (SSID names and passwords) are stored in flash memory on the WiFi module itself, not on the SD card. It's just the M552 S1 command to enable WiFi and connect to an access point that comes from config.g on the SD card.


  • administrators

    PS - I've heard of the firmware getting corrupted when the +3.3V rail was subjected to a transient, and re-flashing the firmware fixed it. I don't know of anything else that causes the firmware to get corrupted, other than using the Erase jumper or sending M999 PERASE - but both of those should cause the Bossa port to appear, perhaps after a reboot. Of course, flashing a dud firmware file will also cause the board to not work until the firmware is erased and re-flashed.



  • I now have my duet installed and running after the firmware re-load. I still have to tweak a couple of settings and reconnect the power off feature, but other than that all is good.
    Thank you all for all of your help and suggestions.


Log in to reply