Extruder churns extremely fast when printing, but step/mm is correct.



  • I've just setup my machine, and am almost done… but when I start a print my extruder churns wildly, like running many times too fast when printing.

    When I run test files provided with the WiFi it seems to be fine, but not when slized in cura? Also when just extruding.

    I am using 1,75mm filament and have filament setup correctly in Cura.
    I had it set at custom machine reprapfirmware at first.. tried Marlin afterwards, but made no difference...

    It's obviously (seems to me) a slizer issue compatibility thingie with Curan Duet Wifi, but?



  • Its probably an issue of one slicing with absolute extruder values and the other writing with incremental values.



  • I have this same problem using cura and craftware. Is there a specific way to eliminate this in the slicer settings?



  • there is a gcode option in the config ro enable absolute or relative extruder values, they should match between the slicer and the firmware config



  • Seems it was the M82 - Can this be changed in the firmware someone? Just so I don't have to go remember to addd M82 to all the machines in every slizer?



  • @Fickert:

    I have this same problem using cura and craftware. Is there a specific way to eliminate this in the slicer settings?

    Adding M82 in my start gcode seemed to solve it.
    I say "seemed" as my bed didn't bother to go to 0, but that might be totally unrelated… extruder geared down to what seemed the right speed
    https://duet3d.com/wiki/G-code#M82:_Set_extruder_to_absolute_mode



  • The default for Duet is relative extrusion. Most people set their slicers to use relative so that it matches. If you choose to use absolute extrusion instead in your slicer, then you need to "tell" the Duet that's what you are doing by using M82 in your config.g. For info, M83 will switch the Duet back to it's default use of relative extrusion.



  • @deckingman:

    The default for Duet is relative extrusion. Most people set their slicers to use relative so that it matches. If you choose to use absolute extrusion instead in your slicer, then you need to "tell" the Duet that's what you are doing by using M82 in your config.g. For info, M83 will switch the Duet back to it's default use of relative extrusion.

    I havn't set it to do anything. In fact, I choose to use a vanilla install of Cura 🙂
    I've never had this issue with any Marlin or Smoothieware installation.



  • Obviously then Marlin and Smoothieware default to using Absolute extrusion. If you used Slic3R as your slicer, you'd likely find that defaults to using relative. Every slicer and every "brand" of firmware have their own default settings, which is what I meant what I said that you have to "tell" the firmware what you choose to use. (or alternatively "tell" the slicer).


  • administrators

    In fact RepRapFirmware defaults to absolute extrusion. But you can change that to relative by putting M83 in your config.g file.

    Most slicers generate either M82 or M83 in the start gcode to tell the printer what they expect. It sounds as though Cura does not.

    Cura is unique amongst the slicers I am familiar with in that it doesn't support relative extrusion, which is a pity because relative extrusion makes more sense and avoids rounding errors.



  • I'd need to go check the source to confirm this but I think Cura limits the maximum absolute extrusion value emitted by segmenting (resetting back to 0 every now and again as the print progresses). Perhaps they do that to limit the amount of rounding error accumulated.



  • This is amazing news! I love using Craftware but had this issue and had no idea why. Very very nice.



  • @dc42:

    In fact RepRapFirmware defaults to absolute extrusion. ….......................

    Oops, sorry. So all the OP needed to do was omit the M83 he must have had in his config.g which was telling Duet to use relative extrusion.



  • As I thought, Cura does this…

    if (getCurrentExtrudedVolume() > 10000.0) //According to https://github.com/Ultimaker/CuraEngine/issues/14 having more then 21m of extrusion causes inaccuracies. So reset it every 10m, just to be sure.
    {
    resetExtrusionValue();
    }


  • administrators

    Yes most if not all slicers do that when using absolute extrusion to limit the accumulated rounding error.



  • @deckingman:

    @dc42:

    In fact RepRapFirmware defaults to absolute extrusion. ….......................

    Oops, sorry. So all the OP needed to do was omit the M83 he must have had in his config.g which was telling Duet to use relative extrusion.

    This one keyed me in on what to look for, thanks.

    Problem is that the Web Configurator put the M83 in there.. not me, meaning the Duet WiFi by all purposes is doing this by default.

    I'll remove it and see how it behaves.



  • That fixed everything 🙂 (removing the M83 the Web Configurator puts in there)



  • My machine is actually stil overextruding, but only by a factor 2 and not by 10, so something is still amis.


Log in to reply