print off-center



  • Hi,

    when I start a print the object is off-center is on the right of the center

    IMG_20191014_220558 (1).jpg

    In the slicer is on the center

    Captura de ecrã 2019-10-15, às 20.40.30.png

    Why is doing this?

    My config.g

    ; Configuration file for Duet WiFi (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Sat Oct 12 2019 00:13:29 GMT+0100 (Hora de verão da Europa Ocidental)
    
    ; General preferences
    G90                                         ; send absolute coordinates...
    M83                                         ; ...but relative extruder moves
    M550 P"CR10"                                ; set printer name
    
    ; Network
    M551 P"XXXXXX"                            ; set password
    M552 S1                                     ; enable network
    M586 P0 S1                                  ; enable HTTP
    M586 P1 S0                                  ; disable FTP
    M586 P2 S0                                  ; disable Telnet
    
    ; Drives
    M569 P0 S1                                  ; physical drive 0 goes forwards
    M569 P1 S1                                  ; physical drive 1 goes forwards
    M569 P2 S0                                  ; physical drive 2 goes backwards
    M569 P3 S1                                  ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                            ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                     ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E119.88           ; set steps per mm
    M566 X1200.00 Y1200.00 Z12.00 E300.00       ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z6000.00 E30000.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z500.00 E500.00        ; set accelerations (mm/s^2)
    M906 X750 Y750 Z750 E750 I30                ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                     ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                            ; set axis minima
    M208 X300 Y300 Z400 S0                      ; set axis maxima
    
    ; Endstops
    M574 X1 Y1 Z1 S1                            ; set active high endstops
    
    ; Z-Probe
    M558 P0 H2 F120 T6000                       ; disable Z probe but set dive height, probe speed and travel speed
    M557 X0:0 Y0:0 S20                          ; define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                            ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4092 R4700                 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120                                ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700    ; set thermistor + ADC parameters for heater 1
    M143 H1 S285                                ; set temperature limit for heater 1 to 285C
    
    ; Fans
    M106 P0 S0 I0 F500 H1 T45                   ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P1 S1 I0 F500 H1 T45                   ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F0                            ; define tool 0
    G10 P0 X-34 Y8 Z-19.2                       ; set tool 0 axis offsets
    G10 P0 R0 S0                                ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    M501                                        ; load saved parameters from non-volatile memory
    


  • Here's how I set mine up with the origin at the center of the bed.

    The slicer uses coordinates based on the bed dimensions because it can't print off the bed. The printer usually has more addressable space and uses its own coordinates. if you set the origin of the bed and the printer at the center of the bed, you'll never have a problem with off-center prints.



  • 🤔 it homes correctly at zero on the left front corner.

    This is a new installation Duet Wifi + E3d V6 I'm learning how to set up all correcting and I think isn't doing that at the beginning...

    I have tried other boards in the past, all 8 bits and Marlin, and I never had this problem.

    I'll try your way to see the difference, but I think I'm doing something wrong...

    Thanks @mrehorstdmd



  • Can you post a sample gcode file? That will confirm either the gcode file is wrong, or something is moving your origin.

    Ian



  • @hmmatos said in print off-center:

    🤔 it homes correctly at zero on the left front corner.

    This is a new installation Duet Wifi + E3d V6 I'm learning how to set up all correcting and I think isn't doing that at the beginning...

    I have tried other boards in the past, all 8 bits and Marlin, and I never had this problem.

    I'll try your way to see the difference, but I think I'm doing something wrong...

    Thanks @mrehorstdmd

    Is "zero" the left from corner of the bed, or the left front corner of the machine, or both? Many machines can move the extruder beyond the limits of the bed. That's where the off-center print problem originates. The front left corner of the bed may be at machine coordinates like (10, 15), but the slicer considers the left front corner of the bed to be (0,0).



  • @hmmatos said in print off-center:

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X-34 Y8 Z-19.2 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    Your tool offset at X-34 Y8 Z-19.2 may be leading to the printing off-centre. Usually you'd set the tool to X0 Y0 Z0, and offset the probe from this. You don't have any offset on the probe, from what I can see. I'm guessing that the Z offset will make your Z homing file a bit strange, too.

    ; Z-Probe
    M558 P0 H2 F120 T6000 ; disable Z probe but set dive height, probe speed and travel speed
    M557 X0:0 Y0:0 S20 ; define mesh grid

    M557 should be more like M557 X20:280 Y20:280 S20

    Ian



  • @droftarts yes, when I get home I share my gcode.



  • @mrehorstdmd "zero" is the left front corner of the bed



  • @hmmatos Have you set the bed dimensions in the slicer to be the same as you've set in your Duet configuration?



  • @droftarts
    I don't have a Z-Probe yet, that config came from reprapfirmware configtool.

    I don't know where he gets that offset maybe from the configtool too, can I put X0 Y0 Z0 in the file?
    Is it better to comment the Z-probe part?



  • @deckingman yes, 300x300x400



  • @hmmatos said in print off-center:

    @droftarts
    I don't have a Z-Probe yet, that config came from reprapfirmware configtool.

    I don't know where he gets that offset maybe from the configtool too, can I put X0 Y0 Z0 in the file?
    Is it better to comment the Z-probe part?

    Yes, you should set your tool 0 axis offsets to:
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets

    However, I suspect your homez.g file will have an offset, probably of Z19.2 in it. Post your homeall.g and homez.g files here to check. If you don't change this, it will probably drive the nozzle into the bed when you try to print!

    Edit: or you could just change it to:
    G10 P0 X0 Y0 Z-19.2 ; set tool 0 axis offsets

    Ian



  • homeall.g

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Sat Oct 12 2019 00:13:29 GMT+0100 (Hora de verão da Europa Ocidental)
    G91                     ; relative positioning
    G1 Z2 F6000 S2          ; lift Z relative to current position
    G1 S1 X-315 Y-315 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000          ; go back a few mm
    G1 S1 X-315 Y-315 F360  ; move slowly to X and Y axis endstops once more (second pass)
    G1 S1 Z-405 F1800       ; move Z down stopping at the endstop
    G90                     ; absolute positioning
    G92 Z0                  ; set Z to axis minimum (you may want to adjust this)
    
    ; Uncomment the following lines to lift Z after probing
    ;G91                    ; relative positioning
    ;G1 S2 Z2 F100          ; lift Z relative to current position
    ;G90                    ; absolute positioning
    

    homez.g

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.0.4 on Sat Oct 12 2019 00:13:29 GMT+0100 (Hora de verão da Europa Ocidental)
    G91               ; relative positioning
    G1 Z2 F6000 S2    ; lift Z relative to current position
    G1 S1 Z-405 F1800 ; move Z down until the endstop is triggered
    G92 Z0            ; set Z position to axis minimum (you may want to adjust this)
    
    ; Uncomment the following lines to lift Z after probing
    ;G91              ; relative positioning
    ;G1 S2 Z2 F100    ; lift Z relative to current position
    ;G90              ; absolute positioning
    


  • well I put X0 Y0 Z0 in config.g and it solves the problem I still don't know where he gets that tool offset value
    Thanks all for the help


Log in to reply