Heater Faults



  • Some days it seems fine but some days I cant heat the hotend above about 50 deg-C. Every time I am met by the error:

    Heating fault on heater 1, temperature rising much more slowly than the expected 2.1°C/sec

    I can clearly see the temperature going up. The temperature plot is smooth with no sudden dips. I have confirmed the temperatures are correct with an independent thermometer.

    This is currently on an E3D Hermera, tbhough the issue also occurred on my previous V6. I have tried upgrading to a 40w heater, switching from a PT100 to a Thermister, updating firmware, using the terminal block or connector. All connections appear good. The part cooling fan is not turned on and the hotend has a silicon sock covering it.

    I've been troubleshooting this for a while now, If anyone has any insights or suggestions I would love to hear them. Is there a way to relax this 2.1degree/sec limit. The heater seems to be working fine?



  • It's probably caused by a large thermal mass, like a copper or brass block instead of the usual aluminum.

    I had the same problem when I switched to copper block, the PID autotune solved the issue for me:
    https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control



  • also check that they have delivered the correct heater for your voltage
    https://matterhackers.dozuki.com/Wiki/E3D_Heater_Cartridge_Resistance



  • @denke Unfortunately this is still a standard aluminium block but nice idea. I've tried PID tuning both using the auto PID tune and also manually changing parameters (e.g. boosting P)



  • @Veti Yep, correct voltage. Also had the same issue with two other heaters



  • @jottesman said in Heater Faults:

    @denke Unfortunately this is still a standard aluminium block but nice idea. I've tried PID tuning both using the auto PID tune and also manually changing parameters (e.g. boosting P)

    What values did the auto tune provide?



  • @Phaedrux M307 H1 A359.0 C202.1 D4.8 S1.00 V12.4 B0



  • Which version of RRF are you running? I had this exact same problem the other day although in my case it turned out to be an issue with saving and restoring config-override on RRF3/DSF.

    Anyway, you say you've tried other temp sensors but were they all using the same wiring? A connection issue that's not long enough to be seen in DWC can still easily cause the fault to trip.



  • @jottesman

    Might want to check any cooling fans or put some insulation on the block. If you’re up at decent temperature and the heater isn’t powerful enough, it’s possible to have the heater on at full and the hot end actually cooling. A good ceramic insulation piece usually does the trick to solve the problem. A tip though, run auto tune again after you install it. The second parameter should increase by at least 50%.



  • @jottesman said in Heater Faults:

    I have tried upgrading to a 40w heater

    Are you sure it's not a 24v heater cartridge running at 12v? A 40w cartridge that can't keep up without the fan blowing and a block sock on it doesn't sound right.

    Is there a bad fit between the block and either the heater or thermister cartridges?



  • @TLAS No cooling fan onto the block itself, and a silicon sock to cover it 😞 . Might not be as good as a ceramic one but shouldn't be an issue.



  • @Phaedrux Yead double checked too. Like I said this has been the same issue with multiple other heater cartridges



  • @gtj0 I can't remember what version it was before, a few months old, but I've also upgraded to the latest firmware 2.05 to try and fix the issue with no luck.

    Both the different heaters that I have tried and the different temperature sensors all had their own unique wiring however they all attached to heater 1. Could it be an issue with the board? Is there a way of remapping to heater 2?



  • @jottesman
    Also keep in mind if you have a fan in the room or other random factors that might cause increased cooling.

    It’s also possible you could have a thermistor coming loose. I always use the cartridge types as they are the most reliable.


  • administrators

    @jottesman said in Heater Faults:

    @Phaedrux M307 H1 A359.0 C202.1 D4.8 S1.00 V12.4 B0

    If you send M307 H1, does it report those same values?



  • @dc42 Interestingly it did however I assumed you suspected that the values were either not applied / were overwritten.

    It turns out there was already a line in the config file specifying the parameters that occurred later that where I had included the correct ones. This was overriding the values and seems to have been what was causing the issues.

    Needs some testing to be sure but it seems likes its running smoothly again.