Mosquito and blobs at the end of perimeter



  • Hello,

    recently I have upgraded to Mosquito hotend and stuck with the slicer settings. When I tried to print the PA calibration cylinder, it looks like that:
    photo_2020-01-15_22-13-45.jpg

    so, PA in my case is set to 0.63 and now is somewhere around same value. But I also noticed strange blobs at the end of perimeters, so I decided to calibrate retraction value, cylinder was printer with 3mm@100mm/s

    This is the model with retraction from 1mm to 2mm:
    photo_2020-01-15_22-13-45 (2).jpg

    Blobs are huge. This is the model with retraction from 3 to 8mm (I believe, making a bigger retraction is dangerous as it could provoke clogs):
    photo_2020-01-15_22-13-45 (3).jpg

    aaaand I don't see an actual difference! So, what could be a problem?
    PS: Previously I had e3d v6 that didn't have such blobs, all the settings except retraction are same.
    PPS: my config:

    G90                                         ; Send absolute coordinates...
    M83                                         ; ...but relative extruder moves
    M665 L209.000 R91.5 H205 B100.0 X0 Y0 Z0.000                    ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0             ; Put your endstop adjustments here, or let auto calibration find them
    
    ; Drives
    M569 P0 S1                                  ; Drive 0 goes forwards
    M569 P1 S1                                  ; Drive 1 goes forwards
    M569 P2 S1                                  ; Drive 2 goes forwards
    M569 P3 S1                                  ; Drive 3 goes backwards WAS S0
    M350 X16 Y16 Z16 E16 I1                     ; Configure microstepping with interpolation
    M92 X400.00 Y400.00 Z400.00 E404.545;         ; Set steps per mm E was 400
    M566 X1000.00 Y1000.00 Z1000.00 E3000.00    ; Set maximum instantaneous speed changes (mm/min)
    M203 X5000.00 Y5000.00 Z5000.00 E6000.00    ; Set maximum speeds (mm/min) 3000
    M201 X1000.00 Y1000.00 Z1000.00 E2500.00            ; Set accelerations (mm/s^2) 250
    M906 X2000.00 Y2000.00 Z2000.00 E1500.00 I60 ; Set motor currents (mA) and motor idle factor in per cent
    M572 D0:1 S0.64					; pressure advance
    M84 S30                                     ; Set idle timeout
    
    ; Axis Limits
    M208 Z0 S1                                  ; Set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S1                               ; Set active high endstops
    
    ; Z-Probe
    M558 P1 H5 I1 R0.4 F300 T6000                       ; P1, Set Z probe type to unmodulated and the dive height + speeds
    G31 Z-0.18 P600              ; Set Z probe trigger value, offset and trigger height
    M557 R30 S9                                 ; Define mesh grid
    
    ; Heaters
    ; NEW? B3950 
    ; OLD B4138 
    ; E3D V6 thermo B4388
    ; M305 P0 T100000 B4138 R4700                 ; Set thermistor + ADC parameters for heater 0
    M305 P0 B4725 C7.060000e-8
    M143 H0 S120                                ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700                 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280                                ; Set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0.3 I0 F500 H-1                    ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                   ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1 F2                               ; Define tool 0
    G10 P0 X0 Y0 Z0                             ; Set tool 0 axis offsets
    G10 P0 R0 S0                                ; Set initial tool 0 active and standby temperatures to 0C
    
    ; Automatic saving after power loss is not enabled
    
    ; Custom settings are not configured
    M557 R70 S20 ; probe within a radius of 25mm from the centre with a mesh spacing of 20mm
    M579 X1.007014028 Y1.01156531665572173 ; 1.02
    ;M915 X Y S40 F0 R2
    M501
    
    


  • the pics are very unsharp i would say you should calibrate your extruder (over extrusion) and maybe temperature



  • @SIam parts are small so I couldn't focus coreectly, sorry 😞
    but if same extrusion and same plastic worked with different hotend, will the picture actually be different with the new one?

    PS - temperature seems to be okay as the overall surface quality is great



  • if you change the filament ... you have to calibrate the extruder (not every filamentis exactly 1.75 mm not every filament is exactly round etc.)

    if you change the hotend you should calibrate the temperature and the extruder



  • @skayred 0.63 PA is a pretty big number and would indicate that you have a Bowden tube in excess of a metre long. Is this the case?



  • @deckingman nope, it is 400mm. There was another my topic about not-working PA, so it started being really visible only on these high values. But I am pretty sure something is wrong for sure



  • @SIam will try to do but dimensional accuracy at least is okay



  • @skayred Try disabling PA completely - just to see what difference that makes. On a small part with short moves, it's unlikely that you get much of a pressure build up in any case.



  • @deckingman will try tomorrow. What could be an effect? And is 10x10x10mm cube okay or some other shape is better?



  • @skayred Pressure in a hot end builds up over the course of a move. The longer the move, the more pressure will build. Therefore it follows that the effect of pressure will be more noticeable the larger the part.



  • @skayred said in Mosquito and blobs at the end of perimeter:

    is 10x10x10mm cube okay or some other shape is better?

    Try a 100x100x100 cube to get up to speed.



  • So I decide to print 20x20 cube just because 100x100 was too long, here is photos (left one without PA, right one with 0.64):

    photo_2020-01-16_11-49-13 (3).jpg photo_2020-01-16_11-49-13.jpg photo_2020-01-16_11-49-13 (2).jpg

    I don't see so much difference but the right one looks slightly better. And, most importantly, those results are not as bad as ones from the first post. Next step is to calibrate the temperature, it seems that I need to set it a bit lower



  • well, lower temperatures brought no difference. So, I have no idea what else to check/calibrate



  • What slicer are you using?



  • @Phaedrux Simplify3d 4.1



  • Have you seen this guide yet?

    https://duet3d.dozuki.com/Guide/Ender+3+Pro+and+Duet+Maestro+Guide+Part+4:+Calibration/40

    It goes through initial calibration of things like the extruder.

    Your cubes still look a little hot and over extruded, but that could just be due to the fact they are such tiny objects. Try either printing a larger object or print two cubes at once separated on the bed to allow for longer layer times.



  • Since you changed hotends (and nozzle? ) is it possible that the nozzle is not the diameter you think it is? If you extrude into air, what is the diameter of that material and is it consistent?



  • @3DPMicro yep, nozzle is brand new e3d 0.4, extrusion is consistent and of the proper diameter. I started thinking, maybe the problem is not in the hotend but in mechanics? When updating the hotend, I slightly changed the configuration of my carriage sliders, they look more or less stable but could that provoke blobs?



  • @Phaedrux that is actually a good idea, last time I calibrated the extrusion rate when I was using AiO EVO hotend that actually has consistent underextrusion



  • @Phaedrux that is quite curious, extrusion width in vase mode was 0.55-0.6, going to try a complex model with 0.87 extrusion multiplier. My extruder is calibrated to be completely accurate, so how overextrusion is even possible?


Log in to reply