Temp will not exceed 250 degrees



  • I'm installing my new Hermes (well Hemera now) anyway I have set max temp to 285°

    ; Heaters
    M305 P0 T100000 B3950 C0 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S150 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4725 C7.060000e-8 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S285 ; Set temperature limit for heater 1 to 285C
    M307 H1 A394.1 C234.5 D3.0 S1.00 V11.8 B0

    but when I try to go to 285 il will not exceed 250°, what am I missing? in config-override I nothing limiting the Temp.

    Thanks for any help.



  • Don't know anything bou he Hermera but ...
    Have you run a heater calibration ?
    Where did the beta of 4725 come from ? It seems odd.



  • 4725 is the number advised by E3D (I have the same hot end / extruder).

    This is straight off the e3d website (Hemera on RepRap - Section 5

    T parameter: 100 000
    B parameter: 4725
    C parameter: 7.06e-8



  • Ok, that's why I mentioned that I have no direct experience with the Hermera.
    The only other thing I can think of is that your heater is a 24V unit and you have it hooked up to a 12V supply. You could of course have a bad connection someplace too.
    Sorry I can't be of more help!



  • @Synapsis Do you have a print cooling fan on during this?



  • Hi thanks for the replies its a 12V and I use all 12V. I did the M303 my temp was "Auto tune phase 3, peak temperature was 285.8".

    So strange it will get to 285 with M303 but not using the DWC. If I use the drop down menu and select 285 it will not heat up but if I select 250 it will. Very strange.



  • No, not strange if I understand you correctly.
    The peak temperature in auto tuning will be an overshoot of the temperature you specified for tuning. Let's say you specified a temperature of 250 degrees for the tuning step, the Duet switched off the heater at 250 but that temperature kept rising to 285 before starting to drop. That is the peak temperature reading you see.
    You may have the maximum extruder temperature set at 250 and if you tell it to heat to 285 the Duet thinks you don't know what you are talking about and overrides your request.
    I do not know the action of the temperature limits - ie I don't know if it would heat to 250 and then shut down with an error or just not bother to heat up to begin with.


  • Moderator

    @Synapsis said in Temp will not exceed 250 degrees:

    Hi thanks for the replies its a 12V and I use all 12V. I did the M303 my temp was "Auto tune phase 3, peak temperature was 285.8".

    So strange it will get to 285 with M303 but not using the DWC. If I use the drop down menu and select 285 it will not heat up but if I select 250 it will. Very strange.

    Did you tune to 250 or to 285?

    Firmware version?



  • @Phaedrux
    Board: Duet WiFi 1.02 or later
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.05 (2019-12-13b1)
    Duet WiFi Server Version: 1.23

    I tuned to 285° and it turned off at 285.8° in my config i have set limit to 285.
    "M143 H1 S285 ; Set temperature limit for heater 1 to 285C"

    @jens55 no sure but if i set 250 for tuning and it get to 285 before turning of is too much. In my case i set to 285 and it turned off at 285.5 which is good. Not sure but I think when it goes over 15°?? it will turn off?



  • @Synapsis you're tuning to 285 and set you limit to 285? Why the 285 limit? I think it's more normal to set your limit 5-10C above your working temperature?



  • When tuning an overshoot of 5 or more degrees isn't impossible, seen it - got the T shirt.

    I think the more salient point here is why M303 can achieve the temperature but what should be the same command from DWC does not. I can't verify mine as my Hemera is sat on the desk next to me currently.


  • Moderator

    Can you post the tuned values? And can you verify that they are in fact loaded?



  • @Phaedrux
    1/22/2020, 6:33:58 PM Auto tune heater 1 completed in 603 sec
    Use M307 H1 to see the result, or M500 to save the result in config-override.g
    1/22/2020, 6:30:48 PM Auto tune phase 3, peak temperature was 285.8
    1/22/2020, 6:30:44 PM Auto tune phase 2, heater off
    1/22/2020, 6:24:00 PM Auto tune phase 1, heater on
    1/22/2020, 6:23:55 PM M303 H1 S285
    Auto tuning heater 1 using target temperature 285.0°C and PWM 1.00 - do not leave printer unattended
    1/22/2020, 6:15:47 PM Connection established

    in config override i have
    "M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B02"



  • @DocTrucker Using PLA I only use 205° more or less I set 285° just in case I wanted to ever get it hotter.
    This reason I noticed is because I needed to heat tighten the hot end and it said to use 285° for this, if not I doubt I would ever had noticed.



  • @Synapsis fair enough! I was concerned you were tuning at your max temp and running at your max temp. You normally tune at your working temp, but I do understand the use of the tuning in this case to verify.

    It maybe worth selecting T0, setting standby and active temps to 285 with G10 and starting the hotend warming with gcode entry in DWC rather than using the general DWC interface. Just incase there is a peculiarity with DWC.



  • You say that nothing happens when you try to set the temperature to 285 but it works fine at 250 .... try setting the temperature to 280 and see what happens. Could very well be that setting to 285 is too close to the configured maximum.



  • @jens55
    You nailed it started with 260 the 275 then 280 a it got to 280 and was stable put 285 and it would'nt go over 280.
    👍 👍



  • @Synapsis did you then type in M307 H1 to get the results of the tune?



  • @Nuramori no I went to the console to be honest.


Log in to reply