Duet 2 Maestro Ender 5 Plus print speeds won't go above 12mm



  • @droftarts said in Duet 2 Maestro Ender 5 Plus print speeds won't go above 12mm:

    @Walternate you will also need to change the M92 line after, dividing X, Y and Z values by 4, and E by 2. However x64 microstepping won’t stress the Duet. Just change the I0 to I1 in the M350 command.

    Ian

    So I made those changes and the z motor stopped responding all together. I reverted in code and we're back to moving well. I'm not sure what the change may have done. I appreciate your time, I'm going to investigate that more.


  • administrators

    @Walternate said in Duet 2 Maestro Ender 5 Plus print speeds won't go above 12mm:

    @droftarts said in Duet 2 Maestro Ender 5 Plus print speeds won't go above 12mm:

    @Walternate you will also need to change the M92 line after, dividing X, Y and Z values by 4, and E by 2. However x64 microstepping won’t stress the Duet. Just change the I0 to I1 in the M350 command.

    Ian

    So I made those changes and the z motor stopped responding all together. I reverted in code and we're back to moving well. I'm not sure what the change may have done. I appreciate your time, I'm going to investigate that more.

    Please try again, I think you must have made a mistake in making the changes. If you still can't get Z to move, post the config.g file you were using at that point.



  • @Walternate said in Duet 2 Maestro Ender 5 Plus print speeds won't go above 12mm:

    M350 X64 Y64 Z64 E32 I0 ; configure microstepping with interpolation
    M92 X320.00 Y320.00 Z3200.00 E808.41 ; M92 X80.00 Y80.00 Z800.00 E407.53 ; set steps per mm

    try

    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80 Y80 Z800 E404.20 ; M92 X80.00 Y80.00 Z800.00 E407.53 ; set steps per mm

    i was a bit surprised by the 800, but aparently creality is deviation from the norm here. interesting.



  • I also have an Ender 5 Plus that was very recently upgraded to Maestro. For the X, Y and Z, I get the same steps per mm, but on the E, I only have 140 (at 16x microstepping with interpolation, and greatly over extruding, though still calibrating). I am using the stock extruder, with an E3D v6 upgraded to Volcano for the hot-end (with 0.6mm nozzle, and slicer is also configured for that).



  • My Creality CR10 printer has 400 steps/mm for Z
    E should be 100 steps/mm unless you use a geard extruder such as the BMG in which case you use 415

    Note the step value is approximate!!



  • I apologize for the delay, @Veti I am testing those settings out now. Thank you so much for taking the time! @Jacotheron I also appreciate your input, I am testing your suggestion now. @dc42 I did retest and it did not work, however I have new numbers here that I am working with. I will update on my success. Thank you for your time!



  • @veti, success! I am moving just fine with the new numbers. I am having a heck of a time with baby stepping, as my first layer is not printing I think due to the fact that the nozzle is too close. I will update when I figure that out



  • @Walternate, please post your latest working config. I just started configuring Duet 2 Ethernet on my Ender 5 Plus.



  • Hi All,

    I'm still a noob when it comes to configs of printers. I'm learning bit by bit. But, I've hit a bit of a wall with my Ender 5 Pro...

    I just replaced the stock 1.1.5 creality board with a Duet 2 Maestro. But, right away I noticed that the motors started making noises I hadn't heard of the stock printer. I've tried downloading and using config files others have been kind enough to post online for their Ender 5's. But, I still get the sound. I really don't know where to go next with this.

    Any help would be very much appreciated!


  • Moderator

    @Damien Please start a new thread for your issue. It's not the same as this thread. Consult the guide for posting here https://forum.duet3d.com/topic/5909/guide-for-posting-requests-for-help and provide the information needed for others to help you.

    Ian


Log in to reply