Heater failures, only upon restart.



  • Railcore II ZLT
    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later + DueX5
    Firmware Version: 2.03 (2019-06-13b2)
    WiFi Server Version: 1.23
    Web Interface Version: 1.22.6

    I am getting an issue where when I turn the machine on, there is always a heater fault on the hotend. I run the autotuning (M303 H1 S245), then save with m500 after it completes without error. The printer will then print without issue.... Until I turn it off. Then, I restart the machine, and the hotend faults again in the exact same way... WTF am I missing here?

    I do not know if it is related as I haven't had time to track it down... but I am also having an issue with layer adhesion, despite the PLA becoming nice and gooey when i ramp up the temps.

    Thanks for your assistance in advance.

    config-override.txt config-user.txt config.txt Bed-Prep PLA.txt



  • I don't know if it is related but I have experienced (and mentioned) something similar. It appears that a flag is set for some errors and not cleared properly. If I recall correctly, the only way it is cleared is to power cycle the printer. I have gotten used to just dismissing the error and it will just happily carry on.
    You use the words 'turn the machine on' .... if this is from a power off state then the issue I am encountering is likely different.



  • Yes, it is from a power off state or an M999 command. I use m562 to clear the fault and run the auto-tune feature. It just fails every time i turn the machine on until i run auto-tune.



  • i hope i have nothing overseen but i miss in your config M501 (which will load the config override file with your pid data)



  • @SIam M501 is in my config.g. Is this the proper file? Now that you say that, it IS NOT at the bottom of the page, it's somewhere halfway up.

    I moved it to the bottom of config.g and I am not going to test it to see if it works.



  • @SIam Looks like that did it. Moving the m501 command to the bottom of the page worked. Order of operations matters! 😜

    Thanks! 😄


  • Moderator

    @CCS did it happen to be above the default heater values?



  • @Phaedrux No. well below thresholds. The issue has been solved and noted in my above statement. Thanks