M21: Cannot initialise SD card 0: Card is unusable<LF>ok<LF>



  • I've just received my Duet 2 Wifi board and have been working on this all day and come to find out after rewiring the whole machine that when I run M21 it tells me "M21: Cannot initialize SD card 0: Card is unusable<LF>ok<LF>" and now I'm stuck cause when I try to go to the web interface it tells me "Your Duet rejected the HTTP request: page not found Check that the SD card is mounted and has the correct files in its /www folder". So basically I can do nothing? I dunno why it needs the SD card to use the web interface in the first place I'd think all that would be part of the firmware on the board. Is there anything I can do OTHER then asking for a new board cause that's gonna take forever.


  • Moderator

    The web interface is just a website and it lives on the SD card.

    How is the SD card formatted?

    I would suggest copying the contents of the card as a backup, and using this tool to format the card. https://www.sdcard.org/downloads/formatter/

    Then replace the folders on the card and try again.

    If it still doesn't work, try a new SD card.

    If it still doesn't work, post a close up picture of the SD card slot to show the solder points.



  • Ok I tryed the ad card formatted on original sd card and 2 other and still getting that and it even tells me that there isn't even a sd card in there when there is. Here's a close up if the ad reader on board you asked for. alt text q


  • administrators

    If it's a genuine UK-manufactured Duet, please contact your supplier and ask for a replacement under warranty, which I approve. https://www.duet3d.com/warranty


Log in to reply