Extruder motors no longer working



  • I have a toolchanger running a duet 3 connected to a raspberry pi and 1 expansion board.
    I have updated to 3.01 RC2 on both the main board and the expansion board.
    Neither of my extruder motors are working any more.
    config.g
    I can select a tool and it picks up correctly, as well as set the temperature.
    Once stabilised, when using the extrusion control to extrude material, the display shows that the correct driver has advanced the material but no extrusion takes place.
    Both tools worked previously



  • @jay_s_uk After you updated the firmware, did you run config.g again?



  • @deckingman

    yes, I've ran emergency stop.
    I've also powered the machine down and backup again.



  • I've tried swapping one of the extruder motors to the main board in place of the motor driving my locking pin.
    It moves when requested so I know it isn't the wiring for the extruder.
    I also tried swapping it to a different motor output on the expansion board but that didn't work.
    All the heaters and fans for the hot ends are being driven from the expansion board and they work correctly.
    I'm stumped if I'm honest



  • @jay_s_uk Yes, I think this is one for DC. I have to confess that I haven't yet updated my printer from an earlier beta so although I run 6 extruders on 2 expansion boards, my situation isn't relevant to yours. Also, I still haven't hooked my RPi so I'm still running stand alone.



  • Is it possible this line might be affecting it?

    M584 X0.0 Y0.1 Z0.3:0.4:0.5 E1.0:1.1 U0.2 P3

    From what I understand RRF starts counting extruders after the movement axis. Maybe defining U axis later in this command is throwing that off?



  • @blt3dp

    Moving the U command before E made no difference


  • Moderator

    @jay_s_uk try the extruder on a separate M584 line of their own. Early RRF version couldn’t parse multiple multiple-axis definitions in one line.

    Ian



  • @droftarts

    No change I'm afraid

    Its not even energising the motor



  • Any thoughts on this @dc42 ?



  • Small update.

    I assigned drive 1.0 to axis 'V' rather than an extruder. At this point I powered down the machine to ensure the expansion board fully got the config.
    I sent M564 H0 to ensure I could move an axis without homing.
    X, Y and Z move fine.
    Axis V does not. It also doesn't energise.

    No further forward but I'd just thought I'd add that I've tried it



  • I've now also tried this in standalone mode to ensure that the raspberry pi is not causing issues.

    I am running the following
    "T0 P0" - this selects a tool without doing any moves to actually pick it up
    "M302 P1" - allow cold extrusion
    Extrude filament
    M122 B1 shows that a move was scheduled and then when its "finished" it shows completed

    Connected to duet by usb cable and using pronterface to control it.
    I am doing this after the machine is booted. No other movement is taking place before hand. Also, all heaters are cold.

    Still can't get any drivers on the expansion board to work.
    Anyone got any ideas?



  • I've created the most basic config I can think of.
    Setting it to use a driver on the main board works,
    Setting it to use a driver on the expansion board doesn't

    M584 X1.2
    M569 P1.2 S1													; Drive 6 direction | Tool 2
    M350 X16 I1             						; Configure microstepping with interpolation
    M92 X160    							; Set steps per mm
    M566 X1400     							; Set maximum instantaneous speed changes (mm/min)
    M203 X25000 					; Set maximum speeds (mm/min)
    M201 X1300 						; Set accelerations (mm/s^2)
    M906 X1300  					; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                 						; Set idle timeout
    

    Think its time to warranty the board.


  • Moderator

    @jay_s_uk Have you tried reverting to the last known working firmware version?
    @dc42 can you look at this thread?

    Ian



  • @jay_s_uk said in Extruder motors no longer working:

    have updated to 3.01 RC2 on both the main board and the expansion board.
    Neither of my extruder motors are working any more.

    Revert to 3.0 release and see what happens.



  • Update

    Reverting the main board to 3.0 and the 3HC to 3.0 RC2 (Most recent previous release I could find) allows the use of the drivers.

    I then applied 3.01-RC2 to the main board (with 3.0 RC2 still applied to the expansion board) and that also worked.

    As soon as I apply 3.01-RC2 to the expansion board, all the drivers no longer work so it looks like there is a bug somewhere.

    @dc42 would there be any compatibility issues running 3.01-RC2 on the main board and 3.0-RC2 on the expansion board until this gets sorted out?



  • @jay_s_uk Apolgies in advance if this seems like a daft question but we all make mistakes and forget things from time to time. So did you run M997 B1 after loading the expansion board firmware?



  • @deckingman
    Yes. Each time I ran M997 B1 and checked using M115 B1 that the firmware was loaded.

    For me, 3.01-RC2 does not work on my expansion board


  • administrators

    Thanks for your report. I know what is going wrong and I will have a new build of the expansion board firmware to fix it later today.



  • Oh good, at least it's not just me


  • administrators

    Fixed in latest build of the expansion board firmware at https://www.dropbox.com/sh/3azy1njy3ayjsbp/AACquxr2m00eV568RZg5QG5wa?dl=0.



  • @dc42
    That fixed it


Log in to reply