Piezo probe Value shows P1000 when not touching



  • I recently updated the firmware from 3.01 to the latest one and now no matter what I do to invert using i1 or default i0, the P= 1000. When I press the disc, it will show P= 0 and go back to 1000 when I let go. I though maybe the disc was bad so I replaced it and still does the same thing. It worked fine before the update but honestly, I can't be sure if it was the update that messed it up. I have messed with the 2 resistors on the module and it doesn't seem to help either.

    The signal pin is current connected to the mod pin on the zprobe connector. The zprobe in pin is unused.

    M122
    === Diagnostics === RepRapFirmware for Duet 2 WiFi/Ethernet version 3.01-RC3 running on Duet WiFi 1.02 or later + DueX5 Board ID:

    Z-Probe
    M558 P5 I1 R0.4 C"zprobe.mod" H5 F1200 T10000 ; set Z probe type to effector and the dive height + speeds
    G31 P500 X0 Y0 Z0 ; set Z probe trigger value, offset and trigger height

    M119
    Endstops - X: not stopped, Y: not stopped, Z: not stopped, Z probe: not stopped



  • The i parameter is no longer supported in M558.

    I'm using the Orion piezo:
    M558 P8 C"^!ZPROBE.IN" R0.4 H2 F350 T5000 A5 S0.01

    In C"^!ZPROBE.IN" the "^" enables the onboard pullup and the "!" inverts the input.



  • @insertnamehere feel like an idiot now but what is a pullup? I keep reading about it but I have no clue what it is or what it does.


  • Moderator



  • No no, it's a valid question.

    The simple answer is that a pullup resistor makes sure the input voltages go to known levels and don't "float" between logic high and low.

    If the input circuit from the Piezo requires a pullup resistor on the output and you don't provide it it may not switch reliably or not switch at all. You could see it go high and stay high all the time.

    First, try not using a pullup and if the input is not working reliably, turn the pullup on. I'm using a Precision Piezo in digital mode and I need the pullup enabled.



  • I never had any issues on my Duet2 with the Orion directly connected with no pullups. You should connect the signal out of the Orion to the signal in on the probe connector, not mod. Then use P8 which is the unfiltered (faster) version of P5.

    Which piezo model do you have?



  • @gtj0 i have the universal kit.



  • @tekstyle The new one with both analog and digital outputs? Have you changed your M558 command as @insertnamehere suggested?



  • If it helps I have the universal board v2.85. Here are the analogue and digital settings that work with my Duet Wifi. Use one or the other. I use the analogue mode to avoid having to fiddle with the tiny pots on the PCB. You also need to connect to the correct pin (A or D) on the PCB according to which mode you use.

    
    ; Analogue Mode
    M558 P1 C"^!zprobe.in" R0.5 H3 F360 T9000 A5 S0.03       ; P1 = Analogue mode
    G31 X0 Y0 Z-0.1 P530                                     ; X, Y, Z offsets, P530 = trigger threshold
    
    ; Digital Mode
    M558 P8 C"^!zprobe.in" R0.5 H3 F240 T9000 A5 S0.03      ; P8 = Digital mode (unfiltered)
    G31 X0 Y0 Z-0.1 P100                                    ; X, Y, Z offsets, P100 = debounce interval
    
    

    You will need to adjust the Pxxx in the G31 to suit your printer if using analogue mode. A good starting point is 5 above the value in DWC when not triggered.

    Also be aware that when using analogue mode the probe will home at 1/3 speed. @dc42 has said this will change at some point in a future RRF release so piezo probes home at full speed.


Log in to reply