slicer setting g-code type



  • i am new to duet 2 wifi and have doubts about what to use in my slicer should i use marlin or reprap g-code type


  • Moderator

    Use reprap gcode flavour.



  • thank you



  • now it has started to make a sound as i switch from marlin to reprap


  • Moderator

    A good sound I hope.



  • a little pee noises that were not there before which happens every second from the extruder motor and think it is not good sound but I do not know




  • Moderator

    that is an interesting sound, but without any other info to go on I'm not sure what to say.

    Add some details for us please: https://forum.duet3d.com/topic/5909/guide-for-posting-requests-for-help





  • 3d printer ender 3 pro

    and this is the whole file for confik.g

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Mon Jan 07 2019 23:53:31 GMT+0200 (Eastern European Standard Time)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Network
    M550 PEnder3 ; Set machine name
    M552 S1 ; Enable network

    ;M587 S"FiberSwag_IoT" P"SonosErGud123" I10.0.1.9 J10.0.1.1 K255.255.255.0 ; Configure access point and IP addresses. You can delete this line once connected
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes backwards
    M569 P1 S0 ; Drive 1 goes backwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y79.892 Z400.00 E94.50 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E300.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z300.00 E18000.00 ; Set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z20.00 E250.00 ; Set accelerations (mm/s^2)
    M906 X600.00 Y600.00 Z600.00 E800.00 I50 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S60 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X235 Y235 Z250 S0 ; Set axis maxima

    ; Endstops
    ; M574 X1 Y1 S1 ; Set active high endstops
    M574 X1 Y1 S1 ; X home to min. Y home to max. Normally Closed limit switches.

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M307 H3 A-1 C-1 D-1 ; Disable heater on PWM channel for BLTouch
    M558 P9 H5 F120 T6000 X0 Y0 Z1 ; Set Z probe type to bltouch and the dive height + speeds
    G31 P25 X48 Y-2 Z1.19 ; Set Z probe trigger value, offset and trigger height
    M557 X50:230 Y50:230 S10 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S255 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S255 I0 F500 H1 T45 ; Set fan 1 to turn on full speed when Hotend reaches 45
    M106 P2 T45:65 H100:101:102 ; Set fan 2 to turn on when MCU reaches 45 and reach full speed when MCU reaches 65 or any TMC2660 report over-temperature

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured

    ; Miscellaneous
    T0 ; Select first tool




  • Moderator

    Your first gcode posted (blot.gcode) was using marlin flavour and included some speed commands in the start gcode. The second one you posted is in Reprap flavor, which is correct, and those commands are no longer present.

    Other than the noise, what is actually happening?
    When does the noise occur? During a print? Just sitting there?

    Your config file looks ok.



  • @Phaedrux it's just the sound.
    As far as I know


  • Moderator

    Does it extrude properly?



  • @Phaedrux

    the extrusion properly I think. trying to get 3d printer running properly and try me to get it printed in good quality, but you can see that the z axis is doing poor quality I just found out. so I can't say if it extrudes properly. but try to fix it

    but thanks for the help


Log in to reply