Ender 5 Duet Wifi 2 and BLTouch 3.1



  • Ok so I am new to to the BLTouch and the Ender 5. I have currently updated it to a Duet wifi 2 and a meanwell PSU. I got the printer to work last night fine with manual leveling and end stop switches. I have been using the RRF Config tool to get the BLTouch to work with little success.

    Currently the probe will extend but not retrack after powering up. It will not trigger as an endstop ( I unplugged the original) for homing.
    Config.g

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Mon Jul 06 2020 13:33:30 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Ender 5" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I0 ; configure microstepping without interpolation
    M92 X80.00 Y80.00 Z400.00 E96.15 ; set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z600.00 E600.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z200.00 E4000.00 ; set accelerations (mm/s^2)
    M906 X850 Y800 Z700 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X220 Y220 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"duex.pwm1" ; create servo pin 0 for BLTouch
    M558 P9 C"!zprobe.in+zprobe.mod" H5 F0 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P0 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:195 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S1 H0 T45 ; set fan 0 value. Thermostatic control is turned on
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0 T45 ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan1" Q500 ; create fan 2 on pin fan1 and set its frequency
    M106 P2 S0.3 H-1 ; set fan 2 value. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    homeall

    ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Mon Jul 06 2020 13:33:32 GMT-0500 (Central Daylight Time)
    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G1 H1 X-225 Y-225 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y5 F6000 ; go back a few mm
    G1 H1 X-225 Y-225 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X15 Y15 F6000 ; go to first bed probe point and home Z
    G30 ; home Z by probing the bed

    ; Uncomment the following lines to lift Z after probing
    ;G91 ; relative positioning
    ;G1 Z5 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning

    deploy and retract

    M280 P0 S10
    M280 P0 S90


  • Moderator

    @TheBiologist said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    ; Z-Probe
    M950 S0 C"duex.pwm1" ; create servo pin 0 for BLTouch
    M558 P9 C"!zprobe.in+zprobe.mod" H5 F0 T6000 ; set Z probe type to bltouch and the dive height + speeds

    How do you have the BLtouch connected? Do you have a duex?

    Depending on where you have the servo control wire connected, you may need to change the pin name used by M950. I think there is a bug in the configurator that is showing the wrong pin choices for the PWM servo control.

    If you're connected to expansion header 3 like shown in the connecting a bltouch doc it should be like this:
    919bae1c-fd51-4e72-ad83-f3a9f8d2c85d-image.png

    ; Z-Probe
    M950 S0 C"exp.heater3" ; create servo pin 0 for BLTouch
    M558 P9 C"!zprobe.in" H5 F0 T6000 ; set Z probe type to bltouch and the dive height + speeds
    


  • @Phaedrux said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    M558 P9 C"!zprobe.in" H5 F0 T6000 ; set Z probe type to bltouch and the dive height + speeds

    M558 P9 C"^zprobe.in" H5 F0 T6000


  • Moderator

    @DIY-O-Sphere Good eye!



  • Awesome I will try that. Thanks for the quick reply



  • @Phaedrux yes I have it wired like in the photo. I made the suggested changes but bltouch still does not power cycle instead is flashing red at a slow steady rate. When I tried to rest the bltouch i get Error: M280: Invalid servo index 0 in M280 command.


  • Moderator

    Please send M115 to verify what firmware version you are actually using.
    Then send M98 P"config.g" in the console and report the results.



  • @Phaedrux

    m115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.02(RTOS) ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2018-12-24b1

    M98 P"config.g"
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Warning: M950 command is not supported
    Warning: M308 command is not supported
    Warning: M950 command is not supported



  • @TheBiologist said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    FIRMWARE_VERSION: 2.02

    Your config is for RRF3, but your firmware is RRF2
    You have to update the firmware.
    First to 3.0 after that go to 3.1.1



  • @DIY-O-Sphere ok I have now successfully updated to 3.1.1. I am still not getting the bltouch to work. It still will not self test on power up. It drops the pin and then starts blinking red light. I have checked the wires and all connections are good. This is a legit BLTouch with their wiring.



  • @TheBiologist said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    M98 P"config.g"

    M98 P"config.g"
    

    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C
    Error: Pin 'fan1' is not free
    Error: Fan number 2 not found

    m115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 3.1.1 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2020-05-19b2



  • Fixed the fan error. Not sure what to do with the heater error or that the z probe is reading 1000 like it is being triggered.


  • Moderator

    @TheBiologist said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    It still will not self test on power up. It drops the pin and then starts blinking red light. I have checked the wires and all connections are good.

    What happens if you connect only 5v and ground? That should cause it to self test. If it's still failing on self test check the pin. You can remove the grub screw on the top of the body and remove the pin. Maybe it's bent or dirty.

    If it's still failing self test try and send the error reset command and then try and deploy and retract again.

    What do you have in your config.g and deploy and retract now?


  • Moderator

    @TheBiologist said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    Warning: Heater 0 appears to be over-powered. If left on at full power, its temperature is predicted to reach 365C

    This is just telling you what it thinks your bed temp could reach if it fails on. To get rid of the warning choose a lower powered heater. Otherwise, just be aware. Don't leave it unattended. Have a fire extinguisher handy. Smoke alarm. Thermal cut out fuse.


  • Moderator

    @TheBiologist said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    the z probe is reading 1000 like it is being triggered.

    Did you change your ! to a ^ in the M558 as pointed out by @DIY-O-Sphere ?

    If you did change that and it's still showing 1000 all the time, that could mean the probe is damaged, or there is a problem with your white signal wire.



  • @Phaedrux The probe cycles twice and then starts blinking red.

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.3 on Mon Jul 06 2020 13:33:30 GMT-0500 (Central Daylight Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Ender 5" ; set printer name

    ; Network
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; physical drive 0 goes forwards
    M569 P1 S1 ; physical drive 1 goes forwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S1 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping
    M350 X16 Y16 Z16 E16 I0 ; configure microstepping without interpolation
    M92 X80.00 Y80.00 Z400.00 E96.15 ; set steps per mm
    M566 X600.00 Y600.00 Z60.00 E300.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X30000.00 Y30000.00 Z600.00 E600.00 ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z200.00 E4000.00 ; set accelerations (mm/s^2)
    M906 X850 Y800 Z700 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; set axis minima
    M208 X220 Y220 Z300 S0 ; set axis maxima

    ; Endstops
    M574 X1 S1 P"xstop" ; configure active-high endstop for low end on X via pin xstop
    M574 Y1 S1 P"ystop" ; configure active-high endstop for low end on Y via pin ystop
    M574 Z1 S2 ; configure Z-probe endstop for low end on Z

    ; Z-Probe
    M950 S0 C"exp.heater3" ; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H5 F0 T6000 ; set Z probe type to bltouch and the dive height + speeds
    G31 P0 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:195 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 B1 S1.00 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M308 S1 P"e0temp" Y"thermistor" T100000 B4138 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 B0 S1.00 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S1 H0 T45 ; set fan 0 value. Thermostatic control is turned on
    M950 F1 C"fan1" Q500 ; create fan 1 on pin fan1 and set its frequency
    M106 P1 S1 H0 T45 ; set fan 1 value. Thermostatic control is turned on
    M950 F2 C"fan2" Q500 ; create fan 2 on pin fan1 and set its frequency
    M106 P2 S0.3 H-1 ; set fan 2 value. Thermostatic control is turned off

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    Deploy and retract

    M280 P0 S10 ; deploy BLTouch
    M280 P0 S90 ; retract BLTouch



  • @Phaedrux it is just the factory ender 5 bed heater. Is that normal?


  • Moderator

    @TheBiologist said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    G31 P0 X0 Y0 Z2.5 ; set Z probe trigger value, offset and trigger height

    Don't set it to P0. That meas triggered at not triggered. Use G31 P25

    @TheBiologist said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    M558 P9 C"^zprobe.in" H5 F0 T6000 ; set Z probe type to bltouch and the dive height + speeds

    You need a feed rate set too. Use F60.


  • Moderator

    @TheBiologist said in Ender 5 Duet Wifi 2 and BLTouch 3.1:

    @Phaedrux it is just the factory ender 5 bed heater. Is that normal?

    yeah it's not uncommon to see the warning. It's a motorized hot plate with wifi afterall.



  • @Phaedrux Thanks for the help! SO far so good. I will try leveling the bed tomorrow.



  • @Phaedrux So turned on the printer first thing this morning to try and calibrate the bltouch and went right back to the same issues. I am begining to suspect bad wire in the cable so I have ordered another. Not sure what else it could be. It was working just fine last night. Tested it unmounted, turned it off and mounted it, and then turned it back on this morning.


Log in to reply