BLTouch 3.1v not lighting up with Duet 2 wifi



  • I have been working on a Printer build and got it to work.... more or less. I would really like to use a BLTouch with it but the touch is not lighting up at all. When I configured it, I followed the guide here
    [https://duet3d.dozuki.com/Wiki/Connecting_a_Z_probe#Section_Duet_2_WiFi_Ethernet_without_a_Duex_2_or_Duex_5_expansion_board].
    I wired it the exact way and had used a different cords (Long and Short) and different touchs. When I configured using the online reprap configuration tool, since I am using the 8th pin for Heater 3, I set it to use the E2 channel for the servo control channel.
    Also any of the prob commands return as successful.

    If anyone has more info, please Let me know. Thank you all.


  • Moderator

    Post your config.g, your homeall, your deploy and retract files, and a photo showing your wiring.

    What firmware version are you using? Send M115 to confirm.



  • Thank you for your reply!!!
    Everything you asked for can be found below.

    config.g

     ; Configuration file for Duet WiFi (firmware version 1.21)
     ; executed by the firmware on start-up
     ;
     ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Sep 02 2020 18:51:18 GMT-0400 (Eastern Daylight Time)
     
     ; General preferences
     G90                                                ; send absolute coordinates...
     M83                                                ; ...but relative extruder moves
     M550 P"BLV mgn Cube"                               ; set printer name
     M667 S1                                            ; select CoreXY mode
     
     ; Network
     M552 S1                                            ; enable network
     M586 P0 S1                                         ; enable HTTP
     M586 P1 S0                                         ; disable FTP
     M586 P2 S0                                         ; disable Telnet
     
     ; Drives
     M569 P0 S1                                         ; physical drive 0 goes forwards
     M569 P1 S1                                         ; physical drive 1 goes forwards
     M569 P2 S1                                         ; physical drive 2 goes forwards
     M569 P3 S0                                         ; physical drive 3 goes backwards
     M584 X0 Y1 Z2 E3                                   ; set drive mapping
     M350 X16 Y16 Z16 E16 I1                            ; configure microstepping with interpolation
     M92 X80.00 Y80.00 Z4000.00 E420.00                 ; set steps per mm
     M566 X720.00 Y720.00 Z12.00 E120.00                ; set maximum instantaneous speed changes (mm/min)
     M203 X6000.00 Y6000.00 Z180.00 E1200.00            ; set maximum speeds (mm/min)
     M201 X500.00 Y500.00 Z250.00 E250.00               ; set accelerations (mm/s^2)
     M906 X800 Y800 Z800 E800 I30                       ; set motor currents (mA) and motor idle factor in per cent
     M84 S30                                            ; Set idle timeout
     
     ; Axis Limits
     M208 X0 Y0 Z0 S1                                   ; set axis minima
     M208 X340 Y350 Z350 S0                             ; set axis maxima
     
     ; Endstops
     M574 X1 Y1 S1                                      ; set active high endstops
     M574 Z1 S2                                         ; set endstops controlled by probe
     
     ; Z-Probe
     M307 H3 A-1 C-1 D-1                                ; disable heater on PWM channel for BLTouch
     M558 P9 H5 F120 T6000                              ; set Z probe type to bltouch and the dive height + speeds
     G31 P25 X30 Y24 Z0                                 ; set Z probe trigger value, offset and trigger height
     M556 S50 X0 Y0 Z0                                  ; set orthogonal axis compensation parameters
     M557 X15:285 Y15:285 S20                           ; define mesh grid
     
     ; Heaters
     M305 P0 T100000 B4138 R4700                        ; set thermistor + ADC parameters for heater 0
     M143 H0 S100                                       ; set temperature limit for heater 0 to 100C
     M305 P1 T100000 B4138 R4700                        ; set thermistor + ADC parameters for heater 1
     M143 H1 S260                                       ; set temperature limit for heater 1 to 260C
     
     ; Fans
     M106 P0 S0 I0 F500 H-1                             ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
     M106 P1 S1 I0 F500 H1 T45                          ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
     M106 P2 S1 I0 F500 H1 T45                          ; set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
     
     ; Tools
     M563 P0 D0 H1 F0                                   ; define tool 0
     G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
     G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
     
     ; Custom settings are not defined
     
     ; Miscellaneous
     M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    

    homeall.g

     ; homeall.g
     ; called to home all axes
     ;
     ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Sep 02 2020 18:52:45 GMT-0400 (Eastern Daylight Time)
     G91                     ; relative positioning
     G1 S2 Z5 F6000          ; lift Z relative to current position
     G1 S1 X-345 Y-355 F1800 ; move quickly to X or Y endstop and stop there (first pass)
     G1 S1 X-345             ; home X axis
     G1 S1 Y-355             ; home Y axis
     G1 X5 Y5 F6000          ; go back a few mm
     G1 S1 X-345 F360        ; move slowly to X axis endstop once more (second pass)
     G1 S1 Y-355             ; then move slowly to Y axis endstop
     G90                     ; absolute positioning
     G1 X-15 Y-9 F6000       ; go to first bed probe point and home Z
     G30                     ; home Z by probing the bed
     
     ; Uncomment the following lines to lift Z after probing
     ;G91                    ; relative positioning
     ;G1 Z5 F100             ; lift Z relative to current position
     ;G90                    ; absolute positioning
    

    deployprobe.g

     ; called to deploy a physical Z probe
     ;
     ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Sep 02 2020 18:53:16 GMT-0400 (Eastern Daylight Time)
     M280 P3 S10 I1 ; deploy BLTouch
    

    retractprobe.g

     ; retractprobe.g
     ; called to retract a physical Z probe
     ;
     ; generated by RepRapFirmware Configuration Tool v3.1.4 on Wed Sep 02 2020 18:55:09 GMT-0400 (Eastern Daylight Time)
     M280 P3 S90 I1 ; retract BLTouch
    

    m115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.0(RTOS) ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2018-06-05b3

    IMG_20200902_185830.jpg

    IMG_20200902_185840.jpg


  • Moderator

    @knosence config and the pins you are using all look correct. If it’s not even lighting up, it’s not getting power, so check continuity of wires to BLTouch, particularly red and blue.

    Ian



  • @knosence

    it is a power problem with the red and blue wires .
    if you push your connecter to the very end it can miss the pins.
    Make sure the plug looks tight and making contact


  • Moderator

    @knosence said in BLTouch 3.1v not lighting up with Duet 2 wifi:

    FIRMWARE_VERSION: 2.0

    Your firmware is two years out of date at this point.

    Time to update.

    Download this file and upload it as is (don't extract it) to the /sys folder in DWC.

    https://github.com/Duet3D/RepRapFirmware/releases/download/2.05.1/Duet2Firmware-2.05.1.zip



  • @droftarts I ordered a multimeter so I wont be able to check right now.
    @peter247 I tried to do that as well with no luck. I also re-crimped them to see if I messed up, but no luck.
    @Phaedrux Thank you for the suggestion, I have downloaded it and uploaded it, but still didn't get any response from the BLTouch. Hopefully when the multimeter comes I will finally have my answer.


Log in to reply