Can't get part cooling fans running :(



  • Hi guys & girls,

    Made the entry into the 3D printer world two months ago, was the first to buy a FLSun QQ-S Pro and 3 weeks later purchased an Anycubic Predator with the idea to make a top 3D printer, the first to replace the hotend with a Maxiwatt and later also replaced the extruder with a BMG dual drive Redrex clone.

    Now a week ago I took the plunge by purchasing an original Duet 2 wifi controller including the 5 "PanelDue.

    After a lot of messing around, I was finally able to make my first print 🙂

    But one thing I can't do, I can't get the two part cooling fans running, they are connected to the FAN-0 connector, and when I plug the ALWAYS ON FANS they just run.

    Below my config.g file hoping someone will look at it to find a solution.

    Thanks in advance,

    Mario
    The Netherlands

    ; Configuration file for Duet WiFi (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v3.1.4 on Fri Sep 18 2020 09:00:56 GMT-0500 (Central Daylight Time)

    ; General preferences
    M575 P1 S1 B19200
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Predator" ; set printer name

    ; Delta Settings
    M665 R185 L440.49 B175 H436.71 ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them

    ; Network
    ;M551 P"tiCipp!50" ; set password
    M552 S1 ; enable network
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S0 ; physical drive 0 goes backwards
    M569 P1 S0 ; physical drive 1 goes backwards
    M569 P2 S0 ; physical drive 2 goes backwards
    M569 P3 S0 ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3 ; set drive mapping

    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z80.00 E430.0 ; set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00 ; set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00 ; set accelerations (mm/s^2)
    M906 X1000 Y1000 Z1000 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S300 ; Set idle timeout

    ; Axis Limits
    M208 Z0 S1 ; set minimum Z

    ; Endstops
    M574 X2 S1 P"xstop" ; configure active-high endstop for high end on X via pin xstop
    M574 Y2 S1 P"ystop" ; configure active-high endstop for high end on Y via pin ystop
    M574 Z2 S1 P"zstop" ; configure active-high endstop for high end on Z via pin zstop

    ; Z-Probe
    M558 P8 C"zprobe.in" R0.4 H30 F1200 T5000 ; set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y0 Z13.90 ; set Z probe trigger value, offset and trigger height
    M557 R175 S20 ; define mesh grid

    ; Filament Sensor
    M591 D0 P2 C"e1_stop" S1 ;activate Filament Sensor

    ; Heaters
    M308 S0 A"Heated Bed" P"bedtemp" Y"thermistor" T100000 B4300 C0 R4700 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bedheat" Q100 T0 ; create bed heater output on bedheat and map it to sensor 0
    M307 H0 A137.8 B0 C533.3 D1.5 ; enable bang-bang mode for the bed heater and set PWM limit
    M140 H0 P0 ; map heated bed to heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C

    M308 S1 A"Maxiwatt" P"e0temp" Y"thermistor" T100000 B4300 C0 R4700 ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1 ; create nozzle heater output on e0heat and map it to sensor 1
    M143 H1 S280 A0

    ; Fans
    M950 F0 C"fan0" Q24000 ;CPAP create fan 0 on pin fan0 and set its frequency !fan2+exp.pb6 with RPM readout on PB6
    M106 C"PartCoolingFan" F65535 P0 S0 H-1 L0.1 ; set fan 0 value. Thermostatic control is turned off L0.3 X1
    M950 F1 C"fan1" Q100 ;HOTEND FAN create fan 1 on pin fan1 and set its frequency
    M106 C"HotendFAN" P1 H1 T45 ; set fan 1 value. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 F0 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Miscellaneous
    M575 P1 S1 B57600 ; enable support for PanelDue
    M501 ; load saved parameters from non-volatile memory
    T0 ; select first tool


  • Moderator

    Can you post the results of M122 and M98 P"config.g" please?

    You say you have 2 part cooling fans? Are they both wired to the Fan0 connector? In series or parallel?

    Are the fans 12v or 24v? Is the PSU 12v or 24v?

    ; Fans
    M950 F0 C"fan0" Q24000 ;CPAP create fan 0 on pin fan0 and set its frequency !fan2+exp.pb6 with RPM readout on PB6
    M106 C"PartCoolingFan" F65535 P0 S0 H-1 L0.1 ; set fan 0 value. Thermostatic control is turned off L0.3 X1
    M950 F1 C"fan1" Q100 ;HOTEND FAN create fan 1 on pin fan1 and set its frequency
    M106 C"HotendFAN" P1 H1 T45 ; set fan 1 value. Thermostatic control is turned on
    

    For fan0 you've set a PWM frequency of Q24000, did the default 500 not work?

    M106 F65535 is not valid. The F parameter is not used in RRF3, and in RRF2 the limit for PWM frequency is below that I believe. So delete that.



  • @Phaedrux

    Yes 2 cooling fans (original Predator) in parallel connected to the FAN-0 connector, fans and the PSU are 24V.

    Don't know about PWM frequency of Q24000, I copied the setup from someone on this forum (honestly doesn't know who anymore), maybe he didn't use the original fans.

    Deleted M106

    M98 P"config.g"
    HTTP is enabled on port 80
    FTP is disabled
    TELNET is disabled
    Warning: Heater 1 appears to be over-powered. If left on at full power, its temperature is predicted to reach 538C

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.1.1 running on Duet WiFi 1.02 or later
    Board ID: 08DLM-996RU-N8PS4-6J9F4-3S46T-1UVVN
    Used output buffers: 3 of 24 (11 max)
    === RTOS ===
    Static ram: 27980
    Dynamic ram: 93212 of which 60 recycled
    Exception stack ram used: 264
    Never used ram: 9556
    Tasks: NETWORK(ready,404) HEAT(blocked,1224) MAIN(running,1824) IDLE(ready,80)
    Owned mutexes: WiFi(NETWORK)
    === Platform ===
    Last reset 00:01:24 ago, cause: power up
    Last software reset at 2020-10-12 21:12, reason: User, spinning module GCodes, available RAM 9316 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task MAIN
    Error status: 0
    MCU temperature: min 29.4, current 34.6, max 34.7
    Supply voltage: min 24.7, current 24.9, max 25.1, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2020-10-13 00:29:14
    Cache data hit count 137051482
    Slowest loop: 6.77ms; fastest: 0.14ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Storage ===
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest read time 3.9ms, write time 0.0ms, max retries 0
    === Move ===
    Hiccups: 0(0), FreeDm: 169, MinFreeDm: 169, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    Heater 1 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Movement lock held by null
    HTTP is idle in state(s) 0
    Telnet is idle in state(s) 0
    File is idle in state(s) 0
    USB is idle in state(s) 0
    Aux is idle in state(s) 0
    Trigger is idle in state(s) 0
    Queue is idle in state(s) 0
    Daemon is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 15.91ms; fastest: 0.00ms
    Responder states: HTTP(2) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0), 0 sessions
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is active
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address f4:cf:a2:6e:87:5c
      WiFi Vcc 3.36, reset reason Unknown
      WiFi flash size 4194304, free heap 25192
      WiFi IP address 192.168.1.20
      WiFi signal strength -71dBm, reconnections 0, sleep mode modem
      Socket states: 4 0 0 0 0 0 0 0
      === Filament sensors ===
      Extruder 0 sensor: ok


  • I changed M950 to Q500, fans still not spinning.

    M950 F0 C"fan0" Q500



  • @holco62 said in Can't get part cooling fans running 😞:

    I changed M950 to Q500, fans still not spinning.

    M950 F0 C"fan0" Q500

    Hi,

    How did you test the fans? What command did you issue?

    Frederick


  • Moderator

    @holco62 said in Can't get part cooling fans running 😞:

    Yes 2 cooling fans (original Predator) in parallel connected to the FAN-0 connector, fans and the PSU are 24V.
    Don't know about PWM frequency of Q24000, I copied the setup from someone on this forum (honestly doesn't know who anymore), maybe he didn't use the original fans.
    Deleted M106

    Don't delete the whole M106, just the F65535 part.

    Try this:

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 C"PartCoolingFan" P0 S0 H-1 B1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ;HOTEND FAN create fan 1 on pin fan1 and set its frequency
    M106 C"HotendFAN" P1 H1 T45 ; set fan 1 value. Thermostatic control is turned on
    


  • @Phaedrux Thanks, I will try it this evening.

    Btw, all the lines 1>5



  • @Phaedrux said in Can't get part cooling fans running 😞:

    @holco62 said in Can't get part cooling fans running 😞:

    Yes 2 cooling fans (original Predator) in parallel connected to the FAN-0 connector, fans and the PSU are 24V.
    Don't know about PWM frequency of Q24000, I copied the setup from someone on this forum (honestly doesn't know who anymore), maybe he didn't use the original fans.
    Deleted M106

    Don't delete the whole M106, just the F65535 part.

    Try this:

    ; Fans
    M950 F0 C"fan0" Q500 ; create fan 0 on pin fan0 and set its frequency
    M106 C"PartCoolingFan" P0 S0 H-1 B1 ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"fan1" Q500 ;HOTEND FAN create fan 1 on pin fan1 and set its frequency
    M106 C"HotendFAN" P1 H1 T45 ; set fan 1 value. Thermostatic control is turned on
    

    @Phaedrux

    It's working now, many thanks for your help 👍 👍 👍

    Is it also possible to start the cold-end fan at a nozzle temp of 50 degrees on the fan01 connector?



  • I see it now 😊 line 4 and 5 is for the hotend fan that triggers on 45 degree, I only have to put the connector on the FAN1 output which is now connected on a always on output 🙄

    Have a lot to learn about G-code 😀



  • Still needed some tuning, but a week ago I did not expect to have a working printer already 😎

    https://youtu.be/CeavMw9Q42I



  • With a Z axis calibration I sometimes see the number 1000 in red in the status box at sensors Z-probe, but usually it stays at 0 (not in red).
    What does that mean?


  • Moderator

    It's showing that the probe is triggered. What it shows and how long it shows it will depend on the type of probe.



  • @PhaedruxOk, but why don't I see the number 1000 in red every time the probe triggers during a calibration?


  • Moderator

    What probe do you have?



  • The stock Predator probe with a micro switch



  • probe.jpg



  • I changed M558 H30 to H35 in the config.g, but that hasn't changed anything, but the calibration is going damn slow now 🤔


  • Moderator

    Well the switch is only going to show triggered when it's depressed, so in normal use it would be very brief.

    M558 H is the dive height.

    You should consider posting a new thread with your probing issues as it's not related to your initial problem which was solved.



  • Ok thanks, I will create a new topic.


Log in to reply