big problem duet3d maestro



  • Hi everyone,
    I have a self-built 3d printer, similar to the Anet A6 but with two nozzles.
    It worked fine but I was running an old version of RRF (v. 2.05) so I decided to upgrade to version 3.1.1 trying to improve my printing quality. I had to update to 3.0 first, then up to latest stable version I found hoping for an easy implementation of the g-code command changes, which clearly was a pain at first having to go through so many changes.

    When I first turned on the printer after updating it wasn't working properly so I made a new config.g file from scratch using the RRF Configuration Tool using all infos found on patch notes and around the forum but without success.

    Now I'm stuck with the following problem:
    I have two heaters and two temperature sensors, both share the same hardware, the first goes up to 210 degrees in about a minute, the other one takes 4 minutes to achieve the same temperature.

    I run a few times the heaters PID auto calibration command (M303 H1 S210 and M303 H2 S210) trying all the heaters in the scroll menu but I have problems with all of them but those into the config.g file (attached at the bottom).
    I also checked both heaters and sensors with a multimeter having about identical values.

    I have no ideas on what to do next, any suggestions?

    config.g



  • YOU WOULD ALSO WANT TO ADD THE CONFIG.OVERRIDE.G FILES AND THE RESULT OF THE PID AUTO TUNING

    config-override.g
    console.txt



  • @luca-f13 First things first, maybe double-check the firmware updated correctly. Send M122 in the console and confirm you're on RRF3.1.1.

    Next, try running M98 P"config.g". That will execute the config file as a macro and tell you any issues in the syntax. I don't see any particular errors from a first look but here's a few thoughts.

    • You don't have an M501 to load anything in your config-override.g file (where the PID tuning parameters are usually saved with M500). It could be that you're not reading these so the firmware is just assuming some default which may be diferent for the different heater ports. Just Add "M501" to the end of your config.g file
    • Your thermistor values are both the config tool default. I'd recommend checking the actual values for your sensors in case they are different! Getting the wrong values will mean they are off by a bit

    Below is my config from my similar machine (Chimera hotend with one part cooling fan) for ref. The "bed_temp" pin name is different, but that's because I've got a D-Wifi not Maestro. I would also double check your fans and how you've asigned them to your tools. I have Fan0 as my hotend fan and Fan1 as my part cooling fan

    ; Heaters
    M308 S0 P"bed_temp" Y"thermistor" T100000 B3950 R4700  ;define bed temp sensor              
    M950 H0 C"bedheat" T0			 ;heater 0 uses the bed_heat pin, sensor 0
    M140 H0
    M143 H0 A3 S120                             ; Set temperature limit for heater 0 to 120C
    
    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 C7.060000e-8   ; define E0 temp sensor
    M950 H1 C"e0heat" T1  ; heater 1 uses the e0heat pin and sensor 1
    M143 H1 A3 S280                             ; Set temperature limit for heater 1 to 280C
    
    M308 S2 P"e1temp" Y"thermistor" T100000 B4725 C7.060000e-8   ; define E1 temp sensor
    M950 H2 C"e1heat" T2  ; heater 2 uses the e1heat pin and sensor 2
    M143 H2 A3 S280                             ; Set temperature limit for heater 1 to 280C
    
    ; Fans
    M950 F1 C"fan1"    ;Fan 1 uses the fan1 pin
    M106 P1 T45 H1:2				 ; Set Fan 1 to run any time heater H1 or H2 is above 45C
    
    M950 F0 C"fan0"    ; part cooling fan (Fan 0) uses the fan0 pin
    
    ; Tools definition
    M563 P0 S"Extruder 0" D0 H1              ; Define tool 0
    G10 P0 X0 Y0 Z0                          ; Set tool 0 axis offsets
    G10 P0 R0 S0                             ; Set initial tool 0 active and standby temperatures to 0C
    
    M563 P1 S"Extruder 1" D1 H2              ; Define tool 1
    G10 P1 X0 Y0 Z0                          ; Set tool 1 axis offsets (set manually in slicer)
    G10 P1 R0 S0                             ; Set initial tool 1 active and standby temperatures to 0C
    
    


  • @engikeneer
    I also add the result of the M122

    M122.txt



  • @luca-f13

    11/12/2020, 01:01:14: M501: Warning: Heater 2 appears to be over-powered. If left on at full power, its temperature is predicted to reach 784C
    

    This suggests that Heater 2 is waaayyy overpowered. And certainly a lot more powerful than Heater 1.

    Prime reason for this might be that you have fitted a 12V heater cartridge to a 24V printer? That makes a 30W into a 120W heater which is quite dangerous!
    Unplug both heater cartridges from the Duet and measure their resistance.



  • @engikeneer
    after seeing this result it is the first thing I did and it gives me almost identical values and in fact the heaters are identical from the same supplier bought in pairs


  • Moderator

    @engikeneer said in big problem duet3d maestro:

    Prime reason for this might be that you have fitted a 12V heater cartridge to a 24V printer?

    That's what I thought, but it looks like a 12v system.

    Supply voltage: min 0.0, current 12.8, max 13.0,

    @luca-f13 Did you wait for the hotend to cool down before tuning the second heater?

    The values you're using suggest they are E3D Semitec thermistors?



  • @Phaedrux the heaters I bought are these
    https://www.amazon.it/gp/product/B082HV788B/ref=ppx_yo_dt_b_asin_title_o00_s00?ie=UTF8&psc=1
    but then again before the update they worked great


  • Moderator

    @Phaedrux said in big problem duet3d maestro:

    Did you wait for the hotend to cool down before tuning the second heater?

    Are the heaters in a shared block or seperate tools?



  • @Phaedrux
    they are two separate elements
    PRUSAnew.PDF



  • Ah missed the 12V...

    @luca-f13 Looking at the link you posted, the B coefficient of your thermistors should be 3950 (assuming you used those). Probably worth changing that in your config. I would also double check the resistance of both thermistors at the Duet, when unplugged. They should be 100K

    Next question, do they read the same temperature when cool at room temp? If they're the same sensor and configured the same, they should match with a few degC

    I am slightly confused by what you're seeing though. Heater H2 is the one that is taking a long time to heat up, but that is the one that also comes up with the overpowered warning? Doers it visibly take longer to heat up when doing the tuning, or just in normal heating? I'm thinking that with such high gains from your PID, the controller might just be limiting the heater as it thinks it is so overpowered.

    If you rerun the tuning on H2, how consistent are the results? I'm wondering if there might be some noise on your temperature measurements that are affecting the tuning. I have seen a couple of people on the forum report that RRF3 is more susceptible to noise in temperature sensors than RRF2 (though haven't seen it myself).



  • @engikeneer
    I have 3950 thermistors but using those proposed in the menu no one gives the possibility to the heater h1 to reach 210 degrees for the calibration test I have tried all those he offers me and this was the only one that allows me to finish the test

    yes the two thermistors detected the same ambient temperature and also as values detected with the multimeter

    no the h2 heater is the one that reaches 210 degrees in one minute the problem is h1 which takes about 7 minutes to reach the temperature with great difficulty

    I am as perplexed as you are because there is no reason for these differences now I have ordered new heaters that I have just received in the afternoon I try to do everything with new ones then I will let you know the result

    I am grateful for your precious help



  • @engikeneer

    *****OH MY GOD *****

    I found the problem is neither electronic nor electrical the problem nor software
    now I hope you don't get mad the problem is with the heater block holder.
    the two heater block holders were made of two different materials one in steel and one in aluminum so the heat was struggling to spread in one case and in the other it spread quickly

    I am very angry but at least I solved it.
    thanks to everyone for the help


Log in to reply