Help with setup - solved

  • Hello,
    Let me thank you in advance.
    I bought the he3d k280. I changed the main board to the duet 2 wifi v1.2 FW 2.5. I also purchased the duet smart effector v2. The challenge i am facing is I am unable to get the programable Z probe to work. I have read a lot of documentation trying to solve the issue.

    Any insight or assistance would be greatly appreciated.
    p.s. I will gladly supply any config or anything asked.

  • Moderator

    I assume you've seen this?

    How far along are you?

    Please post the results of M122
    Post your config.g and homedelta.g and bed.g

  • @Phaedrux said in Help with setup:

    indeed, i have done it twice some places even more. 🙂
    But the step that i am stuck at is Commissioning step 4 the light never comes on .

    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.05.1 running on Duet WiFi 1.02 or later
    Board ID: 08DJM-9178L-L2MS8-6JKFJ-3S86Q-TBGGN
    Used output buffers: 3 of 24 (8 max)
    === RTOS ===
    Static ram: 25712
    Dynamic ram: 92584 of which 416 recycled
    Exception stack ram used: 272
    Never used ram: 12088
    Tasks: NETWORK(ready,896) HEAT(blocked,1232) MAIN(running,3816) IDLE(ready,160)
    Owned mutexes:
    === Platform ===
    Last reset 00:26:01 ago, cause: power up
    Last software reset at 2021-01-10 18:59, reason: User, spinning module GCodes, available RAM 12000 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0441f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 33.3, current 42.2, max 42.6
    Supply voltage: min 24.8, current 24.9, max 25.0, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2021-01-11 01:44:13
    Cache data hit count 4294967295
    Slowest loop: 2.11ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0, FreeDm: 160, MinFreeDm: 160, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === DDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 15.66ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    - WiFi -
    Network state is running
    WiFi module is connected to access point 
    Failed messages: pending 0, notready 0, noresp 0
    WiFi firmware version 1.23
    WiFi MAC address dc:4f:22:6e:e4:db
    WiFi Vcc 3.46, reset reason Turned on by main processor
    WiFi flash size 4194304, free heap 25136
    WiFi IP address
    WiFi signal strength -46dBm, reconnections 0, sleep mode modem
    Socket states: 0 0 0 0 0 0 0 0

  • Moderator

    Does anything on the smart effector light up?

    Photos of the wiring?

  • Yep the print lights come on on the points.
    Wiring is really messy rewired so please don't hold it against me
    20210111_015947.jpg .20210111_020014.jpg

  • it helps if you add power to the effector...

  • there should be cables here

  • @jay_s_uk hey Jay, those are for the thermistor.
    They were there and still didn't work.

  • no, T1 to T4 are the thermistor.
    If thats the case, you are feeding power into the thermistor connections.
    I suggest you revisit the wiring diagram

  • @jay_s_uk Thanks good catch, switched it. Looks like I need to redo the black 6 pin 😞 . Heading to bed. Thank you for taking the time to get me on the right path.

  • So everything has been redone.
    Print lights are working, fans come on as expected, heater cartridge and thermistor work.
    tried to power on using usb still no green light.

  • @RonP can you post your config.g?

  • @jay_s_uk will be a couple of hours. Had to take dog to the vet.☚ī¸

  • config.g
    Here it is

  • @jay_s_uk Here you go

  • M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1

    B4138 is the default and wrong for your thermistor. look up the correct value in your thermistor documentation

    also add a T0 to the end of your config. (is "Select the First Tool on Start-Up" in the configurator)

    you also might want to enable "Read config-override.g file at end of startup process (provides similar functionality to the EEPROM option in Marlin)"
    makes the calibration for a delta easier.

  • @RonP I can't see anything there that would stop the smart effector from working (i just compared it against my old RRF2 with smart effector config).
    What voltage are you working with? 12v or 24v?

  • @jay_s_uk 24v

  • @RonP not sure what else I can add then.
    I would use a multimeter just to check everything out once more.

  • @jay_s_uk hey Jay, went through it all again and it seems good. So does that mean my effector is bad ?
    Thanks for taking the time to help me.

  • @RonP I think for @Phaedrux to be able to answer that, he'll be after clear photos of the top and the bottom of the board, ideally without anything attached.
    Can you also comment on when and where you purchased it?

  • administrators

    If the green light on the Smart Effector never comes on at all, even at power up, the most likely reason is that it is not getting 3.3V and ground through the 8-pin connector.

  • First i want to say thank you for everything.
    It is working now.
    Couple of suggestions:
    1.) The ordering of the connections on the documentation (Smart Effector) doesn't line up with the actual 8 pin. Jay pointed out my error.
    2.) Update the documentation to reflect the correct green led light or say it could be over here (empty header) or here (by the 8 pin)

    So what i think happened is that we had it working shortly after the 6 pin re-do. I was so focused on the green led near the empty header that i didn't see the green led by the 8 pin.
    I just happened to see it when i went to take it apart again and touched the print head and saw the green led by the 8 pin.

    But thanks again for all the focus and attention.

Log in to reply