SOLVED Will not load mesh using G29 S1 command



  • For some reason, it will not load the height when requested from a gcode file.
    heightmap.csv is present, works if I manually command it either from the command line or the GUI.

    Even put it in twice, but still does not load.

    Regards

    Paul.

    ; generated by PrusaSlicer 2.3.0+linux-x64-GTK3 on 2021-02-06 at 12:40:56 UTC
    
    ; 
    
    ; external perimeters extrusion width = 0.30mm
    ; perimeters extrusion width = 0.30mm
    ; infill extrusion width = 0.45mm
    ; solid infill extrusion width = 0.45mm
    ; top infill extrusion width = 0.22mm
    ; support material extrusion width = 0.40mm
    ; first layer extrusion width = 0.40mm
    
    M107
    ;TYPE:Custom
    ; Multi-temp start code - 5 September 2020
    ; Raise bed temp to profile requested bed temp
    M140 S105 ; Raise bed temp to profile requested bed temp
    M104 S150 T0 ; Raise hot-end temp to 150C for G32 auto-calibration
    M190 S105 ; Wait for bed temp to rise
    M109 S150 T0 ; Wait for hot-end temp to rise to 150C
    G29 S2
    G28 ; home all axes
    G28 Z 
    ;G32 ; Autocalibrate bed
    G32 ; Autocalibrate bed a second time
    G28 Z ; Home Z after bed leveling
    ;
    G1 Z20 F600 ; Move bed down 20
    M104 S245 T0 ; Raise hot-end temp to profile requested hot-end layer 1 temp
    M109 S245 T0 ; Wait for hot-end temp to rise to profile requested hot-end layer 1 temp
    ;
    G1 X0.0 Y0.0 Z1.0 F2000.0 ; prepare to prime
    G92 E0 ; reset extrusion distance
    G1 Z0.2 F600
    G1 X60.0 E9.0  F1000.0 ; priming
    G1 X125.0 E12.5  F1000.0 ; priming
    G1 Z0.5 F600
    G92 E0 ; reset extrusion distance
    G29 S1
    ;
    G29 S1
    ; end of start code
    


  • Hi,

    Was that code generated by the slicer?

    It's not very efficient.

    Still G29 S1 should load heightmap.csv if it is the system directory.

    Please post your homeALL.g and homeZ.g files using the </> tag

    Thanks.

    Frederick



  • G28 ; home all axes
    G28 Z

    G28 should home z as well.

    what firmware version are you running?

    how did you check that the heightmap was not loaded?


  • administrators

    @PaulHew, which Duet are you using, with which firmware revision, and in standalone or SBC mode?



  • Hi,
    It is not loading the mesh compensation. using the G29 S1 command.
    Yes the code is generated by the slicer, top line of the GCode I posted states PrusaSlicer

    I checked using the GUI, 'Compensation in use: none.
    I noticed also that my leadscrews were not moving.

    Duet2 with Duex5 in standalone mode. (not enough info for me to do the DIY conversion)
    @dc42

    RepRapFirmware for Duet 2 WiFi/Ethernet version 3.2 running on Duet Ethernet 1.02 or later + DueX5
    Board ID: 08DGM-917DA-G4MS8-6JKDL-3SN6N-TVVB9
    
    

    Regards,

    Paul


  • administrators

    Thanks. Have you checked the GCode file to make sure that your start GCode is present in it, and that the slicer hasn't inserted a G28 or other relevant command in the GCode file after the start code?



  • @dc42
    In the first post it has my start gcode from the actual file I am printing.

    G29 S1 is the last line of my start gcode.

    These are the subsequent lines.

    End of the gcode - It has already printed the prime line  by this point.
    G29 S1
    ;
    G29 S1
    ; end of start code
    
    G21 ; set units to millimeters
    G90 ; use absolute coordinates
    M83 ; use relative distances for extrusion
    ;Filament gcode
    ;G29 S1 P"100.csv"
    ;LAYER_CHANGE
    ;Z:0.24
    ;HEIGHT:0.24
    ;BEFORE_LAYER_CHANGE
    ;0.24
    
    
    G1 Z0.240 F18000.000
    ;AFTER_LAYER_CHANGE
    ;0.24
    G1 E-0.80000 F2700.000
    G1 X28.309 Y27.729 F18000.000
    G1 E0.80000 F2400.000
    M204 S2000
    ;TYPE:Skirt
    ;WIDTH:0.4
    G1 F1500.000
    G1 X29.242 Y27.142 E0.03719
    G1 X30.320 Y26.890 E0.03734
    

    So, no other commands to negate the G29, as far as I know.
    Also had no errors that it could not load the file.

    Going to try G28 S1 P"heightmap.csv"

    Regards,

    Paul.



  • No, G29 S1 P"heightmap.csv" did not work either.
    had to manually load it.



  • Hi,

    We really need to see your homing files

    • homeX.g
    • homeY.g
    • homeZ.g
    • homeALL.g

    Thanks.

    Frederick


  • administrators

    This is strange. I just added G28 followed by G29 S1 to the start of one of my GCode files that didn't have any start GCode, and ran it. It worked as expected, M122 went from reporting "bed compensation in use: none" to "bed compensation in use: mesh". This is on a delta with a Duet WiFi running firmware 3.2.1.



  • @dc42 said in Will not load mesh using G29 S1 command:

    G28

    The last G28 I have is in bed.g, these tramming functions are before running G29 S1.

    rename to a .zip

    Homing Files.txt
    ABS Shape-Box-2.04683g-17m.gcode

    I have included the gcode file, You can clearly see there are no G28s after the G29

    Just reloaded 3.2, full power reboot, just incase


  • Moderator

    Can you check if it's enabled in M122 in case it's a display issue in DWC?


  • administrators

    Why has this thread been marked as solved?


Log in to reply