Weird correlation between XY-motors, Z-probe and heaterports



  • Hi guys,
    I'm in the process of rebuilding my XY-gantry and while I reconfigured everything step_by_step, I've noticed some odd behaviour from Duet2WiFi or RRF3.2.
    The heaters weren't connected to the board, but the thermistors were. ( I wanted to run a drytest with cold extrusion)
    The Z-probe was connected and working as before.
    But every time I started to move X or Y axis, the Z-probe showed triggered. ( I could move the Z-axis with no problems)
    I tried everything I could think off:

    • replacing the Z-probe,
    • changing the input of Z-probe,
    • moving the stepper- and probecables apart,
    • changing the probe-definion in config.g
    • connect the probe with/without Diode

    The solution was to connect the heaters to the Duet! Suddenly everything worked as expected!

    I spent a nice day, sorting that out, but I guess that's part of the hobby 🙂


  • Moderator

    What was the probe?



  • @Phaedrux
    It's a Conductive probe (NPN & NO) I've used it before with little to no problems (except the temp-related failure in a heated chamber)
    LJC18A3-B-Z/BX also works on wood and other materials.
    Which is the reason, why I had it on my CNC as well.
    (try DC42's mini IR probe on shiny metal, just for fun...)


Log in to reply