NEED HELP please



  • I plugged all my wires into the board and turned it on and the screen does not turn on.
    Is there an update i need to perform to make it all communicate?
    I have the Tevo Black widow, with all duet driving hardware.
    The board I now have is duet wifi and the touch LCD display.
    if there are updates how do i go about doing that.
    Sorry i am new to this.
    Any help is Greatly appreciated!!



  • Which screen? Idk much about the Black Widow, but the Duet only supports the PanelDue as a screen AFAIK.


  • administrators

    When you power the PanelDue up, the display should light up unless you have pressed the Erase button on the PanelDue controller. If you have pressed the Erase button then you will need to re-flash the firmware as described in the instructions.

    The first thing to check is that you have connected the PanelDue controller to the touch screen correctly. It's easy to get the pins out of alignment by 1 pin in any direction.

    You can also try disconnecting the PanelDue from the Duet and powering it via the micro USB connector instead. If that makes the display light up, then check that you have plugged the cable into the correct 4-pin connector on the Duet (the one nearest the WiFi module), and that the cable connections are correct (the order of the wires should be reversed between the two ends).

    If you are using the ribbon cable instead of the 4-pin cable, check that you have plugged it into the right socket on the Duet - the CONN_SD socket, not the CONN_LCD one.

    HTH David



  • I have the PanelDue 5"



  • I have a software called TeamViewer, Is it possible for any of you to Take control of my PC and Do this for me… I am very mechanically inclined, I am not at all coherent in this computer world.


  • administrators

    Have you done the checks I suggested? Or do you think you pressed the Erase button?



  • Yes I did do all the checks you suggested.

    I may have pressed the erase button… i am not sure.
    from what it sounds like i did press the erase button.
    If i have clear instructions of how to reprogram the firmware i may-be-able to do so. but most likely not as i failed on the MKS Gen V1.4 and had a Facebook friend come fix what i did wrong.


  • administrators

    Check out the instructions here:

    https://miscsolutions.wordpress.com/paneldue/

    in the section
    "Testing the board and updating the firmware"



  • I tried that. no luck. unless the main duet board has the same issue. i am giving it 24.3 volts.


  • administrators

    What exactly did you try, and at what point in the procedure did you not get the expected result?



  • "Identify the COM port number or port name of the PanelDue board on your PC. If you use Windows, you can do this via Start->Control Panel->System->Device Manager. Expand Ports (COM and LPT), and look for Bossa port. Make a note of the port number. If you can’t find the port, try repeating the Erase and Reset sequence, or disconnecting and reconnecting the USB cable, or try a different USB port on your computer. Note: the port number of the Bossa port for PanelDue will not be the same as the one you use when uploading firmware to Duet electronics.

    Use bossac to program the board. Under Windows, open a command prompt and use this command:

    bossac.exe –port=COM9 -e -w -v -b PanelDueFirmware.bin

    Replace COM9 in this command by the COM port number you found, and PanelDueFirmware.bin by the path to your downloaded firmware file. It is possible to use the interactive version (Bossa) instead of bossac, but if you do then you must check the Erase All, Lock, and Boot from Flash boxes."

    This is where it did not continue to cooperate. the command did not go through. here is what it said,
    C:\Users\CCWCF>bossac.exe --port=COM9 -e -w -v -b PanelDueFirmware.bin
    'bossac.exe' is not recognized as an internal or external command,
    operable program or batch file.


  • administrators

    Assuming you have already downloaded and installed Bossa as described in the instructions, you probably need to specify the path to bossac.exe, for example use "C:\Program Files\BOSSA\bossac.exe" (including the quotation marks) at the start of the command line instead of just bossac.exe.



  • I have tried that… i am not smart in this area.
    I am willing to ship this board and screen back, and re-order and i will make sure i DON'T touch the erase button.
    That will be easier for me as i do not understand these instructions.
    unless there is another way or its something simple im not understanding correctly.
    I am not in anyway frustrated or upset at Duet.



  • You have to be in the correct directory (the directory with bossac.exe and PanelDueFirmware.bin) before running the command.

    Could you post a screenshot of your attempt, then I can point out what's wrong?



  • How do i post a picture. when i click image i get this. [ img]
    I tired dragging and dropping. copy paste.



  • Upload the image to an image host, such as imgur.
    Place the URL inside of the img tags, like this:

    [ img]https://i.imgur.com/v6jkSLc.jpg[/ img]

    Except without the space before the img in each tag.




  • Thank you!!!




  • administrators

    The top left window in your image shows the interactive version of Bossa. It looks like you have the filename entered correctly, and it has connected to the PanelDue. You just need to check the Lock box, then press Write.



  • still no luck.
    i think my problem is the command promt.
    is says
    "file name" is not recognized as an internal or external command, operable program or batch file.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.