Help with strange diagonal banding on Ultibots D300VS+ ?!

  • @wwmotorsports

    Here's a suggestion for a quick experiment that might help narrow down the cause.

    • Print a single walled cylinder diameter 100 mm without infill. Spiralized/vase mode should work. No bottom layer needed. Make sure the print is centered on the print bed. Observe the print to see if the pattern appears.

    • If it doesn't appear clearly change the object to an equilateral triangle.

    • If the pattern it doesn't appear, add a second perimeter and infill.

    • If the pattern is asymmetric it is probably related to one of the three towers / arms. The direction of asymmetry could tell you which.

    • If the pattern is symmetric around the bed center, increase the extrusion factor to 150% (can be done during printing – for a single walled print this is equivalent to increasing the extrusion width by 50 %).

    • If the pattern changes in frequency or pitch angle – it stems from the extruder.

    • If it doesn't change, it's likely motion related.

  • Hey guys, thanks for all of the quick and thorough responses! Sorry for the delay in getting back, but I was out of town for a long weekend.

    @JoergS5 : I had the same thought, so I tried printing in different areas of the bed and at different angles. While the effect changes in pattern slightly, there is no perfect position or alignment that I could find that would make the pattern disappear. In the past, I printed a single walled, 3 sided "propellor" with each one of the legs perpendicular to each of the towers increasing speed every 5mm of print height from painfully slow to right at the max flow rate of the E3D Titan Aero that came with the printer. I have made a lot of changes to the printer since then, but at the time I was not able to discern much of a difference in the pattern with changes in speed. I may try to print something similar again tonight, but make it 6 sided so that each pair of towers is split by a leg of the print to show the effects of that.

    @dc42 : I am running 0.2mm layer height currently. I tried the "Golden Ratio" height of .1618 with no discernable change in the effect. One thing I did notice last night while messing with this is that the LED lights on the printer flicker at the exact frequency of the "PID" pulses of the heated bed. I was very optimistic that these power fluctuations may have been the culprit and forced both heaters back into bang-bang mode and turned the heated bed off after the first layer for good measure. While this did get rid of the LED flicker, the surface pattern persisted.

    @DigitalVision : I was very optimistic that your suggestion was going to be the winner because I have had luck with improvements in quality on my old Rostock V2 (heavily modified, the only thing left of the original printer was the frame) when changing the V6 nozzle from a 0.4mm to a 0.5mm. I have been printing a single wall 40mm x 40mm tower with rounded corners to try to isolate this problem because that really seems to show the surface defect, and unfortunately increasing the extrusion width to 0.6 made a very little discernable difference to the surface pattern. I didn't get a chance to take any pictures of the print at 0.48mm vs 0.6mm extrusion width, but I will do that tonight when I get home to give some more examples of what I am dealing with for everyone to ponder.

    I'll make some more test prints tonight and post the pictures for everyone to take a look at and hopefully one of you will find the answer I haven't yet!

    Thanks again, everyone.

  • @wwmotorsports some more ideas:

    • do the frames flex or vibrate while printing? You can test by fixing them: mount at wall. connect all frames by horizontal stiff material
    • make video and after printing find the problemetic positions and find out whether the linear guides are at a specific position. Then check whether they get stuck at this combination. If bowden, does it have a problematic position or movement?

    No more ideas....

  • @JoergS5 The frame is rock solid. The D300VS is an all metal frame design with delrin roller wheels, carbon rods with spring loaded ball-cup ends, SLS nylon carriages and effector and a direct drive E3D Titan aero extruder (D300VS Kit Link). By all accounts, it should be a really very excellent printer because the components are all top notch, I'm sure there is just something I am missing.

    I printed a tall single walled 40 x 40 tower in vase mode to show what the surfaces look like. The pictures of the 4 sides are linked below:

    Side 1

    Side 2

    Side 3

    Side 4

    As you can see, the pattern is pretty consistent up the height of each side, but changes from side to side, which makes me think it has to be something wrong with the motion system (whether mechanical, electronic, config settings or slicer, I have no idea) not the extruder.

    Any new thoughts with the added pictures?

  • @wwmotorsports I expect the most logic is a part which is not centered (pulley, stepper two bearings inside the stepper) or is loose (pulley, frame, backlash in hinges) or not equal distance (belt). I know that the frame of your printer is rock solit, but a connection could be loose or vibrate.

    You could use a digital dial indicator to find out where you have irregular movements.

  • @wwmotorsports

    You can exchange the stepper pulleys (separately A,B,C axis) with different teeth ones, correct the firmware and print. If the distance of the ripple valleys and mountains is different, you know which of the three sides it is.

  • That looks very similar to when I had a hob bearing get a little slop internally. The lines were quite a bit less sloped, but I am using Nimbles with 30 to 1 gearing and IIRC the Aero has 3 to 1 so that makes sense.

  • Check the bearings on either side of the drive gear on the Titan Aero. I bet one of them has seized.

  • @Phaedrux : I really wanted you to be right because that would be an easy fix, so I broke down the extruder last night to check the bearings, but unfortunately, both bearings were smooth as butter...

    @Alexander-Mundy : My last printer (that I sold to build this one) was a Rostock V2 that I had put a Duet Wifi on and a Zesty Nimble as well. I had some growing pains with that extruder including the bad gear mesh inside of the extruder, so that was one of the first things I checked when I had this problem. Last night when I had the extruder apart, I even used an old Nimble trick and added some 30K diff lube to the gear mesh to make sure that friction in the gears was not my problem.

    To be sure to eliminate the belts/gears as the source of the issue, last night I double checked the alignment of the frame top to bottom, checked that all of the bolts in the frame were tight, shimmed the gears and idlers so that the belt was within +/- 0.1mm parallelism to the towers across their whole length and removed the guiding flanges from the pulleys. One of the belts was rubbing on the flange of a drive gear a little, so I was optimistic that this change would be the magic fix. Unfortunately, even with all of the above checked and tweaked, the ribbing still persists...

    The only other thing I might try to completely eliminate the belt/gear interface as the source of the issue is to try to run smooth drive and idler pulleys on the back side of the belt, but that is obviously not a long-term fix.

    I was starting to think I might just be crazy, but then I picked up a project I had printed with some parts from my old Rostock and some from the D300VS, and unfortunately, there is a visible difference in print quality between the parts. In the picture linked below, the upper portion was printed on the D300VS and the lower portion was printed on the Rostock using the same slicer and the same roll of black PLA filament.

    D300VS vs Rostock Print Comparison

    I'm 100% sure that the geometry and design of the D300VS is better than the Rostock, so I'm really stumped as to what is still causing my issue.

    @dc42 : Is it possible I just have a bad stepper driver?

    Just in case I'm missing something obvious, here's a link to my config file if anyone wants to comb through it.

    D300VS Config File

    Thanks again for trying to help everyone!

  • @wwmotorsports

    Your image seems more to be a matter of underextrusion. And maybe you had a smaller layer height with the Rostock.

    I am no Delta specialist, but 0.1 mm could be relevant, if you have deviations of around 0.1 mm.

    In one forum thread the frames were dicussed to flex. So I would try to fix them at a wall and connect the three aluminium frames horizontally in the middle with something stable (temporarily for testing).

  • Well, everyone who had money on the extruder as the source of the problem can cash their chips in.

    @DigitalVision and @JoergS5 , thanks for pushing me to take a closer look at the extruder, because I was dead convinced it was an issue with the motion system.

    I considered that under extrusion might have been the issue, so I just cranked up the extrusion multiplier during one of my test prints, and sure enough, the pattern immediately changed. Interestingly, there was no actual under extrusion as the printed width was exactly what was requested, so I did another test.

    In the image linked below are three test prints at different layer heights with otherwise identical slicer settings. On the largest layer height print, the imperfections are so close together they are almost hard to see, but as the layer height gets smaller the "ripples" get farther apart and at a shallower angle. I repeated the test at all kinds of amperage and micro-step combinations and got the same result. For grins, I also tried another extruder stepper and different filaments but got the same result. So, as far as I am concerned, there must be some mechanical issue with the E3D Titan Aero that repeats at a constant volumetric extrusion amount, causing the issues I have been having...

    Layer Height Comparison

    For now, I'm going to take this to the E3D forums for some more focused discussion, but if anyone has any other suggestions, I'm all ears!

    Thanks again for the help everyone.

  • @wwmotorsports said in Help with strange diagonal banding on Ultibots D300VS+ ?!:

    For now, I'm going to take this to the E3D forums for some more focused discussion, but if anyone has any other suggestions, I'm all ears!

    Can you please post a link to your E3D forum thread? While I don't think I have anything to contribute in regards to a solution, I'm very interested in the problem and what solutions might be suggested.


  • In my experience with the aero there are a few things that may be your issue.

    The aero gears need to be perfectly aligned to mesh smoothly. The whole body has to turn slightly to get them just right.

    The bearings are fickle. Even though you say it turns smoothly my learned instinct says never to trust them. I'd replace them out of spite. 😉

    The large gear may need to be adjusted on the hobbed gear to get the filament path lined up on the teeth.

    The idler tensioner tension has a sweet spot of not too tight and not too loose.

    Just throwing some ideas out there.

  • @garyd9 , sure thing. See the link below:

    @Phaedrux , thanks for the tips! I definitely agree that this thing appears to be pretty picky. I have already clocked the body and adjusted the large gear on the hob to get the hob and filament path to align. I have replacement bearings on their way as I type this, so I can eliminate that as the issue soon.

    The only other thing that I can think of is where the stepper shaft gets centered into the heat sink. Since there is not a bearing in there and I'm sure that the idler is moving the shaft around a little, I wonder if the shaft is actually making contact with the aluminum housing and causing a repeating stick-slip condition? Hmmm...

    If I can't get this resolved shortly, I'm probably going to nuke the Titan Aero and go get an effector from 713 Maker and put an E3D V6 and a Zesty Nimble on it since I had such good luck with that basic setup in the past. I'll report back on whatever I find that actually fixes this!

  • @wwmotorsports You have two bearings inside the stepper, so non-centered bearings could be a cause.

  • As I read this thread today, I did also a test:
    I printed a 50 mm diameter cylinder in vase mode. Identical settings. On the left, 0.13 mm layer height, on the right 0.2. On the right, you see like a twisted symmetrical spiral all around the print (in live- version even more than on the photo) which is absolutely gone on the left... Really strange!

  • @JoergS5 : that's definitely a possibility, but I have tried two different brand new E3D steppers (compact and pancake) and had the exact same defect so I doubt that's my issue in this case.

    @kuhnikuehnast : what kind of extruder are you running?

  • @wwmotorsports said in Help with strange diagonal banding on Ultibots D300VS+ ?!:

    @JoergS5 : that's definitely a possibility, but I have tried two different brand new E3D steppers (compact and pancake) and had the exact same defect so I doubt that's my issue in this case.

    @kuhnikuehnast : what kind of extruder are you running?

    It is a zesty nimble. Really strange! Has anyone an idea how this is possible?

  • EDIT: I had the extruder gear ratio in the wrong place in the calculations, please see my comments in the next post

    Well, I am not 100% sure, but I think this may all stem from a full step positioning error of the extruder stepper, at least in my case.

    I was updating to the 2.02 firmware last night when I noticed that the StealthChop mode was now available, so I thought I would give it a try. First thing, it was really impressive how much quieter the printer was with that chop mode enabled. Second, there was a noticeable difference in the print quality changing the chop mode, which I did not expect. In the picture below, the part on the left was printed with StealthChop and the part on the right was printed with an old firmware version using constant off time chopping. The difference isn't dramatic, but it is noticeable:

    StealthChop vs Constant T-Off

    I wondered why that might be and I did a little research about that chopping method and saw that they claim it helps minimize zero-crossing positioning error. That got me thinking and I calculated the volumetric flow of the Titan Aero per full step of the extruder and compared that to the length of extrusion required to consume that same volume of filament (accounting for the fact that the edges of the extrusion are actually radiused). Lo and behold, the spacing between the ripples in my prints match the volume of extrusion per full step of the extruder almost exactly for all of the layer heights I have tested. See a screengrab of my calculations below (note: I'm tessting with a 0.6mm nozzle):

    Extruder Ripple Calculator

    I figured this all out pretty late last night, so I haven't had time to experiment more, but my next step is to switch the extruder stepper to the other driver that I am currently not using to see if that helps. However, after a little more math, I'm not wildly optimistic that even the most precise stepper driver would fix this.

    I have a 400 step/rev stepper with a 16 tooth pulley on my towers, giving me 12.5 full steps/mm of travel for the motion components, which seems reasonable that the human eye would not likely detect the stepping error at that close proximity.

    The extruder, on the other hand, with a 400 step/rev stepper, a 3:1 gear ratio and a 7.3mm hob printing with a 0.6mm nozzle at a 0.2mm layer height has a 2.86 MM/STEP ratio when you compare the volume of extrusion per full step to the motion required to consume that volume. In other words, even with a geared extruder and a 0.9° stepper, the extrusion is 35.75 TIMES less accurate than the motion of the carriage...

    It seems to me that the only way to remedy that is to run an extremely high gear ratio on the extruder which would cause significant speed issues, or run a filament diameter smaller than the nozzle diameter to alleviate the natural "inverse gearing" that happens when you squeeze a 1.75mm filament through a 0.4mm hole (inverse volumetric ratio of roughly 19:1 by my math).

    Someone, please tell me my math is wrong because otherwise, this is a pretty sad realization...

    @dc42 , any thoughts on this?

  • @kuhnikuehnast

    I had a ripple similar to yours
    It was the flex cable on the extruder.

    But your extrusion problem looks more cyclic than mine.

    alt text


Looks like your connection to Duet3D was lost, please wait while we try to reconnect.