Newbe need help duet ethernet printinmg headtower fails



  • Hello

    I tryed to print headtower, but if the print start the heater and the beg go to temperature 1.
    I am comingh from Radds 1.5 and Repetier
    Can you help me?

    here is my cura start script:
    M107 ; Stopp Fan
    M83
    M92 X80.40 Y80.40 Z800.00 E440.50:837.00 ; Set steps per mm
    M201 X1500 Y1500 Z300 E10000 ;Set max printing acceleration
    M201 X3000.00 Y3000.00 Z300.00 E10000.00:10000.00
    T0
    M106 P1 S255
    M190 S[bed0_temperature] T0
    M109 S[extruder0_temperature] T0
    G28; home all axes
    G90; set positioning to absolute
    G92 E0 ; set E to 0
    G1 E15 F300 ; fill up nozzle from previous retract
    G1 Z0 F6000; set nozzle to first layer height
    G1 F12000; ensure fast travel to first print move
    G92 E0; set E to 0 again

    And here a bit from the gode:

    ;POSTPROCESSED
    ;ChangeAtZ instances: 1
    ;Generated with Cura_SteamEngine 3.6.0
    T0
    M190 S110
    M104 S260
    M109 S260
    M82 ;absolute extrusion mode
    M107 ; Stopp Fan
    M83
    M92 X80.40 Y80.40 Z800.00 E440.50:837.00 ; Set steps per mm
    M201 X1500 Y1500 Z300 E10000 ;Set max printing acceleration
    M201 X3000.00 Y3000.00 Z300.00 E10000.00:10000.00
    T0
    M106 P1 S255
    M190 S[bed0_temperature] T0
    M109 S[extruder0_temperature] T0
    G28; home all axes
    G90; set positioning to absolute
    G92 E0 ; set E to 0
    G1 E15 F300 ; fill up nozzle from previous retract
    G1 Z0 F6000; set nozzle to first layer height
    G1 F12000; ensure fast travel to first print move
    G92 E0; set E to 0 again

    M83 ;relative extrusion mode
    G1 F3000 E-4.5
    ;LAYER_COUNT:500

    ;LAYER:0
    M107
    G0 F1800 X119.08 Y102.422 Z0.2
    ;TYPE:SKIRT
    G1 F3000 E4.41685
    G1 F1800 X119.623 Y101.849 E0.02626
    G1 X120.222 Y101.334 E0.02627
    G1 X120.87 Y100.883 E0.02626
    G1 X121.561 Y100.499 E0.02629
    G1 X122.286 Y100.187 E0.02625
    G1 X123.039 Y99.95 E0.02626
    G1 X123.813 Y99.791 E0.02628
    G1 X124.598 Y99.71 E0.02625
    G1 X125 Y99.7 E0.01337
    G1 X175 Y99.7 E1.66301
    G1 X175.789 Y99.74 E0.02628
    G1 X176.569 Y99.859 E0.02624
    G1 X177.334 Y100.057 E0.02628
    G1 X178.074 Y100.331 E0.02625
    G1 X178.783 Y100.679 E0.02627
    G1 X179.454 Y101.097 E0.02629
    G1 X180.078 Y101.58 E0.02625
    G1 X180.651 Y102.123 E0.02626
    G1 X181.166 Y102.722 E0.02627
    G1 X181.617 Y103.37 E0.02626
    G1 X182.001 Y104.061 E0.02629
    G1 X182.313 Y104.786 E0.02625
    G1 X182.55 Y105.539 E0.02626
    G1 X182.709 Y106.313 E0.02628
    G1 X182.79 Y107.098 E0.02625
    G1 X182.8 Y107.5 E0.01337
    G1 X182.8 Y157.5 E1.66301
    G1 X182.76 Y158.289 E0.02628
    G1 X182.641 Y159.069 E0.02624
    G1 X182.443 Y159.834 E0.02628
    G1 X182.169 Y160.574 E0.02625
    G1 X181.821 Y161.283 E0.02627
    G1 X181.403 Y161.954 E0.02629
    G1 X180.92 Y162.578 E0.02625
    G1 X180.377 Y163.151 E0.02626
    G1 X179.778 Y163.666 E0.02627

    0_1552061066425_Neue Bitmap.jpg


  • administrators

    @eckbert0815 said in Newbe need help duet ethernet printinmg headtower fails:

    I tryed to print headtower, but if the print start the heater and the beg go to temperature 1.

    I'm sorry, I don't understand your problem description. Have you tested and tuned the bed heater and extruder heater?



  • I dia a pid tuning and saved it with M500.
    The problem is, when the print starts, the heater goes from 260° to 1° and teh bed from 110° to 1°-



  • @eckbert0815 Looks like it's something to do with your slicer settings.

    In the actual gcode file these lines are fine
    M190 S110
    M104 S260
    M109 S260

    but a little later are these lines

    M190 S[bed0_temperature] T0
    M109 S[extruder0_temperature] T0

    The firmware won't understand those commands.



  • Thanks, now i have the next problen, big elephantfeeds and overextrusion.



  • @eckbert0815 I'm not surprised.

    For your steps per mm you have M92 X80.40 Y80.40 Z800.00 E440.50:837.00 ;

    But that's in you slicer start script. Why are you making those settings in your slicer and not your configuration files? More importantly, why do have two completely different values for each extruder? Do you have one with a 1.8 degree motor and the other with a 0.9 degree motor?

    You haven't told us anything about your printer or your configuration settings, other than the start script you use in Cura. I suggest you read this then come back with the information that is needed for someone to be able to help. https://forum.duet3d.com/topic/5909/guide-for-posting-requests-for-help



  • @deckingman

    You are right, i told you nothing!
    With radds and repetier is it easier to cofigurate the printer with the startcode, otherwise you have to flash a new firmware or edit it on the printer self.

    Let`s start again!

    Ich have a core xy see picture.
    Technial details:
    Modell: NoName
    Hotend: Nf tc-01 full Metall Heatbrak, 0.41 Microswiss Nozzle
    Extruder: 2x Titan Bowden one with 1.8° stepper and one with 0.9°
    Pancake stepper.
    Filament: ABS-X Schmelzbar
    Firmware: Duet (RepRap)
    Slicer: Cura 3.6

    New Cura Startcode: (works fine)
    T0
    M116
    M106 P1 S255
    G28 Y X ;home X and Y axes
    G1 Z20 F6000 ;Move the platform down 0mm
    G1 E15 F300 ; fill up nozzle from previous retract
    G28 Z ;home Z axes
    G1 Z0 F6000 ;Move the platform down 0mm
    G92 E0
    G1 F200 E3
    G92 E0

    New config.g
    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Wed Mar 06 2019 16:12:25 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"R2D2" ; Set machine name
    M540 PBE:04:32:3E:51:3A ; Set custom MAC address
    M552 P0.0.0.0 S1 ; Enable network and set IP address
    M553 P255.255.255.0 ; Set netmask
    M554 P192.168.1.1 ; Set gateway
    M586 P0 S1 ; Enable HTTP
    M586 P1 S1 ; Enable FTP
    M586 P2 S1 ; Enable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes backwards
    M569 P3 S0 ; Drive 3 goes backwards
    M569 P4 S0 ; Drive 4 goes backwards
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80.40 Y80.40 Z800.00 E918.03:837.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E120.00:120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X10000.00 Y10000.00 Z500.00 E1500.00:1500.00 ; Set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z300.00 E10000.00:10000.00 ; Set accelerations (mm/s^2)
    M906 X1900.00 Y1900.00 Z1900.00 E1900.00:1400.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y265 Z245 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S0 ; Set active low and disabled endstops
    M574 Z1 S1 ; Set active high endstops

    ; Z-Probe
    M558 P0 H5 F120 T6000 ; Disable Z probe but set dive height, probe speed and travel speed
    M557 X15:285 Y15:245 S20 ; Define mesh grid

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S130 ; Set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S1 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic power saving
    M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; Set voltage thresholds and actions to run on power loss

    ; Custom settings are not configured

    0_1552138837635_IMG_0346.jpg
    with radds, the printer prints ok with 120mm/s

    0_1552138856829_IMG_0347.jpg
    0_1552138867215_IMG_0348.jpg

    Now i got this:

    The headtower is so lala print from 260-215° Flow 100 EM/EW 40
    0_1552139346818_IMG_0353.jpg
    0_1552139352821_IMG_0354.jpg

    But the 20mm cube........i don`t know the problem.
    0_1552139487510_IMG_0349.jpg
    ![0_1552139493910_IMG_0350.jpg](Uploading 100%)
    0_1552139498024_IMG_0351.jpg
    0_1552139504974_IMG_0352.jpg
    0_1552139750442_IMG_0350.jpg

    Sorry for my bad english, i am from germany.



  • Note the printer is still in process, becaus i can`t print the parts for paneldue, dor, sidecover .....



  • @eckbert0815 The problems look to be temperature related and I can't see any M307 commands in your config.g so I suggest you tune the heater PID settings https://duet3d.dozuki.com/Wiki/Tuning_the_heater_temperature_control

    Also your steps per mm for the extruders don't match what you've said about the motors. For an E3D Titan with 1.8 degree motors the steps per mm are in the order of about 420 so for a 0.9 degree motor, they should be about 840. In your config.g you have E918.03:837.00. So I suggest you set the steps per mm roughly, then calibrate both extruders.

    I'm guessing that by "headtower" you mean a temperature tower. If the pictures show the result of printing ABS in a range from 260 to 215 then the upper delamination of the layers is exactly as one would expect if that was printed as low as 215.



  • @deckingman The M307 ist in the config-override.g

    ; Heater model parameters
    M307 H0 A90.0 C700.0 D10.0 S1.00 V0.0 B1
    M307 H1 A1249.4 C240.8 D5.3 S1.00 V27.2 B0
    M307 H2 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H3 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H4 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H5 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H6 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    M307 H7 A340.0 C140.0 D5.5 S1.00 V0.0 B0
    G10 L2 P1 X0.00 Y0.00 Z0.00
    G10 L2 P2 X0.00 Y0.00 Z0.00
    G10 L2 P3 X0.00 Y0.00 Z0.00
    G10 L2 P4 X0.00 Y0.00 Z0.00
    G10 L2 P5 X0.00 Y0.00 Z0.00
    G10 L2 P6 X0.00 Y0.00 Z0.00
    G10 L2 P7 X0.00 Y0.00 Z0.00
    G10 L2 P8 X0.00 Y0.00 Z0.00
    G10 L2 P9 X0.00 Y0.00 Z0.00

    I have changes to the extruder with the 0.9 stepper becaus the big gear from the other titan ist not the best, changed at the board too and calibrate it. But not the second one. I wil calibrate the exturder later.

    New steps and jerk....
    M350 X16 Y16 Z16 E16:16 I1 ; Configure microstepping with interpolation
    M92 X80.40 Y80.40 Z800.00 E879.00:420.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E1200.00:1200.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X10000.00 Y10000.00 Z500.00 E3600.00:3600.00 ; Set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z300.00 E10000.00:10000.00 ; Set accelerations (mm/s^2)
    M906 X1900.00 Y1900.00 Z1900.00 E1400.00:1900.00 I30 ; Set motor currents (mA) and motor idle factor in per cent

    Now i try a print with less temperature 240° nozzle and bed 85°, retract 5.5mm.

    It sems to be better.



  • @eckbert0815 said in Newbe need help duet ethernet printinmg headtower fails:

    @deckingman The M307 ist in the config-override.g...........................

    In that case, you need to add M501 to the end of your config.g file in order to read in those values. https://duet3d.dozuki.com/Wiki/Gcode#Section_M501_Read_stored_parameters

    Without the M501, the values stored in config-override. won't get read. Alternatively, you can copy or cut and paste those M307 lines into your config.g file.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.