Homing all wacky on my Maestro [SOLVED]



  • Hi.

    I've got a (for me at least ) really weird problem. I'm kind of a noob when it comes to gcode, so please bear with me if I misunderstand or just ask questions that should be obvious. I just converted of a little Geeetech Mecreator2 to a Maestro board and I've searched the forum, but I can't find any obvious explanation for this.

    I have a Duet2 Wifi working perfectly on my Tevo Little Monster Delta, so I think I have at least a basic understanding of how the Duet boards work.

    General info about the Mecreator2:
    Cartesian printer (one separate motor for each axis, so not core xy right?)
    X- and Y- fixed at the top.
    Z- moves the bed vertically.
    X- and Y- end stops at the far end (ie. at +160).
    Z- end stop at the top (ie. at 0)

    All files are now freshly generated on the reprap configurator and not altered at all to make it easier to find any errors if You need to look at them.
    Generating these new files didn't make any difference in the homing behaviour.
    I attached the files so that the post wouldn't be a mile long.

    Firware is the latest stable version (2.02)

    I connected everything and electrically it all seems to be correct and working, so here is the issue:

    Because the homing doesn't work right, before I can do any axis testing, I manually move the X- and Y- axis to the front left and the bed to the top and set it as 0 with G92 X0Y0Z0. I have also tried setting 0 for each axis separately, but it didn't make any difference.

    When I move any of the axis manually (with the on screen buttons in the web interface) everything works perfectly.

    However, if I click home for any of the separate axis the Z-axis moves the bed down (ie. the wrong way) about 25mm and then stops.
    I think I can hear a faint single "tick" as if the correct axis attempts to move.
    If i click home all, the X- and Y- moves about 10mm the wrong way each and the Z- once again moves the bed down (ie. the wrong way) a little bit and stops.

    I hope I'm just missing something super simple and obvious, but I'm afraid it's the opposite...

    Regards,
    Bo

    4_1552554117902_homez.g 3_1552554117902_homey.g 2_1552554117902_homex.g 1_1552554117902_homeall.g 0_1552554117902_config.g



  • before you try the homing make sure that each axis is moving correcly

    i.e does G0 X100 followed by G0 X0 move the head right and left by 100mm?



  • also a Z Value of Z2133.33 is rather odd. is that correct?



  • I haven't done it by gcode, but by clicking on the buttons in the web interface and that works. It's off by a a few tenths, but that shouldn't affect anything when the axis are in the center, should it?



  • The Z-value of 2133.33 is what the configurator set when I input my printer specs, so I hope so...
    But could that affect the direction or the fact that the Z-axis moves when I press the home button fΓΆr X- or Y-? None of the axis was near min or max when I tested this.



  • Wouldn't it move move the z axis so that the nozzle doesn't hit the printed object or bed when homing?

    Did you check and make sure the endstops are all working correctly?



  • @siblues

    I don't know, but not 25mm right? It doesn't on my Delta, but that's a completely different setup, so i guess that isn't applicable here...

    End stops work, but how would that affect it when it's not near any end? I'm probably missing something here and as I said, I'm not very good with gcode or scripts, so if I sound thick, You know why πŸ™‚





  • the reason it moves so much for you is that the home script moves the z axis down by 5 mm. since your steps are so wrong you get 26mm.



  • @veti
    Ahh. That would explain that part of the problems. Thanks Veti.
    I followed a guide for the setup, that I can't find again, so it might have been removed for beeing bogus...
    Then hopefully it's just the thing I need. I'll try it when I get home tonight and post back with results.

    Br,
    Bo



  • @Veti
    Sorry to say that the only things that changed when setting Z-value to 400 was that the bed moved less and the faint "ticking" sound is now gone 😞
    It still responds the same weird way, moving Z- no matter which home button I click.

    I tested the movement by gcode (G0 X100 and then G0 X0 and then the same for Y- and Z-) again and it behaves exactly as it should.
    I also re tested the end stops and they work properly.

    I tested the X- end stop by using the "Test Fans" preinstalled button in the web interface also and that too works just as expected.
    However, when I do a G0 X100 and press the end stop mid way there is no reaction at all? It still goes the full 100mm. Shouldn't it stop when I do that?



  • @Veti

    I tried a G28 after moving the axis by hand then a "G0 X0Y0Z0" to set the zero point and that does the same thing as clicking a home button 😞



  • @bikerbuz said in Homing all wacky on my Maestro:

    However, when I do a G0 X100 and press the end stop mid way there is no reaction at all? It still goes the full 100mm. Shouldn't it stop when I do that?

    No. End stops are only active during G1/G0 moves that use the S1 switch like in the homing files.

    You may want to go through this commissioning guide for cartesian printers.
    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter
    As well as https://duet3d.dozuki.com/Wiki/Test_homing_behaviour
    and https://duet3d.dozuki.com/Wiki/Connecting_endstop_switches



  • @bikerbuz

    the default homeing from the configurator contains a z 5 mm move down to move anything out of the way. that is normal.



  • I got frustrated and tore the wiring apart and reconnected everything once again. Ran the tests all over again.
    Everything was 100% (just like before) except for that I got no response at all from the Z- end stop. I replaced the wiring for that end stop and it responded fine.

    I started the printer and thought I'd try "home all" just for fun, before I did any testing. Eureka πŸ™‚ Homing works perfectly now πŸ˜„

    The only thing bugging me is that a faulty wire could consistently work in end stop tests, and just as consistently fail in homing tests...

    @Veti Thanks for Your help and suggestions. They made me think twice about trusting some random post, instead of coming here for help.
    It sure put me in the right mood to try solving this! It's greatly appreciated.

    @Phaedrux Thanks for the links, I'll read them all through carefully when I get a little bit more time to spare.


Log in to reply