z-homing failed with mini IR



  • @bluedust Use a G1 movement to position the probe before using G30 to probe it.

    G90 ; absolute positioning
    G1 X150 Y150 ; move to bed center
    G30 ; probe z height
    

    Is that what you mean?

    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z



  • @Phaedrux it does match cause I've got dual independent z-axis, so I could level the x-gantry.



  • @phaedrux said in z-homing failed with mini IR:

    G30

    I am not sure if that is what I mean...

    This is my current Code.

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M5+58 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y-42 Z1.45 ; Set Z probe trigger value
    M557 X100:200 Y100:200 S100:100 ; Define mesh grid

    I wanted to do something like this, I just don't know if I can, or if there is more to it.

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops

    ; Z-Probe
    M5+58 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y-42 Z1.45 ; Set Z probe trigger value
    M557 X100:200 Y100:200 S100:100 ; Define mesh grid

    But if I can make my IR Z Probe Home to the center of the bed, and not off the bed, that would be perfect.

    I am not sure how to use G1, or G30 as they are not currently in my config. I will have to look into them. I am currently printing, but will play when it's completed. Also note, I have a CoreXY, not a Cartesian. Not sure if that changes things.

    Thanks!



  • @gueee78 said in z-homing failed with mini IR:

    @Phaedrux it does match cause I've got dual independent z-axis, so I could level the x-gantry.

    In that case you could use a G32 in the homez to call bed.g to level the bed, and then use a single G30 in the center as shown above to set the z height.

    G32 ; call bed.g to level the bed
    G90 ; absolute positioning
    G1 X150 Y150 ; move to bed center
    G30 ; probe z height
    


  • @bluedust said in z-homing failed with mini IR:

    I wanted to do something like this, I just don't know if I can, or if there is more to it.

    ; Endstops
    M574 X1 Y1 Z1 S1 ; Set active high endstops

    ; Z-Probe
    M5+58 P1 H5 F120 T6000 ; Set Z probe type to unmodulated and the dive height + speeds
    G31 P500 X0 Y-42 Z1.45 ; Set Z probe trigger value
    M557 X100:200 Y100:200 S100:100 ; Define mesh grid

    Yes that could work. your homing files would specify how the Z axis is homed. To use a probe, you use G30, to use the endstop switch, you would use a G1 S1 Z move to trigger the endstop. And with your probe defined in the config.g things like G29 that use the probe would still work as normal.

    But if I can make my IR Z Probe Home to the center of the bed, and not off the bed, that would be perfect.

    I am not sure how to use G1, or G30 as they are not currently in my config. I will have to look into them.

    This would probably be best and would be easy to do. The snippet I posted above would go into your homing file. If you post your entire homing files I can show exactly what needs to be modified.

    Also note, I have a CoreXY, not a Cartesian. Not sure if that changes things.

    Homing Z would be the same between cartesian and corexy.



  • @phaedrux

    I poked around the config files.
    I think I figured it out and updated the homeall and homez files

    Will play after this print completes

    Thanks!



  • @phaedrux

    Good stuff!
    Z works in the center of the bed now!

    Thanks!



  • I still couldn't find a solution for that problem.

    I even updated my firmware and redid the whole configuration, but it still doesn't do the bed leveling with two z-motors.

    I do an initial homing of all axis wich works fine, when I start Auto Bed Compensation it probes the two points but then it throws the error message: Probe points P0 to P1 must be in clockwise order starting near minimum X and Y

    has anyone got a similar configuration working and could give me some advice?



  • Does the order of your probe points match the order the motors are defined in config.g?



  • yes it does and the error message occours even if I switch the probe points


  • administrators

    Are you running a very old firmware version that doesn't support bed levelling using independently driven leadscrews? Send M115 to check the firmware version.



  • no, I'm running latest stable release 2.02


  • administrators

    @gueee78 said in z-homing failed with mini IR:

    Error: Probe points P0 to P1 must be in clockwise order starting near minimum X and Y

    That message means that the firmware thinks you want to do old-style bed compensation. It should only do that if the number of leadscrew coordinates you defined in M671 doesn't match the number of Z motors defined in M584. So try running M584 without parameters, and M671 without parameters, and report the results.


Log in to reply