Z=0 datum was not determined probing.



  • How do I fix this error? It just started showing up after a firmware update: Duet Maestro M3D Promega

    Warning: the height map was loaded when the current Z=0 datum was not determined probing. This may result in a height offset.


  • administrators

    It means that you have both a Z endstop switch and a Z probe, and you used the endstop switch to home Z. The problem with this arrangement is that the endstop switch and the Z probe need to agree on where Z=0 is. If they don't, then your height map will show a significant offset, corresponding to the different in Z=0 levels. The difference between these two Z=0 levels is likely to be affected by temperature.

    Ways round this include:

    • Ignore it, if you are satisfied that it doesn't cause any problems. The main issue is likely to be that a height map that you produce by probing one day may not work when you load it from the SD card another day, because the difference in Z=0 as seen by the endstop switch and as seen by the Z probe has changed.
    • Instead of using the endstop switch to home Z, use the Z probe. See https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z_using_a_Z_probe.
    • After homing Z using the endstop switch, and before either probing (G29 or G29 S0) or loading a height map (G29 S1), do a single G30 probe at/near the centre of the bed.


  • Thank you !

    This happened after I updated the firmware. It was never an issue before and I'm not sure how or why it's reading the IR probe all of the sudden. I've always used the Z-Probe ( limit switch ) and it worked just fine. How do I disable the IR probing function and should I do that?


  • administrators

    That message is new in the 2.03RC firmware, that's why you didn't have it before.

    I suspect that you have set up your homez.g file and the Z homing section of homeall.g incorrectly. See https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_Z_using_a_Z_probe. Z homing using a Z probe should be done using a G30 command, not a G1 S1 or G1 H1 command.



  • Hi thanks, for the info but as I havent meshed the bed yet I cant ignore it and using G30 without the switch, the head crashes in to the bed, I have no desire currently to use IR probe. How can I disable it or have the firmware ignore it?
    As above recently updated and now having issues.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.