rfm - RepRapFirmware FileManager [duetbackup successor]



  • Hi wilriker,

    I hate to sound stupid, but how do I use it? Where do I put the files? And how do I access it? My system is Windaze 7 PC and a DUET-EtherNet controller.

    Thanks in advance...3mm



  • @wilriker

    Yep, -removeLocal now works.
    You can't specify the remote directory as 0:/ any more though. Not sure if this is intentional or not.

    $ ./rfm backup -domain duet0 /tmp/duet0 0:/
    2019/07/30 05:49:53 Fetching filelist for 0:/0:
    2019/07/30 05:49:53 Directory not found
    

    Doesn't matter to me, not sure if it's matter to others.



  • @3mm You download the release for your operating system. For Windows that would be rfm-windows_amd64.zip. Then you unpack that to a location of your choice. It is a command-line tool so you have to open cmd and navigate to the directory where you unpacked rfm to (alternatively: in Explorer right click while holding shift in the directory where rfm.exe is located - this should provide a context-menu entry to open a command line in this directory).

    There you can simply run

    rfm help
    

    to get an overview and the available sub-commands. With

    rfm help <subcommand>
    

    you can see individual parameters of each sub-command.



  • @gtj0 said in rfm - RepRapFirmware FileManager [duetbackup successor]:

    @wilriker

    Yep, -removeLocal now works.
    You can't specify the remote directory as 0:/ any more though. Not sure if this is intentional or not.

    $ ./rfm backup -domain duet0 /tmp/duet0 0:/
    2019/07/30 05:49:53 Fetching filelist for 0:/0:
    2019/07/30 05:49:53 Directory not found
    

    Doesn't matter to me, not sure if it's matter to others.

    No, that's a bug. 🤦 I'll look into that.



  • @gtj0 Found it and fixed it.

    Release v1.1.0-RC3

    This can be found as usual on GitHub Releases page.

    Another bug fix. There was a regression introduced in v1.1.0-RC1 where it was no longer possible to specify the root directory of the SD card as 0:/. This is fixed in this release.

    Also this release candidate is intended to be the last one before final release of this version.



  • @wilriker

    Thank you very much!

    3mm



  • Arch User Repository Package

    For Arch Linux users: I have submitted a package to install rfm via AUR: https://aur.archlinux.org/packages/rfm/

    This is available for x86_64, arm, armv6h, armv7h and aarch64.



  • Release v1.1.0

    v1.1.0 has existed Release Candidate stage and is now available at GitHub Releases page or via Arch User Repository.

    Reiterating the changes:
    This release implements the persisting of -exclude parameter values in rfm.toml. These parameters will be persisted separately for backup and upload command so they do not confuse each other.

    A new keyword reset has been added as a recognized value for the -exclude parameter to delete all persisted excludes for the current command, i.e.

    rfm backup -exclude reset ...
    

    will remove all persisted excludes for the backup command. Further -exclude parameter after that (even in the same command) will add new excludes.

    Note that order is relevant, i.e.

    rfm backup -exclude 0:/gcodes -exclude reset backup-dir 0:/
    

    will backup everything in 0:/ since the given exclude for 0:/gcodes was reset by the following -exclude reset parameter.

    Bug Fixes

    • -removeLocal was broken for files (working for directories though)
    • Sub-command upload would fail most of the times (this was fixed between RC3 and this version)


  • I'm trying to use your script, but I always get 'invalid character '<' looking for beginning of value' error. What am I doing wrong?

    I'm using the amd64 version...

    Thanks.



  • @fma This happens if the Duet responded with an HTML error page instead of a JSON error. I've seen this happen more often recently but so far have not found the cause.

    Are you using the latest v1.1.0 final release above?

    Also which sub-command does this happen for? Also you can use the parameter -debug to see the actual response coming from the Duet. This might give a hint what's going wrong.



  • Yes, I'm using the final release.

    The error happens with all commands, and -debug does not give much info:

    ./rfm ls 0:/ -debug
    
    0::
    2019/08/18 12:52:40 invalid character '<' looking for beginning of value
    

    BTW, does it require a specific version of RRF? Im' running 2.02RC2...



  • @fma It should work with any version of RRF. Though the -debug parameter has to come before the location to list (in this case) or more general: before any parameter that does not have its own -something prefix.



  • My bad, I made a mistake in the device name! All seems to work fine 🙂

    Thanks for your help.



  • @fma I'm glad it was that simple. 🙂


Log in to reply