Duet "Crashes" on Print



  • When I upload and print a file my Duet seems to crash. The web interface disconnects and the screen on the printer become unresponsive

    I have checked all the movements, including home
    Heated the bed
    Heated the hotend
    tested the extruder
    Tested the probe
    and everything works ok

    If there any logs I can examine to try and work out what is going on?

    When entering M122 I get

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.01(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-917NK-F23T0-6J9DJ-3SD6N-TDBWF
    Used output buffers: 3 of 20 (20 max)
    === RTOS ===
    Static ram: 28476
    Dynamic ram: 96292 of which 16 recycled
    Exception stack ram used: 484
    Never used ram: 5804
    Tasks: NETWORK(ready,328) HEAT(blocked,1248) MAIN(running,3476)
    Owned mutexes:
    === Platform ===
    Last reset 00:23:19 ago, cause: power up
    Last software reset at 2019-06-12 20:55, reason: User, spinning module GCodes, available RAM 5960 bytes (slot 2)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 4
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 23.4, current 25.8, max 26.0
    Supply voltage: min 12.1, current 12.3, max 12.4, under voltage events: 0, over voltage events: 0
    Driver 0: standstill, SG min/max 0/200
    Driver 1: standstill, SG min/max 0/214
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max 0/132
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-06-13 20:46:27
    Slowest loop: 2.99ms; fastest: 0.08ms
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 237, MaxWait: 495583ms, Underruns: 0, 0
    Scheduled moves: 32, completed moves: 32
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.0
    Heater 1 is on, I-accum = 0.4
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 167.51ms; fastest: 0.08ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.21
      WiFi MAC address b4:e6:2d:52:f6:a2
      WiFi Vcc 3.40, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 16696
      WiFi IP address 192.168.0.201
      WiFi signal strength -51dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0
      === Expansion ===

    Any help / things to look for most welcome.

    The only change I made since it last worked was to add the duex5 to do 3 point bed leveling (I have now removed that (and related gcode) and gone back to 1 z stepper (2 motors) as a point of elimination

    Regards,

    Mark



  • As an additional test I have also tried printing direct on the duet screen and that also does not start the print.



  • Just to be clear. You can home all the axes, heat the bed, heat the hot end and extrude filament yes?



  • @deckingman Yes, I have full control of the printer and everything works, I just can't start a print



  • @mark That's very odd. Does it do it with every gcode file or just one particular file? I wonder if your SD card has become corrupted. Have you tried a different card?



  • @deckingman

    I have tried a new Benchy and a calibration cube that has been on the card a while and printed previously.

    If I backup all the files on the card and do a factory reset and the issue still persists (once I do a manual setup again), can I just copy the backed up files back on the card to get back to where I am at the moment?



  • An easier test would be to use a new sd card. Copy the contents of your current card over and try the new card.



  • @Phaedrux 👍 will try it out tonight

    Thanks


  • administrators

    @mark, your M122 report indicates that the last software reset was user-initiated, not a crash. This may have been caused by using the Emergency Stop button, or by sending M999, or by upgrading firmware.



  • I figured it out, and am very ashamed to say it was user error 😞

    I accidently uploaded the slt rather than G-code file!

    @deckingman thanks for your input and keep up the good work on your projects, you have a new follower
    @Phaedrux thanks for the advice
    @dc42 Again thanks for responding - should uploading anything else other than a g-code file to print be a valid user story?

    Again thanks all for you inputs

    Mark



  • How did you upload an STL? I've just tried and the file selector greys them all out and dragging and dropping won't take it either.



  • @Phaedrux I can still upload a stl. Maybe I am not using the latest firmware - I need to work out how to update it, but that's a job for another day!



  • Download this zip file https://github.com/dc42/RepRapFirmware/releases/download/2.03/Duet2Firmware-2.03.zip

    Then upload the whole zip file as is to the Settings page in the DWC. That's all you have to do.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.