board not working



  • Hi, I recently bought a duet 2 wifi board. I received the board yesterday and trying to get is all set up. but it does not do what it is supposed to and on the documentation, it says that there should be three lights that turn on, only one is on. I don't know if the board has a fault but I haven't even had time to make any connections and have not done anything else to the board to damage it. I was wondering who I might be able to talk to to get a replacement or if they know what the problem is. I have taken pictures to prove and have contacted the resaler E3D Online IMG-7080.JPG IMG-7081.JPG IMG-7082.JPG any help would be greatly appreciated



  • It looks like you haven't connected any power wires to the board ....
    You can't expect everything to light up like it should if you haven't connected power.



  • (i think?) 3.3v should light up with usb power. Can you get a close up of U3 over by the Vin/Bed terminals?



  • i will do that now



  • @jens55 I have also just to show you i=have plugged everything in to see if that would work but still not getting any 3.3v power or connectivityIMG-7084.JPG IMG-7083.JPG


  • Moderator

    Laptops don't always provide adequate usb power as well. Try a different port or a PC. Not all USB cables are adequate for power either.

    If you have a PSU ready and waiting, may be worth trying to connect 12v/24v from the PSU.



  • @Phaedrux I just tried that and nothing changed, but the always-on fan is working



  • would it be possible a fuse is blown because of the only thing that isn't working is the 3 volt supply





  • @patmurphyp9 said in board not working:

    would it be possible a fuse is blown because of the only thing that isn't working is the 3 volt supply

    I don't think so. but if you have a meter you could always measure them.

    the picture of U3 and surrounding area isn't very clear the only thing that stands out is something between the end of R85(?) and U3 but I cant tell if its a solder bridge, silscreen, maube those pads should be connected and its not a problem. But as you've tried different cables and different supplies I guess one of the admins will drop by and weigh in


  • Moderator

    @patmurphyp9 I agree with @bearer, looks like there’s something between U3 and R85. This may be shorting out 3.3V. If you have a multimeter, it would be good to test for 3.3V on a pin on the expansion header, just in case it’s the LED that’s failed. Have you tried connecting to it using YAT?

    Otherwise, if you have a soldering iron and a steady hand, and feel like cleaning up the possible bridge between U3 and R85, to see if that cures it, that’s fine.

    If none of those options work for you, I’m happy to authorise a warranty replacement. Contact E3D referencing this thread.

    Ian
    Duet3D support



  • @droftarts said in board not working:

    just in case it’s the LED that’s failed.

    👍 didn't even cross my mind.
    the potential bridge bugged me a little as its on the 5v regulator and it does light up the 5v led so would expect u2 to get 5v and do its job.



  • @droftarts yes I have tried connecting it using YAT and I didn't even get a port response. I did check and there was something between the connection and I was able to blow it off, I tried again turning on the board but the same problem is there. I checked the 7.5A fuse and it is intact, and I have used a multimeter and I'm not seeing 3.3v anywhere closeIMG-7086.JPG



  • Just for my curiosity could you put your negative probe on the big tab on U2 and measure against pin 1 and 3 (i.e the two outermost pins on each side) and post the two voltages.

    You don't have to though, I'd contact E3D and arranged for a replacement if I were you.


  • administrators

    I agree, please ask E3D to replace the Duet. With nothing else connected to the Duet, the 3.3V LED should light even when using USB power.



  • @dc42 Is there anything that I could do to fix it myself, and or is there a common issue/part to fix. I have contacted e3d and still waiting



  • @patmurphyp9 said in board not working:

    Is there anything that I could do to fix it myself

    https://raw.githubusercontent.com/T3P3/Duet/master/Duet2/Duet2v1.04/DuetWifiv1.04a_Schematic.pdf

    if you can read the schematic and replace smd parts, then sure, no problem. if not you'll have to determine exactly what is the problem first. i.e. is it U2 not generating 3.3v or is it some of the devices using 3.3v that have failed and are shorting out the 3.3v rail?

    a good start is to measure the voltages I asked for as it'll go a long way towards answering oart of that and directing the next step.

    on the other hand of you're not confident you can fix it, its probably better to wait for the replacement.


Log in to reply