Duet 0.8.5 firmware upgrade



  • dc42 has suggested I head here from the RepRap forums for assistance in upgrading the firmware on my 0.85.

    Background, i'm running a kossel mini with duet 0.8.5 onboard, and its been running great for a while with PLA. I've decided to give e3d's Edge a go which requires higher temperatures, i'm getting some strange banding on the prints which from a post on the RepRap forums has pointed in the direction of PID tuning not being configured for the bed.

    I've made an attempt to setup PID tuning for the bed, however sending M303 H0 S80 returns an error.
    I clearly need to do a firmware upgrade.

    I've done a bit of googling and found the guide on how to update the firmware on duet2 but not for this older model.

    Currently running:
    RepRap Firmware
    Version: 1.10+4
    Web interface version: HTML:1.11, JS: 1.11

    What steps need to be taken in order to update this board, and to which versions are stable to update to?

    Thanks

    config.g


  • Moderator

    @StuartMoorhouse updating Duet 0.85 is much the same as updating Duet 2 Ethernet. See https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware

    As you’re coming from a pretty old version, rather than jumping through lots of hoops to incrementally update, I’d advise erasing firmware and flashing the latest with Bossa, which is 1.26.1 for Duet 0.85. Use file RepRapFirmware.bin from https://github.com/dc42/RepRapFirmware/releases/tag/2.05.1

    There have been a lot of changes, so it will be like starting again. Use the information from your existing config.g to help create a new set of sys folder files, using the RRF config tool: https://configtool.reprapfirmware.org/Start

    If you have customised anything (I can’t read your config file on my phone), update these new files with your customisations. Then spend time checking and commissioning your printer anew. And keep a backup of your old config, in case you want to revert!

    Any problems, just ask.

    Ian



  • Thanks @droftarts
    So, can I just clarify so I don't end up with a doorstop...
    That this is the correct version https://github.com/dc42/RepRapFirmware/releases/tag/2.05
    Am I aiming for the Duet2CombinedFirmware.bin binary file which doesn't have the version after it?

    And, its a simple case of following the 'usual procedure' as outlined in the updating firmware guide on the dozuki? Grab that binary file, upload and then install? Do I need to update the web control files too? or is this whats included in the combined firmware?

    I've a copy of my config file so will copy across the info to the new one.

    Thanks

    Stuart



  • I've re-read your post again. Yes erasing and re-flashing with Bossa sounds like the way to go. I'll give that a shot.


  • Moderator

    @StuartMoorhouse Duet2CombinedFirmware.bin is for Duet 2 WiFi and Ethernet. As I said, use RepRapFirmware.bin for Duet 0.85. And use the repository I linked, which is the latest 2.05.1. The one you linked is 2.05.

    Ian



  • @droftarts thanks,
    Ive got the firmware re-flashed to 2.05.1 with Bossa

    I ran the RepRap firmware configuration tool and generated the system files, as it states I put the Reprap Firmware file in the /sys directory, the web control bundle in the /www directory and the system files into the /sys directory.
    I cannot connect to the duet via DWC however (checked IP settings too).

    I restored the card back to its backup manually and was then able to connect to the printer via the previous IP address, I was greeted with a new DWC page so it looks like the firmware update has worked.

    I have tried as the config tool also suggests uploading the configuration bundle zip file via upload system files in DWC. When I do this, it creates another /sys folder within the directory and puts the new files in there.

    However I don't think its reading the config files properly.
    I can take manual control of the printer, heat the heaters.
    I cannot however select files to print - I can see them and tick their box, but don't know how to print them.
    Theres a new option 'load filament' which when I click it returns the error 'failed to load filament'

    Ive tried various incarnations of moving the files round and nothing seems to bring the right results.

    What have I missed? Apologies if its something blazingly obvious.

    Thanks


  • Moderator

    @StuartMoorhouse You should be on 1.26.1, this is the latest for Duet 0.85, and is bundled in with 2.05.1 for Duet 2.

    Send M115 and post response to check.

    The firmware will run whatever file is at sys/config.g at startup. Probably best to rename your old sys folder ‘sysold’ and move the new sys folder out of there and to the root.

    Ian


  • Moderator

    I expect the network issue with the new config is that you haven’t copied the settings from the old config to the new one.

    You just click on the file name to select a file to print, or right click for options.

    Hard to say where you have put everything. Perhaps post a screenshot of the file layout, and post your new config.g file.

    See this guide for using ‘filaments’: https://duet3d.dozuki.com/Wiki/Filaments

    Ian



  • @droftarts I think were back up and running now. I hadn't changed the IP address when creating the new config.g file, Id taken note of what it defaulted at and then tried to connect to that. I changed that and then I was able to connect.

    Still having the strange banding issues but thats not for this topic.
    Thanks for your help.


Log in to reply