Print abberation input requested



  • I am printing out a tray for organizing stuff. The tray stacks vertical and horizontal.
    Here is what it looks like when printed:
    tray4a.jpg
    I then printed two trays at the same time and got this:
    tray7a.jpg
    Going back to a single print, I got this:
    tray5a.jpg
    Note the weirdness in the back wall.
    I then rotated the model 90 degrees and got this:
    tray6a.jpg
    Oh good, back as it was before
    I then printed two of these together and got this:
    tray3a.jpg tray2a.jpg
    Same crap as before but this time the wall with the aberrations is the front wall. Note that the second picture of the model in the center of the build plate shows more of an issue compared to the one that was printed off center.
    Here is a slightly different perspective which also shows all but the front walls to be formed without issues
    tray1a.jpg

    Note that there are some very minor dimensional adjustments (like a mm or less) in various sections of the print to allow proper stacking horizontally but no major other changes happened.

    I haven't got a clue whatsoever what could be causing these weird things. The aberrations almost looks like what happens in a badly adjusted pressure advance when the print speed changes .... but it should be happening elsewhere too.

    Suggestions ? Guesses ?

    Oh, I did switch between skirt and brim in the slicer (Cura) at some time but I do not know if that coincided with the print aberrations showing up.

    Latest Cura, Master branch, Duet2 wifi with RRF3.01-RC05


  • Moderator

    Have you watched the print while this is happening?

    Now that 3.01 final release is out you should probably update.



  • I was intending to give 3.01 a bit of time ... seen too many ' updated from RRF3.00 - x and now things aren't working' posts.
    Having said that, if it wasn't a situation where some portions printed fine and others didn't and the issues magically showed, I probably would upgrade. It seems to me that since identical walls (front and back) worked for a while and then all of a sudden didn't that the issue isn't RRF related. It might still be related but it isn't my first go-to attempt at solving this. I would rather understand what is going on before doing too many random changes.
    I have watched a little of the print ... there is a sizeable hump forming on the upper edge ... just the same as when doing the pressure advance calibration and you increase PA beyond optimal. The print speed isn't varying though and why wouldn't identical walls cause identical issues?
    I guess they are not completely identical as there is an intersection of a side wall with the main wall on the wall that has the issues. When the problem first came up on the back wall, that wall had two intersecting walls ..... coincidence ?



  • Further thoughts - the aberration always appears at a spot where the side wall intersects the main wall but then always appears at the same distance where there is no side wall. When I have too much flow for the nozzle distance on the first layer, I sometimes get humps that could look similar and maybe I have too much flow or just borderline and the side wall pushes things into an aberration but then why would the aberration go away and show up a few mm later on a straight wall?
    Aaaaarrrgggghhhhh


  • Moderator

    What are the print settings?

    Reason I ask if you've watched the print is I'm wondering if there is some mechanical issue that you'd be able to notice at that point.

    What are your print settings? It looks like there's a bit of ringing around those areas as well, but the photos are a bit hard to see detail due to reflections and out of focus.

    Reason I mention updating to 3.01 final is that release candidates are no longer supported once the final version is out. If it is a firmware issue, we'd like to know if it's affecting the final release.



  • An interesting development .... I was printing two trays at a time and they were close together. Spreading the trays apart by a substantial amount resulted in the aberration disappearing .....
    It just makes no sense to me!
    I will upgrade as suggested.
    What print settings are you interested in?



  • I'll be not that useful but...
    I would say that is a Cura fault. In the past I had similar problems. Unfortunately Cura is not perfect. Amazing for what it offer , but not perfect.
    For example the latest version have a strange X shift if I multiply the object inside the program.
    https://community.ultimaker.com/topic/32558-multiply-selected-object-cura-461-shift-bug/?tab=comments#comment-264219
    Also Cura doesn't handle well the rising of the line width. (make strange separation between walls and so on...)
    I don't know what to say about your case now just because from that errors I had I changed so many things in the printer and in the profiles.
    The errors are regular, so something is repeated wrongly also if the preview in Cura doesn't show it.
    If you have modified heavily your profile , try to use a stock profile with just adjusted the temps , speed and layer height.
    This can point a difficult for the program to handle personal and particular configurations.


  • Moderator

    Thin wall settings. Print speed. Extrusion width, layer height. Just trying to get a full picture of what's going on.



  • @giostark, thanks for that. I had noticed the x shift but figured it not to be a big deal.
    What gets me is the randomness of the fault with the same model.



  • @Phaedrux, I have exported the project and the file is attached. This version, with the wider clearance between objects, did not produce the aberations but it's the same as the closer spaced version that did show the faults. .3mf extension was changed to .txt extension for upload.

    CFFFP_karen-ink pad storage v11.txt



  • Tried upgrading to 3.1.0 but things are broken now. Until that is sorted, I can not try out different things 😞



  • Finally got RRF3.1.1 going. It still hung initially but reverting to DWC1 and running the upgrade from there worked !


  • Moderator

    I downloaded your 3mf but it looks like it just included the model, but not the print settings.



  • Hmmm .... I had the model loaded and just exported the whole thing. Didn't even know that there is a way to NOT export all the settings at the same time.
    Any suggestion what I might be doing wrong?


  • Moderator

    Not sure. Normally the settings go right along with it.

    How bout a sliced gcode file, most of the settings are usually appended.



  • Could it have been related to the fact that I changed te file extension frm .3mf (or whatever) to .txt ?
    I assume you changed it back to look at it ....

    I have changed the model a bit with fillets and currently, printing one at a time, I do not see the previous faults. I have not yet printed this as a multiple model print close together (which is when the earlier problems arose)

    Do you want the .3mf file anyway or should I wait until I can reproduce the issue with the current model ? Do you want the sliced gcode file anyway or wait ?


  • Moderator

    Oddly when I saved it, it chose .zip as the extension. I renamed it to .3mf. That kind of makes sense though, since .3mf is also a zipped archive, so it must have detected the mimi type or something.

    Regardless. If you share the 3mf again or the gcode or a screen shot or text description of the settings I'll take a look at it, but if it's not happening on a single object I'm thinking it has less to do with settings, but who knows.



  • It sure is a weird thing ... and I have no clue why this could be happening. In any case, by tomorrow I will print two at a time and see what happens.
    Thanks for trying to help!


  • Moderator

    If you do get the defects when printing two together capture an M122 as well.



  • Will do - thanks!



  • I got some aberation on a single print and am now doing a three models at once print.

    M122 of the one model print:

    m122 may21.txt

    Project file of 3 model print as being printed right now (same settings as the one model print)

    CFFFP_karen-ink pad storage v11.txt

    Note that I have increased bed temperature to fairly high 80C and reduced layer height from 0.3 mm to 0.2 mm with a 0.4 mm nozzle.


  • Moderator

    Photo of the fault?


  • Moderator

    I was able to get this 3mf to load in cura 4.6.1 but it didn't select the print profile though it did load them. Which profile are you using?

    Also, Cura gave a warning that the model is not water tight. This can lead to all sorts of crazy things. So I suggest running the model through Netfabb online if you have an autodesk account: https://service.netfabb.com/login.php



  • Issues are same as before but here is a new picture (although not quite as clear)

    20200521_204814.jpg

    Profile is "Duet-PLA on glass,volcano,0.8 mm" .... doesn't make any sense whatsoever that it would not select the right ptofile. Makes the exported project useless.

    I never had Cura report anything being non-watertight but am not exactly surprised. These non-watertight sections are likely only on the first layer as I had (and still have) problems with the interlinking protrusions of the model.
    It's kinda hard to see but here is one interlink section:

    20200521_205953.jpg

    What you don't see is that there is a gap that is 5 mm tall between the interlock and the main body of the model. The previous/lower model slides into that gap when stacking vertically. For some reason this fails very often in the print so I added some attaching wings that are 0.3 mm tall but they are kinda afterthoughts and likely would cause the error (although I have not seen it)
    The first 5 mm of the attachment section is also very weak and breaks off easily. The print is rougher than the remaining section which is part of the main model. You can see a bit of that roughness if you magnify the picture. I suspect a pressure advance issue but it's very frustrating and a single print takes 5 hours !



  • It is possible that the issues with the profile and even the 'not watertight' are caused by us using different versions of Cura. I am using the 'Master' branch whereas you are using the 'official' Cura release.


Log in to reply