Z babysteps not working while printing 3.1.1



  • Hi guys,

    I am experiencing a weird problem.

    Z-Babystepping is not working at all once the print starts - neither from the Paneldue screen - nor DWC.
    I am running the latest firmware for both.

    When the printer is in idle (not printing) - z stepping is working normally both + and -, but when the print starts it stops responding altogether.
    M290 command also does not give any info while printing.
    I always put 3 wide skirt circles before the print just so I can make sure the the z-height is right and to prime the nozzle properly - but if it starts wrong, I cannot adjust it with babysteps - and that is something I was so used to on my previous setup.

    I have tried both + and - even 3mm just to see if anything will change over the course of printing, but it does not.

    I have also set the software limit switch of Z to -3 so I can go below Z0, but nothing I do can make the babystepping work once the print starts.
    It's weird because, as I said - in idle it works as expected.

    Any ideas?

    Please find my config.g attachedconfig.g


  • Moderator

    @omni said in Z babysteps not working while printing:

    I am running the latest firmware for both.

    Can you be specific on versions? Latest changes rapidly.



  • He's running 3.1.1 (both firmware and dwc) on duet2ethernet



  • Hello everyone,

    i just signed up because i saw this topic on the forums. I encounter exactly the same issue as Omni.

    Description:

    -Babystepping does not work while printing
    -When triggering the offset the value will be shown in the web interface but the Z axis wont move
    -I changed the Z height min to -3 but still not work
    -when pausing the print baby steps work as intended
    -when resuming the print baby stepping won't work again

    I am printing with:
    -duet wifi
    -RepRapFirmware for Duet 2 WiFi/Ethernet 3.1.1 (2020-05-19b2)
    -Version von Duet WiFi Server: 1.23
    -Prusa slicer 2.2RC5

    Thanks

    DerGulli



  • @DerGulli can you share your complete config so we can compare what similarities you and omni have? (for e.g. I don't have issue with baby stepping and omni's configuration is very similar to mine)


  • Moderator

    How are you sending the commands to baby step? PanelDue? DWC? Console?

    If you send M290 by itself, what does it report as the cumulative baby stepping value?

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M290_Baby_stepping



  • @Phaedrux omni is doing both trough dwc and trough paneldue (he's not very active on forum but I'm online with him these days non stop trying to solve these problems he's having after I conviced him to move from marlin)

    now I'm trying to decode what omni said "after printer start printing it's not accepting M290 any more" .. for that we'll have to wait for him to read&reply



  • @arhi What would I do without arhi, my 3d printing guru! 🙂

    Sorry I was away the whole day, so I wasn't able to reply. So as arhi said, I tried using it both through Paneldue7 and DWC. It is exactly the same problem as DerGulli is experiencing. Babysteps works until I start the print - after that it just stops responding. It prints out the value I am setting on the screen - but the Z axis is not moving at all. When I type M290 in the console to check the current value it does not returnt anything.

    I dont know if gcode can influence that in anyway, but I am using Ideamaker.

    If you need any additional info I would be more than glad to provide it...

    It's really annoying since otherwise rhe machine is working great now...

    Thanks a lot!



  • thanks for the quick reply I really appreciate
    I just use the baby stepping command on Paneldue and the web interface. As I said both versions work fine as long I am in “pause” state.
    I attached my config.g.
    Any help is welcome as I am also transferred from marlin to reprap shortly 🙂

    With best regards DerGulli
    config.g



  • @DerGulli said in Z babysteps not working while printing 3.1.1:

    thanks for the quick reply I really appreciate
    I just use the baby stepping command on Paneldue and the web interface. As I said both versions work fine as long I am in “pause” state.

    When you are in "printing" state if you send M290 in the console do you get any result?



  • nothing in the config of both of you looks weird to me 😞

    btw I just retested on my printer ... printer started .. I'm playing with baby steps on the paneldue and this is on dwc

    ed3f05fd-7436-424d-9a3b-b7130b7d4902-image.png

    so it is "during print", no pause, pre, after ... the head is moving and plastic is going out 😄 ...

    print is started from the sd card trough "upload and start" on DWC


  • Moderator

    Do you happen to have incredibly long and slow moves on the first layer? Though I'm not sure that even matters anymore.



  • Hello all,

    thanks for your support so far ! I checked with M290 and i got the correct readings but by Z axis didnt move.
    At the end i tried to reinstall my firmware ending up that baby stepping works now as intended.

    I don't know what was messed up.....btw. i used my old config that i posted before.

    Best regards and thanks

    DerGulli



  • @DerGulli Hey, nice to know you solved it.
    I will try that too... I was just worried that reinstalling the firmware might screw something up since now the machine is working great (apart from the baby-stepping problem...



  • I can confirm that reinstalling the firmware solves the problem.


  • Moderator

    Very bizarre. Thanks for the updates.



  • @Phaedrux said in Z babysteps not working while printing 3.1.1:

    Very bizarre. Thanks for the updates.

    it's not "iap4e.bin" as omni didn't change that one but he uploaded again duet2combinedIAP.bin with the duet2combinedfirmware.bin .. I know I had some issues myself uploading duet2combinedIAP.bin before it's possible they had wrong version? not sure what that part of the firmware does and is there any way the upgrade procedure checks if all files are inter-compatible but..


  • Moderator

    I suspect that they were not actually running 3.1.1. If the IAP files are not present the firmware update will fail.



  • @Phaedrux can't say for DerGulli but omni's duet was flashed by me, I had to flash 3.0.0 using usb and than upgraded to 3.1.1 trough dwc, checked three times diagnostic output was properly stating firmware version.... not to mention, there's no 3.x version with babystepping not working 😄 ...

    I know that if IAP files are not there update will fail, but the iap4e.bin is from 3.0.0 iirc (not present in later releases) and the duet2combinedIAP I know I put the 3.0.0 version on the SD card directly and the new one I uploaded trough DWC but as I said I had DWC before f*up the upload of the IAP file so dunno what happens if you have IAP from 3.0.0 and firmware 3.1.1 (well probably what we just seen)



  • Hm,

    i can remember when i got the board (new with duet) i just tried upgrading to the newest firmware and it failed. The i started reading.
    Thats how man do... break stuff and read the instructions after 😂
    Then i updated to 3.0 then to 3.1.1 as it should be.
    Maybe something got mixed up trying to update to 3.1.1 directly.

    Greets DerGulli


Log in to reply