Issues with print quality, wall surface rough.



  • Hello all,

    New to the forum and new to Duet 3D, been 3D printing over a year now! I bought a RatRig V-Core Pro 2 months ago, it's a 300x300x300 linear rail CoreXY machine. Pretty good overall, but having some strange surface finish on the walls.
    This is Printed Solid PLA, 220C, 93% flow, 60mm/s, 3 walls, 0.4mm nozzle, 0.2mm layers sliced with ideamaker, 16x microstepping:
    db7b789d-4f61-43b3-aa86-888a59768b72-image.png

    This will not go away, after replacing/trying:
    -XY stepper motors from LDO 1.8 to E3D 0.9
    -Extruder from a clone BMG to a genuine Titan
    -Extruder motor form a LDO 0.9 pancake to a LDO 1.8, to some random 1.8 (tried with both extruders)
    -Hot end from clone to genuine V6
    -Belts from whatever to genuine Gates (with pulleys)
    -A BigTreeTech GTR running Marlin to the Duet 3 with updated firmware
    -I've tried Cura, PrusaSlicer, and Ideamaker
    -Extremes in belt tension
    -Extremes in flow rate
    -Bass nozzles and e3d's Nozzle X
    -Print temp and bed temp very less then 1C
    -Fan speed does not change anything
    -I have tried hatchbox, esun, and printed solid pla
    -I have tried esun and overture petg
    -Temps from 190 to 230 for pla
    -No the hot end does not wobble, everything is...firm. As in no play.

    I know this looks like a z problem. I really don't think so, as the layers all all the same height when a light is shined normal to the surface. In addition, the frame is squared to 0.1deg using a digital protractor, and all three lead screws have been given the same treatment. I use auto tramming at the beginning of each print. I have fiddled with the anti backlash thingy. I have tried different couplings.

    The parts are within 0.05mm for most things. Everything comes off the printer square.

    I am at a complete loss. I have spent over a month working on this and .... nothing. Any help would be appreciated, because I am at the end of my wit.🙃



  • @CorvoDewittV2 do you have a good clear video of it in action?



  • I sure can, would a YouTube link work?



  • @Baenwort here is kinda a walk though :
    https://youtu.be/7eKYOTkbRbc
    And here is just printing:
    https://youtu.be/kA6UAp0g7Oo
    Let me know if you need anything else!!


  • Moderator

    Sounds like you've tried a lot and you've got most things covered.

    So the surface finish you're talking about is the slightly blobby look too it?

    And this has persisted between a marlin controller and now to a Duet3?

    Have you tried tuning pressure advance yet? https://duet3d.dozuki.com/Wiki/Pressure_advance

    I would maybe try backing off your extruder pinch roller tension. Back the nut off to about half. There should be just a slight bite mark on the filament when you pull it out. May need to redo your E steps per mm.

    Just in case, please provide the output of M122, your config.g, homing files, slicer start gcode, etc.

    Are you using the duet 3 in standalone or Pi mode? Are you all up to date with 3.1.1?



  • Yeah I would say maybe a bit blobby, inconsistent maybe?
    I have played around with linear advance, and I really did not see much improvement.
    The problem was nearly identical between marlin and duet, which made me very sad
    I am running the duet with a pi and on 3.1.1
    config.g
    homeall.g
    config-override.g

    Here is my start Gcode:
    G28 ; home all axes
    M290 Z0 R0 ; clear babystepping
    G32 ; do the tango ; Wait for set temperatures to be reached

    M116 P0 ; wait for tool 0 heaters to reach operating temperature
    M83 ; relative extruder movement
    ; Purge line
    T0
    G1 Z2 F240
    G1 X2 Y15 F3000
    G1 Z0.28 F240
    G92 E0.0
    G1 Y220 E15.0 F1500.0 ; intro line
    G1 X2.3 F5000
    G1 Y15 E30 F1200.0 ; intro line
    G92 E0.0
    G29 S1
    And M122
    === Diagnostics ===
    RepRapFirmware for Duet 3 MB6HC version 3.01-RC9 running on Duet 3 MB6HC v1.01 or later
    Board ID: 08DJM-956L2-G43S8-6J9F4-3S86J-TA3QFUsed output buffers: 1 of 40 (10 max)
    === RTOS ===
    Static ram: 154572
    Dynamic ram: 162032 of which 76 recycled
    Exception stack ram used: 528
    Never used ram: 76008
    Tasks: NETWORK(ready,2076) HEAT(blocked,1184) CanReceiv(suspended,3824) CanSender(suspended,1432) CanClock(blocked,1432) TMC(blocked,80) MAIN(running,2612) IDLE(ready,80)
    Owned mutexes:
    === Platform ===
    Last reset 01:05:33 ago, cause: power up
    Last software reset at 2020-07-05 16:57, reason: User, spinning module LinuxInterface, available RAM 75912 bytes (slot 1)
    Software reset code 0x0010 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0444a000 BFAR 0x00000000 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 not detected, interface speed: 37.5MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 26.8, current 44.0, max 46.1
    Supply voltage: min 23.9, current 24.0, max 24.1, under voltage events: 0, over voltage events: 0, power good: yes
    12V rail voltage: min 12.2, current 12.2, max 12.3, under voltage events: 0
    Driver 0: standstill, reads 1815, writes 25 timeouts 0, SG min/max 0/1023
    Driver 1: standstill, reads 1815, writes 25 timeouts 0, SG min/max 0/1023
    Driver 2: standstill, reads 1816, writes 25 timeouts 0, SG min/max 0/1023
    Driver 3: standstill, reads 1803, writes 38 timeouts 0, SG min/max 0/1023
    Driver 4: standstill, reads 1804, writes 38 timeouts 0, SG min/max 0/1023
    Driver 5: standstill, reads 1824, writes 18 timeouts 0, SG min/max 0/1023
    Date/time: 2020-07-05 20:09:11
    Slowest loop: 5.75ms; fastest: 0.14ms
    === Move ===
    Hiccups: 0(0), FreeDm: 375, MinFreeDm: 348, MaxWait: 1412368ms
    Bed compensation in use: mesh, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 97, completed moves: 97, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === Heat ===
    Bed heaters = 0 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    Heater 0 is on, I-accum = 0.3
    === GCodes ===
    Segments left: 0
    Movement lock held by HTTP
    HTTP* is ready with "M122" in state(s) 0 0, running macro
    Telnet is idle in state(s) 0
    File* is idle in state(s) 0
    USB is idle in state(s) 0
    Aux is idle in state(s) 0
    Trigger* is idle in state(s) 0
    Queue* is idle in state(s) 0
    LCD is idle in state(s) 0
    SBC is idle in state(s) 0
    Daemon* is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 1.41ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 0 of 8

    • Ethernet -
      State: disabled
      Error counts: 0 0 0 0 0
      Socket states: 0 0 0 0 0 0 0 0
      === CAN ===
      Messages sent 15724, longest wait 0ms for type 0
      === Linux interface ===
      State: 0, failed transfers: 0
      Last transfer: 15ms ago
      RX/TX seq numbers: 61548/61549
      SPI underruns 0, overruns 0
      Number of disconnects: 0
      Buffer RX/TX: 0/0-0
      === Duet Control Server ===
      Duet Control Server v3.1.1
      HTTP:
      Finishing macro bed.g, started by G32

    Next stack level
    Code buffer space: 4096
    Configured SPI speed: 8000000 Hz
    Full transfers per second: 18.90



  • @Phaedrux Tried backing off the idler tension, more or less the same. Also, went from 220 to 240 half way through this cube, cant even tell.
    addd4559-b372-4f05-afc2-fa46267aa058-image.png


  • Moderator

    Other thing I would check is the titan bearings. They have a habit of failing.

    At least we know that coming from a different controller and having the same issue makes it a mechanical problem. It seems like extrusion or x y motion, so you've only got a few avenues to chase down.



  • @Phaedrux the titan is pretty new, how do I check the bearings? And all 3 I'm guessing? Should the smooth idle pulleys be an issue?



  • Phaedrux is right that if changing the controller did not cause a change in the outcome it is most likely mechanical. I had hoped it would be noticeable from the video.

    The only other thing is slicer. Have you tried any other ones or validated all the non-physics related settings are the same between the printer that doesn't do it and the Rat one?



  • @Baenwort Yeah I agree, I was really hoping it was the board, because I had already changed so much out. I have tried prusaslicer, cura, and idea maker. All the same. It has to be mechanical right?? I'm running about 1200mm/s^2 for acceleration, and 60mm/s print speed, 600 jerk per min, I forgot the units lol.

    What do you think? Extruder? I really don't want to buy another one but if it fixes it, at this point, idgaf. I'm willing to try pretty much anything at this point.


  • Moderator

    Disassemble the Titan and check the bearings. See if they squeak or if they are leaking black lube. Usually pretty easy to tell if they have failed. It can happen pretty quickly if the spring tensioner is over tensioned.



  • Have you tried printing with the part fan off to see if it still looks the same ?



  • @Scachi yeah tried that too, no difference 😞



  • @Phaedrux Bearings all are good, no leaking or squeaking, turns smooth. He is a benchy, maybe you can see something in this. IMG_20200706_072014.jpg



  • I think you’re fighting a couple issues. Looks to me like over extrusion and also a possible issue with part cooling.

    Having to run your extrusion multiplier at 93% is an indicator that your over extruding. Temp and or E-step could be too high and causing this.

    220c for PLA is on the high side. Would recommend trying lowering it to 200 even 190 and trying.

    Also recommend recalibration your esteps. I’ve found it best to calibrate the esteps with the nozzle removed and the hotend temp at 0. You will want to remove the nozzle, set the temp at 0, and enable cold extrusion. Mark the filament at 150mm and extrude 100mm at 1mm/sec. Doing it this way I can run my extrusion multiplier at 100%.

    Is there a different cooling fan setup for that hotend that you can try? The ducts that come with the 4010 fans are not ideal and it looks like it’s blowing right on your hotend and the heater is having issues with keeping the temp consistent. This is evident at the tops and bottoms of the letters in the cube. Recommend finding a way to focus the airflow and direct it down a little so the air is not on the heat block. Having to print at 220 is also an indicator that you part cooling is actually cooling the heat block and you’re having to increase the temp to compensate.

    Just a couple ideas of things to try. Hope it helps.



  • @mwolter I will try a lower temp right now, and I'll double check my esteps. That hot end is my personal hot mess lol, maybe I can design some fan ducts tho. No fan doesn't seem to help tho



  • @mwolter I checked my esteps without the nozzle, dead on. Here is a print at 195C:
    IMG_20200706_100711.jpg



  • Looks better, the layers are more consistent but would be good to do a temp tower test.

    The issues at the top and bottom of the letters are still present. Have a feeling this due to the fan ducts. Seems like the cooling for the plastic isn't enough but it's also affecting the heat block temp. Printing a four-wall cube (no top or bottom) in vase mode that has no letters and solid walls would help to isolate the cooling issue.

    Would also be good to tune Pressure Advance once the other issues are resolved.



  • @mwolter I'll try a temp tower, Ill have to look up how to do that in idea maker. Yeah I'll have to do something with the fans. That might take me awhile lol. I tried printing a cube at 220 and 107% flow, just to show I guess? Anyway:
    IMG_20200706_110249.jpg



  • To me, the 220 107% print is bulging and looks melted. Like a marshmallow.



  • I had a similar issue on a machine that showed vertical walls like in your picture. In my case, my extruder current was my issue. I increased my current from 600mA to 800mA in config.g and that took care of the weird striping issues. I'm assuming the backpressure inside the nozzle caused it to over/under extrude on a regular basis creating the bulging.

    It's an easy test to increase your extruder motor current and then print again. Just something I've experienced with similar results as in your picture.


  • Moderator

    Have you PID tuned the bed and hot end heaters?



  • @PDBeal I will try that when I get home!



  • @Phaedrux Yep, temp is very stable, about +/-0.6c


Log in to reply