Heater Fault and z Stall since the RRF 3.0 Update



  • Hi everyone,

    Its a bit hard to explain ( mostly because of my poor english level 😛 ).

    In short, since I have updated my duet2 Wifi to the RRF3.0 I face many errors.
    I need some help for the folowing problem:

    1 ) It's like the thermistore is not configured the right way. And I have many heater faults. It's an E3d V6 standard hotend.

    M308 S1 P"e0_temp" Y"thermistor" T100000 B4725 C7.06e-8 ; define E0 temperature sensor
    M950 H1 C"e0_heat" T1 					; heater 1 uses the e0_heat pin and sensor 1
    M143 H1 S280                                   		; Set temperature limit for heater 1 to 280C
    M307 H0 A165.1 C686.8 D1.7 S1.00 V25.6 B0		; Pid tuning
    

    2 ) I have a Z stall report on EVERY layer. I dont use end stoper for the Z axis, juste the Bl-Touch probe.

    ; Endstops
    M574 X1 S4						; Set endstops controlled by multiple motor load detection
    M574 Y1 S4                               		; Set endstops controlled by multiple motor load detection
    M574 Z1 S2
    M915 X Y S3 R1						; Configure motor load detection
    
    ; Z-Probe
    M950 H3 C"nil"						; Disable heaters h3 to free up pins
    M950 S0 C"exp.heater3"                         		; create servo pin 0 for BLTouch
    M558 P9 C"^zprobe.in" H10 F50 T2000            		; set Z probe type to bltouch and the dive height + speeds
    G31 P500 X0 Y79.3 Z1.20;Z1.72                        	; Set Z probe trigger value, offset and trigger height
    M557 X20:280 Y20:280 S20                       		; Define mesh grid
    

    3 ) The bord fan don't work any more.

    M950 F2 C"!Fan2+exp.pb6" Q25000 T45:65 H100:101:102		;Board FAN
    

    Here I give you my full configuration:
    config.g

    deployprobe.g
    retractprobe.g

    homex.g
    homey.g
    homez.g
    homeall.g

    bed.g

    stop.g
    sleep.g
    resume.g
    pause.g
    cancel.g

    Hope someone can help me.

    Thankyou 😄



  • Can you confirm which version of RRF you installed using M115?

    if you don't use a z endstop, comment out the M574 for the z endstop.

    the pin names for the hot end are incorrect.
    They should be "e0temp" and "e0heat"

    You also don't need to free up any pins anymore as they aren't explicitly assigned.



  • Here is :
    8a9075b2-45e7-4b1b-888c-fadf6ea5cef6-image.png



  • @jay_s_uk

    Ok so now the thermistor seem more stable, thats good.

    But if I comment the "M574 Z1 S2" the printer report an error
    f3527dfb-b81f-4879-ae36-0e988f40fb61-image.png

    I think it normal as the S2 parameter is to use the zProbe as endstopper witch is my case.

    So I still get the Z stall on every layer and the board fan not working.



  • If you are using the zprobe (as you've implied) as an endstop then your homing files need adjusting accordingly.
    If you are using an endstop separate to your zprobe then you would keep it in but you would need to add a pin name for it to function correctly.

    Your fans are using frequencies that are a lot higher than expected. Typically they would be Q500.
    You also haven't actually set the fans up using M106.

    It may be a good idea for you to run through the RRF configurator and compare the outputted files against your config and adjust accordingly.



  • I do believe that H100:101:102 isn’t supported in the new firmware you need to change the numbering to something less than 32 I think. So that could be why your board fan isn’t working.


  • administrators

    @baird1fa said in Heater Fault and z Stall since the RRF 3.0 Update:

    I do believe that H100:101:102 isn’t supported in the new firmware you need to change the numbering to something less than 32 I think. So that could be why your board fan isn’t working.

    That's right. In RRF2 every temperature sensor had to be associated with a heater, so we allowed you to configure heaters 100 upwards as "virtual heaters". In RRF3 the H parameter in the M108 command is a [list of] sensor numbers, and sensor numbers can't exceed 31 on Duet 2 or 55 on Duet 3.

    You will need to configure sensors for the MCU and stepper drivers using M308 commands.



  • Thank you everyone, the MCU fan now work fine.

    The only remaining problem is the Z stall on every layer...


  • administrators

    @Donpi said in Heater Fault and z Stall since the RRF 3.0 Update:

    The only remaining problem is the Z stall on every layer...

    Either reduce the Z acceleration, or increase the S parameter in the M915 Z command.



  • @dc42

    But stall detection is not enabled on Z axis, i dont have any M915 for Z axis

    I use the probe as sensor with this command M574 Z1 S2


  • Moderator

    M350 X256 Y256 Z256 E256 I0 ; Configure microstepping without interpolation

    It's not recommended to use native x256 microstepping. It can limit the top speed of movements and cause pauses/hiccups. Use x16 microstepping with interpolation enabled. This gives the best of both worlds of low CPU overhead and the drivers will interpolate the motor steps to x256 for smooth and quiet movement.

    ;Reset sensor
    M280 P0 S160
    
    ;Rough prob
    M402 ; Retract prob
    M401 ; Deploy prob
    G1 H1 Z-305 F6000
    M402 ; Retract prob
    
    ;Down 5mm
    G1 H2 Z5 F6000
    
    ;Fine prob
    M402 	; Retract prob
    M401 	; Deploy prob
    G30 	; Prob
    M402 	; Retract prob
    

    This is unnecessary for the BLtouch. You do not need to manually control the pin. Remove all of the M401 M402 commands. G30 will automatically deploy and retract as needed.

    @Donpi said in Heater Fault and z Stall since the RRF 3.0 Update:

    The only remaining problem is the Z stall on every layer...

    What exactly does this mean? Is it stalling mechanically? Is it just pausing briefly? Can you post a video showing what you mean?



  • @Phaedrux

    About my z Stall, the print itself is nearly perfect and there is no mecanical manifestation ( no pause ).

    Juste the popup on the panel due or the web control.

    I can try to make a little video later in the day, but you would not see anything.


  • Moderator

    What does the pop up say?



  • @Phaedrux
    Sometimes
    Warning driver(s) 0 stalled at Z Height xx.xx

    sometimes
    Warning driver(s) 1 stalled at Z Height xx.xx

    and sometimes
    Warning driver(s) 0 1 stalled at Z Height xx.xx

    I my printer is a coreXY



  • Now you ask, I noticed that it's never on Z



  • Thats reporting stalls on X and Y then, not on Z



  • I setted the microstepping of all axis to 16 with interpolation ( and changed the steps per mm by the way)

    And set my M915 with a bigger S

    But I still get the warning



  • how do you have stall detection set up?
    what do you have it setup to report?



  • @jay_s_uk

    At this moment I am trying with :

    M574 X1 S4						; Set endstops controlled by multiple motor load detection
    M574 Y1 S4                               		; Set endstops controlled by multiple motor load detection
    M915 X Y S5 R1						; Configure motor load detection
    

    And still having the stall popup.

    I dont realy whant to disable de report with R0 because this will only hide the problem. (if there is one)



  • Well then you're getting expected behaviour. R1 logs the error in DWC.
    You may have to look at retuning your stall detection.
    There are a few factors that can be adjusted, such as motor current, The H and S values on M915 etc.


Log in to reply