Duet 3 v1.0 Fault on SD slot



  • Hi,

    Switched my machine on this morning and was unable to connect..did the usual check still nothing noticed no network activity on the board so erased and and opened bossa installed firmware install all OK but still no network activity so connected a Pi and network comes up
    and I can connect as usual through the Pi but as the Pi is not working with my board not much actual use the slot has always been a bit of a fiddle with it not latching 1st time but wasn't really a bother as don't remove the card that often.

    Any Advise?

    Cheers
    C


  • administrators

    please connect over USB (with a terminal like YAT) with an SD card in the socket and send M122



  • @T3P3Tony

    Hi Tony see below thanks.

    M122
    === Diagnostics ===
    RepRapFirmware for Duet 3 MB6HC version 3.1.1 running on Duet 3 MB6HC v0.6 or 1.0 (SBC mode)
    Board ID: 08DJM-956L2-G43S8-6J9DL-3SD6M-1S3UF
    Used output buffers: 1 of 40 (13 max)
    === RTOS ===
    Static ram: 154604
    Dynamic ram: 161360 of which 20 recycled
    Exception stack ram used: 308
    Never used ram: 76924
    Tasks: NETWORK(ready,1972) HEAT(blocked,1416) CanReceiv(suspended,3820) CanSender(suspended,1488) CanClock(blocked,1436) TMC(blocked,204) MAIN(running,4528) IDLE(ready,76)
    Owned mutexes:
    === Platform ===
    Last reset 00:02:56 ago, cause: reset button
    Last software reset at 2020-08-10 18:57, reason: User, spinning module GCodes, available RAM 76172 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0444a000 BFAR 0x00000000 SP 0xffffffff Task MAIN
    Error status: 0
    MCU temperature: min 39.1, current 39.7, max 39.8
    Supply voltage: min 23.9, current 24.2, max 24.3, under voltage events: 0, over voltage events: 0, power good: yes
    12V rail voltage: min 12.1, current 12.1, max 12.2, under voltage events: 0
    Driver 0: standstill, reads 20356, writes 0 timeouts 0, SG min/max not available
    Driver 1: standstill, reads 20356, writes 0 timeouts 0, SG min/max not available
    Driver 2: standstill, reads 20356, writes 0 timeouts 0, SG min/max not available
    Driver 3: standstill, reads 20356, writes 0 timeouts 0, SG min/max not available
    Driver 4: standstill, reads 20356, writes 0 timeouts 0, SG min/max not available
    Driver 5: standstill, reads 20356, writes 0 timeouts 0, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Slowest loop: 0.34ms; fastest: 0.14ms
    === Storage ===
    Free file entries: 10
    SD card 0 detected, interface speed: 12.5MBytes/sec
    SD card longest read time 0.0ms, write time 0.0ms, max retries 0
    === Move ===
    Hiccups: 0(0), FreeDm: 375, MinFreeDm: 375, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === MainDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === AuxDDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0 CDDA state: -1
    === Heat ===
    Bed heaters = -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1 -1, chamberHeaters = -1 -1 -1 -1
    === GCodes ===
    Segments left: 0
    Movement lock held by null
    HTTP is idle in state(s) 0
    Telnet is idle in state(s) 0
    File is idle in state(s) 0
    USB is ready with "M122" in state(s) 0
    Aux is idle in state(s) 0
    Trigger* is idle in state(s) 0 0, running macro
    Queue is idle in state(s) 0
    LCD is idle in state(s) 0
    SBC is idle in state(s) 0
    Daemon* is idle in state(s) 0 0, running macro
    Aux2 is idle in state(s) 0
    Autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 1.42ms; fastest: 0.01ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0), 0 sessions Telnet(0), 0 sessions
    HTTP sessions: 0 of 8

    • Ethernet -
      State: disabled
      Error counts: 0 0 0 0 0
      Socket states: 0 0 0 0 0 0 0 0
      === CAN ===
      Messages sent 0, longest wait 0ms for type 0
      === Linux interface ===
      State: 0, failed transfers: 0
      Last transfer: 140774ms ago
      RX/TX seq numbers: 0/1
      SPI underruns 0, overruns 0
      Number of disconnects: 0
      Buffer RX/TX: 0/0-0
      ok

    Cheers
    C


  • administrators

    @Carlo said in Duet 3 v1.0 Fault on SD slot:

    SD card 0 detected, interface speed: 12.5MBytes/sec

    Although that is not a great speed it does appear to be working. please post your config.g thats on the SD card.

    Its saying SBC mode so is the Pi connected? I wonder if you get a different response with the Pi not connected.



  • Tony the Pi is not connected
    and it was working yesterday in stand alone mode

    Config.g
    ; Configuration file for Duet 3 (firmware version 3)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Mon May 25 2020 14:05:35 GMT+0100 (British Summer Time)

    ; General preferences
    G90 ; send absolute coordinates...
    M83 ; ...but relative extruder moves
    M550 P"Duet 3" ; set printer name
    M665 L440.47:440.47:440.47 R234.553 H410.523 B185.0 X 0.265°, Y 0.181°, Z 0.000° ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X-0.00 Y0.00 Z-0.00 A0.00 B0.00 ; put your endstop adjustments here, or let auto calibration find them
    ;M665 L438.767:438.767:438.767
    ; Network
    M552 P192.168.0.25 S1 ; enable network and set IP address
    M553 P255.255.255.0 ; set netmask
    M554 P192.168.0.254 ; set gateway
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0.0 S0 ; physical drive 0.0 goes backwards
    M569 P0.1 S0 ; physical drive 0.1 goes backwards
    M569 P0.2 S0 ; physical drive 0.2 goes backwards
    M569 P0.3 S1 ;G5 ; physical drive 0.4 forwards for G5 flex
    M584 X0.0 Y0.1 Z0.2 E0.3 ; set drive mapping CHANGE G5 0.4G
    M350 E8 I0 ;G5 ; G5 configure 8 microstepping interpolation off
    M350 X16 Y16 Z16 I1 ; configure microstepping with interpolation
    M92 X160.00 Y160.00 Z160.00 E1900.00 ; G5 set steps per mm G5 1900
    M566 X1200.00 Y1200.00 Z1200.00 E6.00 ; G5 set maximum instantaneous speed changes (mm/min) 6
    M203 X12000.00 Y12000.00 Z12000.00 E2400.00 ; set maximum speeds (mm/min)
    M201 X1200.00 Y1200.00 Z1200.00 E120.00 ; set accelerations (mm/s^2)
    M906 X1050 Y1050 Z1050 E270 I50 ; set motor currents (mA) and motor idle factor in per cent
    M84 S45 ; Set idle timeout

    ; Axis Limits
    M208 Z-0.3 S1 ; set minimum Z

    ; Endstops
    M574 X2 S1 P"io4.in" ; configure active-high endstop for high end on X via pin io4.in
    M574 Y2 S1 P"io1.in" ; configure active-high endstop for high end on Y via pin io1.in
    M574 Z2 S1 P"io2.in" ; configure active-high endstop for high end on Z via pin io2.in

    ; Z-Probe
    M558 P8 R0.8 C"io3.in+io3.out" H5 F1200 T5000 ; set Z probe type to effector and the dive height + speeds
    G31 P500 X0 Y0 Z-0.12 ; set Z probe trigger value, offset and trigger height
    M557 R160 S20 ; define mesh grid

    ; Heaters
    M308 S0 P"temp0" Y"thermistor" T100000 B3950 ;B3950 C0 R4700 configure sensor 0 as thermistor on pin temp0
    M950 H0 C"out0" T0 ; create bed heater output on out0 and map it to sensor 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M307 H0 A108.2 C457.9 D0.5 S1.00 V24.1 B0 ; disable bang-bang mode for the bed heater and set PWM limit
    M140 H0 ; map heated bed to heater 0
    M308 S1 P"spi.cs0" Y"rtd-max31865" ; configure sensor 1 as thermocouple via CS pin spi.cs0
    M950 H1 C"out1" T1 ; create nozzle heater output on out1 and map it to sensor 1
    M143 H1 S450 ; set temperature limit for heater 1 to 450C
    M307 H1 A512.3 C269.6 D3.6 S1.00 V24.0 B0 ; disable bang-bang mode for heater and set PWM limit

    ; Fans
    M950 F0 C"out9" Q250 ; create fan 0 on pin out9 and set its frequency
    M106 P0 S0 H-1 C"Part Cooler" ; set fan 0 value. Thermostatic control is turned off
    M950 F1 C"out7" Q250 ; create fan 1 on pin out7 and set its frequency
    M106 P1 S1 H1 T45 ; set fan 1 value. Thermostatic control is turned on
    ;M950 F2 C"out8" Q100 ; set fan 2 value. Thermostatic control is turned off
    ;M106 P0 S0 I0 F500 H-1 L0.35 B2.5 ;Berd air pump settings

    ; Tools
    M563 P0 S"E3D Brass 0.4" D0 H1 F0:2 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings
    ;Retraction settings
    M207 S1.50 F900 T550 Z0.3 ;G5 ; G5 retraction setting

    ;MCU Temp
    M912 P0 S-1.8 ; adjust MCU temp for correction at ambient
    ; Miscellaneous
    ;M501 ; load saved parameters from non-volatile memory

    Cheers
    C


  • administrators

    @Carlo Thanks

    So when connected in YAT, with the Ethernet plugged in if you send

    M552 P192.168.0.25 S1
    

    Does it work as expected?

    Another test is to send M665 with no parameters and see if the correct ones are displayed back.

    Basically trying to confirm if the SD card it being read or not.

    Laos if you have another SD card it would be worth testing that.



  • @T3P3Tony

    Response from YAT

    M552 P192.168.0.25 S1
    ok
    Ethernet running, IP address = 192.168.0.25

    M665
    Error: M665: M665 parameters do not apply to Cartesian kinematics
    ok

    Still can't connect:
    Your Duet rejected the HTTP request: page not found
    Check that the SD card is mounted and has the correct files in its /www folder

    First thing I tried of the usual thing was swap the card with a backup of all the folders
    Before I re-flashed the firmware


  • Moderator

    It definitely seems like it's not reading the SD card. Not executing the config.g and can't read the /www folder.

    Can you try sending M22 followed by M21? This should unmount and remount the SD card.

    Also M122 P104, which should try to measure the write speed of the SD card.



  • @Phaedrux said in Duet 3 v1.0 Fault on SD slot:

    M22

    Hi,

    Yat output of M21/M22

    M22
    SD card 0 may now be removed
    ok
    M21
    Error: M21: Cannot initialise SD card 0: Card is unusable
    ok

    I've tried a third card which this is output against, weirdly the SD slot is now latching 1st time?.

    M122 P104
    Error: Failed to create folder 0:/gcodes in path 0:/gcodes/test.tst
    Error: M122: Failed to create file
    ok

    Cheers
    C


  • Moderator

    When and where was the board purchased? There seems to be a fault in the SD card slot.

    Can you post close up photos of the slot insides and the solder tabs?



  • @Phaedrux

    Yeah Pic to follow
    08/04/20 E3D

    Cheers
    C


  • Moderator

    Sorry, is that August 4th or April 8th? Not that it matters, either are within 6 months.

    You can contact E3D and initiate a warranty exchange. Use this thread as authorization. I'm not sure what the current Duet3 stock status is due to the current manufacturing issue with driver diodes, so there may be a delay on replacement. At least in the meantime you can use SBC mode.



  • @Phaedrux
    LoL no I can't use SBC mode it has never worked "under investigation"

    IMG_1617.jpg IMG_1611.jpg
    Best I can get on my phone

    I can't see anything obvious with the slot or pads?

    Cheers
    C


  • Moderator

    Right: https://forum.duet3d.com/topic/16191/duet3-pi-dwc-freezing/31?_=1597246408031

    All the more reason to swap it out. Something is amiss.



  • @Phaedrux
    April

    Thanks as always appreciate your help.

    C


  • Moderator

    It sounds like FW 3.2 beta1 is arriving shortly (maybe this week), if you still have the board when it lands, perhaps you can test it to see if it has an effect on your other SBC issue.



  • @Phaedrux

    E3D is out of stock so I'll keep hold until I've tested 3.2.1beta may be helpful.

    Cheers
    C


  • Moderator

    Do you happen to have a different pi to test SBC mode with?



  • @Phaedrux

    Yeah tested it with 3 Pi's 2x 4b and 1 3b+ all exactly the same result with nothing else attached and even tried a new 26 pin cable still the same.



  • @Carlo
    The freezing I sorted by not using duetPi and just adding DSF to another distro but thats a far as I could get I could do everything but print ..just went nuts on the purge line or first move
    actually damaged my print bite sheet rammed the head in to the bed bent the heat break
    but same files Iv'e printed many time in stand alone



  • i didn't read the whole thread i'll admitt, but if you want to verify the individual parts that make up the connection between the pi and the duet this old-ish thread has a ton of information on where to go digging https://forum.duet3d.com/topic/15551/duet3-pi-dcs-is-unavailable-after-wiring-24v/119?_=1597267914698

    (and if not, disregard:)



  • @bearer

    Thanks bearer I was following the thread at the time I did check continuity and chris did manage to recreate an issue I was having so expect there would be a fix at some point
    though at the time it was still freezing my issues which are many but with the duet even weirder and may not have been software or communication between the 2 as it ran as expected until a file was loaded everything else perfect probe, mesh G1's all extruding, heaters maybe a buffer/memory conflict/issue ?


  • Moderator

    @Carlo These two pins of your SD card socket do not look well soldered:
    Screenshot 2020-08-13 at 14.50.20.png
    Can you take a picture of the socket from an angle across the board, as shown here https://duet3d.dozuki.com/Wiki/SD_Card#Section_SD_Card_Socket

    Ian



  • @droftarts

    Hi Ian,

    Sorry the board went in the mail run today wanted to keep it a while to test 3.2 beta 1
    plus it is out of stock...but you get 7 days for return once they issue a returns # and I may have no access to office or workshop due to another possible 2 week lock down in my area

    all the pins looked to be well attached and no oxidation all the contacts look ok..bit hard to see inside the slot

    Image I took yesterday from a different angle.

    IMG_1618.jpg

    Dunno if it is of help.

    Cheers
    C


Log in to reply