G29 failing height map has a substantial Z offset



  • Have Railcore II. Using BLTouch v3.1.. Leveled my bad (4 points). Zeroed out Z where paper just drags and ran probe point macro. Updated config.user with Z offset that macro showed and rebooted. When I try run g29 I get error "Warning: the height map has a substantial Z offset. Suggest use Z-probe to establish Z=0 datum, then re-probe the mesh." So I must have missed a step or something. Duet/RRF is new to me; coming from Marlin so not sure what I'm doing wrong. To confirm my Z is correct; I lowered nozzle to Z0 and paper was dragging so I know I didn't mess up Z offset. Any help please. Thanks



  • @harlock328 Are you running 3.2 beta1? I just experienced a similar issue with a known level bed.



  • You generally need to make sure you've homed the bed before applying a height map. Otherwise it has no datum



  • @oozeBot
    Board: Duet WiFi 1.02 or later + DueX5
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.05.1 (2020-02-09b1)
    Duet WiFi Server Version: 1.23



  • @jay_s_uk
    Yes I homed it before trying to run G29.



  • @harlock328 You don't have a G29 command in your config do you?

    I'd suggest uploading your config.g, and homing files so we can see what's going on. Might also be worth showing a picture of the heightmap in case there's anything weird there.

    You say you levelled the bed, but are you using auto-tramming (/independent Z motors)? If so, did you run this between homing and your G29? Also upload your bed.g file. if not, ignore 😛

    I'm also confused by 'config.user' the file to edit should be config.g. Is that a typo?



  • @engikeneer said in G29 failing height map has a substantial Z offset:

    @harlock328 You don't have a G29 command in your config do you?

    I'd suggest uploading your config.g, and homing files so we can see what's going on. Might also be worth showing a picture of the heightmap in case there's anything weird there.

    You say you levelled the bed, but are you using auto-tramming (/independent Z motors)? If so, did you run this between homing and your G29? Also upload your bed.g file. if not, ignore 😛

    I'm also confused by 'config.user' the file to edit should be config.g. Is that a typo?

    Yes it's using 3 z motors. bed level with probe afterwards macro. Config.g has comment at beginning not you change and use config.user for any modifications
    G28 X Y
    M561 ; Clear bed transforms
    G28 Z ; Home Z
    G32 ; Level Bed 1
    G28 Z ; Home Z
    G32 ; Level Bed 2
    G28 Z ; Home Z
    G32 ; Level Bed 3
    G28 Z ; Home Z
    G29 ; Probe the bed at X points

    level.jpg config-user.g config.g bed.g



  • Hi,

    I assume you are homing Z with the probe?

    Please post your homeZ.g file.

    Thanks.

    Frederick



  • @fcwilt
    ;File : homez.g
    ;Effect : does a 2-stage Z-homing. Once quickly to bring the bed up from a long distance quickly, then again slower for better accuracy.
    ;Use-case : the machine may be Z-homed from any position at a reasonable pace, without resorting to dangerous options such as M564 H0 - while still retaining accuracy of the final probe.

    G91 G1 Z5 F1000 S2 ; lift z so we don't crash
    G90 G1 X150 Y150 F6000 ; Move to the center of the bed

    ; M558 Fxxx sets the probing speed.
    ; Probe rapidly to get us in the right ballpark.
    ; This brings the bed up quickly but may be less accurate.
    M558 F300
    G30

    ; Probe again slowly for precision
    M558 F100
    G30



  • Hi,

    Your homeZ.g looks OK assuming the X and Y offsets of the Z probe are 0.

    Frederick



  • @fcwilt I may be wrong but I thing G30 S3 is correct. He might be probing 4 points to generate the plane, but he's only got three Z-motors to correct so it's a three point correction. That's certainlky how I have mine working when I probe 6 points (I probe twice either side of each lead screw) and use G30 S3



  • @engikeneer said in G29 failing height map has a substantial Z offset:

    @fcwilt I may be wrong but I thing G30 S3 is correct. He might be probing 4 points to generate the plane, but he's only got three Z-motors to correct so it's a three point correction. That's certainlky how I have mine working when I probe 6 points (I probe twice either side of each lead screw) and use G30 S3

    You are correct. I was thinking of the other use of G30.

    Frederick


  • Moderator

    Please post your homeall as well.

    What order are you running your files?



  • @Phaedrux
    homeall.g

    I run home all
    Then level with probe (it does bed leveling and g29). Tried doing level. home z then g29 same problem. 2_TrueLevel_Then_Probe.g. Also tried just homing the g29 no joy.



  • I should have mention from the start; that g29 was working fine but my bed level on corners were off little. From pic when it was working
    bed1.png
    I centered my rails and re-aligned the Zs and re-ran bed level only. The bed was flat. .003 dev after that. then I did the offset procedure. That's when this mess started. Sorry not stating this from beginning. What I get for trying for perfect LOL.



  • @harlock328 I now understand the config-user.g file - it is essentially a macro which is called from within your config.g file in the line:

    M98 P"config-user.g"                    ; Load custom user config
    

    Nothing crazy there, just means you have to look in two places to see how your printer is configured.

    As I understand it:

    • you are setting your Z height by probing the centre of the
    • you are auto leveling the bed based on probing the four corner points
    • you are then creating a height map for bed mesh compensation based on probing 4 points (one in each corner)

    The Z height and the auto leveling are both correct, but I think you are using the mesh compensation (G29) wrong. You need to probe more points to get anything useful from it. The point of mesh bed compensation is to account for unevenness in your bed surface, you have already levelled it at the corners with G32 bed leveling.

    If your bed bows up in the middle, that will cause a Z-offset between the bed mesh you've made (only at the corners) and the z homing point (in the middle).

    You set up the spacing of the points to probe using the M557 command - you have this at the end of your config:

    M557 X50:200 Y50:200 S150 S150          ; Set Default Mesh (conservative)
    

    Personally, I'd recomend probing at least 50mm spacing (minimum), prefereably finer, by setting the S parameter (note that you only need one!). Also, probably push it closer to the edges of the bed to get better coverage. It might take longer to run, but will give much better results and probably doesn't need redoing that often if your printer is pretty rigid (which a Railcore should be 🙂 )
    https://duet3d.dozuki.com/Wiki/Gcode#Section_M557_Set_Z_probe_point_or_define_probing_grid
    I'm thinking something more like this based on your axis limits:

    M557 X20:220 Y20:220 S30           ; Probe the bed at 30mm spacing
    

    One other thing - I would make sure that you add M561 to the start of your homing files too. That way you will get more consistent results if you run things in different orders. In the my homez and homeall files on my printer, I have M561 as the first line, then G29 S1 as the last to load the heightmap saved on disk. That way I know bed mesh compensation is on even if I re-home my printer (e.g. when starting a new print) but won't affect my homing.



  • @engikeneer
    That's when g29 worked.. Now I getting "Warning: the height map has a substantial Z offset. Suggest use Z-probe to establish Z=0 datum, then re-probe the mesh."



  • @harlock328 said in G29 failing height map has a substantial Z offset:

    @engikeneer
    That's when g29 worked.. Now I getting "Warning: the height map has a substantial Z offset. Suggest use Z-probe to establish Z=0 datum, then re-probe the mesh."

    In your M557 specify 9 points using P3:3 and be sure the middle point is the same point as used setting the Z=0 datum which appears to be 150,150.

    See if that doesn't get rid of the message.

    Frederick



  • @harlock328 even if you get that warning, it should still have been successful and created a heightmap (it just has a Z-offset). Can you show us the heightmap with 30mm spacing?


  • Moderator

    I would try deleting the heightmap.csv file entirely.

    Then run G28 to home and G29 to probe the bed. Don't do G32 yet. That should produce a heightmap and there should be no warning about an offset. If that works correctly, then try G28, G32, G28 Z, and then G29 and that should also produce a heightmap with no offset.



  • @Phaedrux
    Did you steps; confirm no heatmap seen. ran g28 than g29; same error. Heatmap looks the same![alt text](8f9e1c9d-f0d8-4e20-b061-b2a078183c72-image.png image url)



  • @fcwilt
    This is my M557 X45:282 Y46:254 P2:2 S240 S240; what should it look like for 150,150 (I just starting to lean rrf; from marlin and not expert in that either)



  • @harlock328 said in G29 failing height map has a substantial Z offset:

    @fcwilt
    This is my M557 X45:282 Y46:254 P2:2 S240 S240; what should it look like for 150,150 (I just starting to lean rrf; from marlin and not expert in that either)

    For starters you use either Paa:bb or Saa:bb, not both.

    Now you can use just Paa or Saa and it treats it as Paa:aa or Saa:aa, so I just use the aa:bb form.

    As to testing with 9 points to be sure that the middle point is the same as 150,150 I think that this would work

    M557 X50:250 Y50:250 S100:100

    because 50 + 100 = 150 and 150 + 100 = 250.

    I don't know what your probe X and Y offsets are, so remember to take them into account when moving the probe to 150,150 when using G30.

    Frederick


  • Moderator

    The files you are editing are in the /system folder, right?

    Please send M98 P"config.g" and post the results.

    If you got to the general tab in DWC, what version does it report as?



  • @Phaedrux
    I put changes in config.user.g config.g says Do NOT make changes here and to modify config.user

    Board: Duet WiFi 1.02 or later + DueX5
    Firmware: RepRapFirmware for Duet 2 WiFi/Ethernet 2.05.1 (2020-02-09b1)
    Duet WiFi Server Version: 1.23


Log in to reply