Pressure advance Slow down



  • Hey everyone, Ive been reading the forums for a bit now trying to find my answer and Im better off asking!
    New duet user so please be gentle (not even close to new on 3dp)

    I Recently got a corexy running duet, and ive been tuning it like i would my other machines, now of course linear advance isnt the same so we come to Pressure advance.
    i did the tutorial i found on the dozuki for calibrating it and i found with my 600mm+ bowden fed by a BMG i need 2.2 for my PA. so i added that line to my config.g and now my prints are INCREDIBLY slow..

    Here are my existing settings
    M566 X900.00 Y900.00 Z12.00 E120.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z180.00 E6000.00 ; Set maximum speeds (mm/min)
    M201 X3000.00 Y3000.00 Z20.00 E10000.00 ; Set accelerations (mm/s^2)

    wondering what Jerk/accel values i should aim for, i tried adjusting them mid print but no changes. once i turned off the M571 it was golden again..

    THanks for taking the time to look!



  • I would recommend increasing your Z and E values in your M566 line. On both of my BLV CoreXY printers my Z instantaneous is set at 150 and my E is 2000.00. The E is most important when using pressure advance to maintain your print speed.

    I would also increase the Z value in your M201 line. Mine are set at 50...too low and it can be a bit slow on a layer change increasing the chance of a blob.

    It may take some testing to make sure that your extruder can handle this and not skip or chew the filament. I use Bondtech BMG direct drive extruders on all of my printers.



  • I adjusted the config to these

    M566 X1200.00 Y1200.00 Z150.00 E3600.00

    with the M572 D0 S2.20

    and yeah. SUPER slow, like 20mm/s slow


  • Moderator

    Are you saying it's still super slow even with that change to the extruder jerk?

    Are you using Cura by chance? Check your start gcode for any commands that may be over riding your config.g values.



  • this is my Start gcode from PrusaSlicer

    ; Raise bed temp to profile requested bed temp
    M140 S[first_layer_bed_temperature] ; Raise bed temp to profile requested bed temp
    M104 S150 T0 ; Raise hot-end temp to 150C for G32 auto-calibration
    M190 S[first_layer_bed_temperature] ; Wait for bed temp to rise
    M109 S150 T0 ; Wait for hot-end temp to rise to 150C
    G28 ; home all axes
    G32 ; Autocalibrate bed
    G32 ; Autocalibrate bed a second time

    G1 H2 X0 Y0 F6000;
    ;G29 S1; load mesh heightmap - loaded in bed.g
    ;G1 H2 Z20 F600 ; Move bed down 20
    M104 S[first_layer_temperature] T0 ; Raise hot-end temp to profile requested hot-end layer 1 temp
    M109 S[first_layer_temperature] T0 ; Wait for hot-end temp to rise to profile requested hot-end layer 1 temp
    G28 Z; home z again
    G1 H2 X0 Y0 F6000;
    G1 X0.0 Y0.0 Z1.0 F1000.0 ; prepare to prime
    G92 E0 ; reset extrusion distance
    G1 Z0.2 F600
    G1 X60.0 E9.0 F1000.0 ; priming
    G1 X125.0 E12.5 F1000.0 ; priming
    G1 Z0.5 F600
    G92 E0 ; reset extrusion distance

    ; end of start code


  • Moderator

    What do you have in bed.g and homeall.g and homez.g?
    I don't see anything in there that would be artificially be limiting the speed.

    What are you printing? Do you have a minimum layer time set in the slicer? That could be slowing down your print.



  • Make sure there are no entries in the config-override.g that supersede things.


  • administrators

    If enabling pressure advance slow down the print, this is caused by either the extruder acceleration or extruder jerk being set too low. Your extruder acceleration is already set very high in the M201 command, but the jerk set in the M566 command is very low. So try increasing it as @JamesM suggested.

    You can send M201 and M566 without parameters (even during a print) to check what values are being used.



  • Thanks for the suggestions!

    I set a E value of 2000, then added the 2.2 pressure advance and max speed was still 15mm/s
    nothing listed in override config. I think im just going to tune my slicer around the lack of PA.

    Now to work on this filament runout sensor!


  • Moderator

    Do you have Z hop on retraction? Wipe on retraction or coasting enabled?



  • @Phaedrux

    yes,
    0.18mm Zhop
    wipe enabled 75%
    did have retract on layer but im tweaking that.



  • @dc42 does E acceleration play a role in pressure advance slowdowns? I was under the impression that only E jerk played a role in the pressure advance slowdown. E acceleration being low would slow down a print regardless of pressure advance, correct? The E and X/Y movement is synchronized, so any slow down would happen regardless of PA, no? And PA, while it uses the E acceleration to determine advancement amount, wouldn’t cause slow down with low acceleration. Actually, in some cases wouldn’t a combination of too high of acceleration combined with too low of jerk cause slowdowns? As in: if E jerk is slowing down the print with PA, wouldn’t increasing E(/X/Y) acceleration cause the print to slow even more because the PA is trying to advance even further?


  • Moderator

    @MadMonkey said in Pressure advance Slow down:

    wipe enabled 75%

    If you're going to use Z hope you might want to increase the max speed, accel and jerk for the z axis as well.

    And it's recommended to disable wipe/coasting when using pressure advance.



  • im open to trying whatever.. honestly this seam is my issue, its causing bulges down stream from seam moves.
    i did that test and found 2.20 to be my magic number, but cant make it work..

    What should i adjust on the M566/M201/M203 area?


  • Moderator

    M566 X900 Y900 Z60 E3000 ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000 Y18000 Z600 E6000 ; Set maximum speeds (mm/min)
    M201 X3000 Y3000 Z200 E10000 ; Set accelerations (mm/s^2)



  • @Phaedrux inputed those, restarting a new test. ill let ya know how it goes

    Thanks again


Log in to reply