printer movement on startup



  • How do I disable printer z+ movement when I turn on the printer?



  • @Orang_ Please post the config.g and config-override.g

    Normally there is no movement



  • ; General preferences
    G90                                            ; send absolute coordinates...
    M83                                            ; ...but relative extruder moves
    M669 K10 U170 L319 R55.94 A-45:52 B135 H439.2 X-60,Y60,Z180
    
    M666 X0 Y0 Z0
    M579 X1.0171 Y1.0309
    ; Network
    M552 S1                                        ; enable network
    M586 P0 S1                                     ; enable HTTP
    M586 P1 S0                                     ; disable FTP
    M586 P2 S0                                     ; disable Telnet
    
    ; Drives
    M569 P0 S1                                     ; physical drive 0 goes forwards using default driver timings |D3 stealthChop2
    M569 P1 S1                                     ; physical drive 1 goes forwards using default driver timings
    M569 P2 S1                                     ; physical drive 2 goes forwards using default driver timings 
    M569 P3 S0                                     ; physical drive 3 goes forwards using default driver timings
    M584 X0 Y1 Z2 E3                               ; set drive mapping
    M350 X64 Y64 Z64 E64                           ; configure microstepping with interpolation
    M92 X1761. Y1761. Z1761. E1488.59           ; set steps per mm 1761.5 1488.59 
    M566 X1200.00 Y1200.00 Z1200.00 E1200.00       ; set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E1200.00    ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z500.00 E1000.00       ; set accelerations (mm/s^2)
    M906 X500 Y500 Z500 E600                       ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                        ; Set idle timeout
    
    
    ; Axis Limits
    M208 Z-40:300                                 ; set minimum Z
    
    ; Endstops
    M574 X2 S1 P"!xstopmax"                            ; configure active-high endstop for low end on X via pin xstop
    M574 Y2 S1 P"!ystopmax"                            ; configure active-high endstop for low end on Y via pin ystop
    M574 Z2 S1 P"!zstopmax"                            ; configure active-high endstop for low end on Z via pin zstop
    
    ; Z-Probe
    M558 P5 C"^zstop" H10  F1200 T1000 A3			; 
    M557 R130 S20                                   ; define mesh grid
    G31 X0 Y0 Z3.67 P500 h10
    
    ; Heaters
    M308 S0 P"bedtemp" Y"thermistor" T100000 B4600 ; configure sensor 0 as thermistor on pin bedtemp
    M950 H0 C"bed" T0                              ; create bed heater output on bed and map it to sensor 0
            ; disable bang-bang mode for the bed heater and set PWM limit
    M307 H0 R0.826 C133.9 D1.46 S1.00 V0.0
    M140 H0                                        ; map heated bed to heater 0
    M143 H0 S120                                   ; set temperature limit for heater 0 to 120C
    
    M308 S1 P"e0temp" Y"thermistor" T100000 B4072  ; configure sensor 1 as thermistor on pin e0temp
    M950 H1 C"e0heat" T1                           ; create nozzle heater output on e0heat and map it to sensor 1
    M307 H1 R2.707 C226.1 D3.97 S1.00 V0.0         ; disable bang-bang mode for heater  and set PWM limit
    M143 H1 S260                                   ; set temperature limit for heater 1 to 280C
    M570 H1 P5 T15
    
    ; Fans
    M950 F0 C"fan0" Q500                           ; create fan 0 on pin fan0 and set its frequency
    M106 P0 S0 H-1                                 ; set fan 0 value. Thermostatic control is turned off
    
    ; Tools
    M563 P0 D0 H1 F0                               ; define tool 0
    G10 P0 X0 Y0 Z0                               ; set tool 0 axis offsets
    G10 P0 R0 S0                                   ; set initial tool 0 active and standby temperatures to 0C
    
    M563 P2 S"2rr" D0 H1 F0                     ; define tool 2
    G10 P2 X0 Y0 Z-23.3                                ; set tool 2 axis offsets
    G10 P2 R0 S0  
    
    M563 P5 S"TEST" D0 H1 F0                     ; define tool 2
    G10 P2 X0 Y0 Z-29.3                                ; set tool 2 axis offsets
    G10 P2 R0 S0  
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    T2
    M575 P1 B57600 S0
    


  • whats in your tool change files for T2?



  • @jay_s_uk said in printer movement on startup:

    whats in your tool change files for T2?

    ????



  • tfree2, tpost2, tpre2 - I removed them because they were not needed



  • @Orang_ Change the T2 to T0 in config.g? From those differing tool Z heights, you do have a tool changer?



  • @Stephen6309 said in printer movement on startup:

    @Orang_ Change the T2 to T0 in config.g? From those differing tool Z heights, you do have a tool changer?

    at t0 the same thing,



  • @Orang_ I figured it out, it is the effect of the tool offset in Z. But how to make the printer not react when loading



  • good question I have the same effect and always wondered what it is



  • @taconite Well, apparently, after loading the initial settings, the tool is loaded with an offset



  • @Orang_ You have different heights above the bed for you nozzle. T0 will reach the bed, but T1 and T2, won't.



  • @Stephen6309 Thank you. I know. I set the correct offset value at t0. tool t1,t2 are experimental, but still if the tool offset is set, the printer raises the Z-axis when it is turned on


Log in to reply