Horrible print quality vs Arduino, my bad ?

  • @denke It does look overextrude, when I reduce the steps, it starts to show underextrusions features.

    From what I have understood, all movements are sloppy and "frenetic" instead of fluid.

    Remember this is the exact same printer, with the same steps/min in both firmwares. And same thermistores configured, so it should result in the same temperature range.

  • It has been a while since I have seen It discussed, but do you have M82 or M83 in the start of your .gcode.

  • @number40fan Nothing at the start of the gCode, but I have M83 in the config file, and also have the "relative extruder move" checked in Simplify, which I believe sends the M83 command on it's on. Would this be a problem ? (Pictured benchies where generated on Cura, which I believe does not use the relative extruder moves ?)

    PS: Actually,.. I just checked my Cura gCode and have found this : ;

    Generated with Cura_SteamEngine 3.2.1
    M190 S95
    M104 S230
    M109 S230
    M82 ;absolute extrusion mode

    This could be something,but, if this was all that is wrong, my print should have also been bad in the Arduino, wouldn't it ?

  • @artur said in Horrible print quality vs Arduino, my bad ?:

    Unstable wifi, it spontaneously resets it's IP.

    Have you checked that the MAC address does not exist in your other devices?. Duplicated MACs would generate stability issues.

    Regarding the overextrussion, It may also be the extruder stepper driver losing control. Is the current configuration according to the stepper rating?. I use 70% and works fine.

  • @carlosspr There are no other equal MAC address in our network, and this happens with more than one board (can't say if all).

    Stepper driver is rated for 2.5A, tipically, we are driving them on 800mA since it's more than enough for reliable operation on our machines.

    I've tested the DUET on 0.8A to 2A and the problem is consistent for all currents.

  • @artur using absolute extrusion on the gcode and relative in the firmware is going to cause problems. Cura can use relative as well. It's a hidden setting by default.

  • @phaedrux aren't the relative extrusion of the firmware overrided by the M82 command on the beginning of the gCode ?

  • @artur I was under the impression that the generated gcode was also different, but I could be wrong.

    In Cura do you have RepRapFirmware selected as your gcode flavor?

  • administrators

    If it was an absolute/relative issue then you wouldn't be able to get a print at all. Chances are that you have one of the configuration parameters set vastly different between the two firmwares. Is there any obvious change in the way that the machine moves?

  • @dc42 There is, it looks more Jerky in general. I've tried with the exact same acceleration and Jerk parameters (adjusted between mm/s and mm/min) and it was worse.

    @Phaedrux Good point, it was on Marlin, I'm going to test that. Still, the problem also exists with S3D which has a Marlin/Reprap option selected. So I don't really believe this will solve the issue.

  • @Phaedrux Reprap flavor seems in Cura seems to give the print a better quality, but still not on pair with what we usually get using an Arduino.

    @dc42 The Jerky movement have been lessen by reducing the max acceleration to 1500mm/s2 from 3000mm/s2. It now have the same overall fluidity has the arduino has with 3000mm/s2. What am I missing here ? Is there and hidden parameter I forgot to chance somewhere ?

  • administrators

    @Artur, does the print complete in the same amount of time on the two systems?

    Can you post videos of the same part being printed on your Arduino system and on Duet, with the same speeds and other parameters?

    Because of 3D Meetup Sweden I haven't compared the settings in your Configuration.h and config.g files yet, but I will do that soon.

  • @dc42 I'll make the test, film it and I'll post. Thank you.


Looks like your connection to Duet3D was lost, please wait while we try to reconnect.