Problems installing the IR Probe on the Duet Ethernet



  • Problems installing the IR Probe on the Duet Ethernet V 1.04 in analog mode

    1.) My IR Probe blinks only 2 x after switching on the printer -> Digital Mode
    (even if board is only powered via USB)

    This seems to be the real problem, because according to the description *) it should blink 4 times.
    In other words:
    I can't get the IR sample to work in Analaog mode on Duet Ethernet.

    2.a) Test on laboratory power supply with 3.3V with open "out" output at the sensor lets it blink 4 times -> Analog Mode

    2.b) Additional pull-up resistance 33k between "out" and "vcc" causes the sensor to flash 2 x -> Digital Mode

    Under condition 2.a) I do not get a linear output signal depending on the distance. Only 3 values for the distance/voltage:
    0V far away (LED off),
    1.5V approached (LED off),
    1.7V very close (LED on)
    But this seems to be the function of the module in analog mode. Or am I mistaken here ?

    This is also reflected in the printer. Also with M558 P1 I get only the values 0 or 1000 according to the digital mode.

    Cable connections:

    IR Probe / Duet Ethernet (Z Probe Connector)
    GND / GND
    VCC / +3.3V
    out / Z Probe In

    At first I thought my IR sample was defective.
    My second one (ordered because of suspected defect) behaves like the first one.

    I also made a 2nd connection cable from the IR Probe to the Duet Ethernet. This and the previous one I measured for errors at the contacts. But I can't see any error here either (e.g. contact from GND).

    Where is my thinking error, please help me.

    *)
    https://miscsolutions.wordpress.com/mini-height-sensor-board/


  • administrators

    Please make quite sure you have selected probe type P1 in the M558 command in config.g; so that when you power up the Duet, the internal pullup resistor is disabled. Setting it to P1 later won't have the same effect, because the IR sensor only checks for the pullup resistor once, about 4 seconds after power up.



  • Many thanks for the tip 🙂
    That was the mistake.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.