Attempt to move motors when VIN is not in range DWC shows 0.5V



  • Status on the Issue
    I am using a DUET 2 WIFI 1.03 with newest firmware (non-beta) - on an Ender 3 pro, the power supply is the Ender 3 Pros. The fans are the Ender 3 stock fans which are all 24V. I used hooked these up to the board, but did several wrong wirings ( I think), I even tried to hook up a 5V fan without changing the jumper nothing happend. After this the motors were still working. I turned the board off and tried to rewire the fans that did not work, the next day I turn the board on and I get the error and DWC showing 0.5 V.

    The issue:
    When I try to move the motors it says "Attempt to move motors when VIN is not in range"

    DWC shows 0.5 V in VIN
    I have tested all fuses they show zero ohm
    I have measured power in and it shows 24 V
    I have measured from power to heatbed and it shows 24V
    I have measured from power to hotend and it shows 24V
    Wifi Blue light check
    3.3V green light check
    5V red light check
    VIN blue light check
    Z,Y, X stop red lights check
    I have checked that VIN is tight (it is tight..)
    All jumpers are in "stock" positions

    So... Thats about where we are at... Help me DUET forum, you are my only hope... I just wanna know if it is dead and I have to try again 😞



  • Just got home from work (will just do continues updates here in the hope that someone will see and have an idea/using it as a log in case someone wants to chim in).

    I have done a "visual" inspection of the board, everything seems to be in order nothing that looks burned or shorted.

    The DWC still reports 0.5 V, but I can activate both hotend and heatbed.. But not my motors. So power is clearly going somewhere but not to the motors.

    I will look into if the fans can work - Ah... there we might have it.. I think I have fried the board at the fans.. I cannot get my fan to work on any position, neither always on or any of the others... Is there a way to confirm this?



  • @magnusjen said in Attempt to move motors when VIN is not in range DWC shows 0.5V:

    DUET 2 WIFI 1.03

    The 1.03 boards have a fan fuse near the fan connectors. Check if it is blown.
    https://duet3d.dozuki.com/Wiki/Duet_Wiring_Diagrams



  • @phaedrux I have tested the fuses and the resistance is zero as it should be if it is working.



  • Perhaps you could measure the voltage in the following points, one (or both) are used to measure Vin and you should see close to Vin/11.
    The pictures may not match your board exactly.

    1_1552591335864_duet wifi r81_v1.jpg

    0_1552591335863_duet wifi R16_v1.jpg
    I don't know which side is GND.



  • @genghisnico13 So, the top picture one is 24V (23.7 is the reading I get all the time but thats 24V) and the one in the lower picture is 23.5 which is odd, I measured it several times to ensure it was correct.



  • @magnusjen Interesting I would like to see what @dc42 has to say about it, but if I am not mistaken that doesn't look good at all.



  • @genghisnico13 Yeah... I have lost hope, I am just waiting for someone to confirm it is dead.. I will take it as an expensive lesson in basic wiring.



  • it can be resoldered see information here:
    https://duet3d.dozuki.com/Wiki/Connector_and_spare_part_numbers#Section_Fan_mosfet
    but wait for DCs input



  • @veti Well, sounds like I will just wire my old control board up if that is the case and wait for new electronics parts to arrive and the perfect day to sit super calm and solder it on.

    But good to know there is a fix, I will just wait for DCs comment.


  • administrators

    The voltage reported by DWC (and also in the M122 report) is the VIN voltage after the 7.5A fuse. That supply also feeds the stepper motors, 5V regulator and extruder heaters. A voltage divider with a ratio of 11:1 feeds the ADC input.

    If the input to the voltage divider is 24V but the DWC reading is only 0.5V then I can see a few possibilities:

    1. The upper resistor in the voltage divider is not soldered down or is cracked.
    2. The ADC input pin is shorted to another signal that is close to ground potential.
    3. The ADC has failed. But in that case I would expect the thermistor readings not to be correct.

    My gut feeling is that your Duet can be got working again.

    Does the extruder heater heat up when commanded to do so, despite the VIN reading of 0.5V in DWC and/or M122 ?



  • @dc42 He has a 1.03, not 1.04.

    OP: can you post a photo of your board from above?



  • @elmoret

    is it possible this is the same issue the other guy had?

    do you have a 10 pin connector hooked up to an LCD?



  • @tenjin Hi there, no I don't have an LCD and I have nothing going into the 10 pin connector.



  • @dc42 Thanks for replying, you got the situation right, I will upload a picture of my board aswell as another guy commented.

    The extruder heater heats up fine, I checked both at the nozzle "to see it was just an IT lie" and DWC reports the heating. I have taken a screenshot of my DWC.

    I would be happy if whatever mistake I have made can be corrected, you guys have made an awesome board.

    0_1552628048374_2019-03-15.png

    I could not also add the picture of my board, I will do it as a reply to the other guy



  • @elmoret Hi there, here is a picture of the board from above, if you guys need it I can unplug everything.

    0_1552628177522_2019-03-15 06.27.29-1.jpg
    0_1552628198909_2019-03-15 06.27.20.jpg


  • administrators

    As this is such an unusual fault, and I can't think how it would have been caused by user error, I am happy to approve a warranty replacement if it's a genuine Duet and it was in warranty when the fault was reported. If it was out of warranty then I suggest that the board is sent to our US-based repairer for analysis and possible repair.



  • @dc42 Hi, that is an amazing offer! I bought it Friday last week (2019.03.08) from RepRap.me in Denmark, they are one of your vendors in Denmark and I could not imagine them selling a knock off.

    How do I go about the warrenty replacement?


  • administrators

    Contact RepRap.me and point them to this thread.



  • @dc42 Thank you for your assistance, hopefully I can get the next to function and can post more interesting questions


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.