Mid air printinting



  • Hi, I discovered the 3d printing about 6 months ago and till 2-3 weeks ago I didn't know much about G codes, I own an Anycubic Chiron and decided to upgrade and went for a Duet2Wifi. all good so far, everything went well at cold but when I tried to print the first time the nozzle stays in the air about 1.5 mm above the bed, even if I lower the nozzle from the browser with baby steps it goes down but at the first next move the IR probe (IR DC42) goes in and lift the nozzle again.
    I'm using simplify3d and I tried so far to add G91, G90, M564 H0 inside the slicer to get over the end-switch limits but nothing helps. When I do the G32 on duet web I get a warning about the offset and on the visual map, the mesh is much lower than the bed.
    Here are my configuration files, any help is much appreciated

    0_1566145419093_config.g
    0_1566145429888_homez.g
    0_1566145439342_homeall.g
    0_1566145442786_bed.g

    Thank you



  • In your homeall.g and homez.g you have G92 Z=0 after you use G30 to probe the center of the bed. You should remove the G92 and let the G30 set your Z0 point. This likely accounts for your odd Z offset.

    https://duet3d.dozuki.com/Wiki/ConfiguringRepRapFirmwareCartesianPrinter#Section_Homing_files



  • Thank you, removing G92 Z=0 fixed the map offset from mesh grid but in Simplify 3d it's still printing in mid-air and does not aloud me to lower the nozzle below the probe trigger high. In Simplify 3d on scripts, I'm only using is G28 and G29 S1.



  • please calibrate your trigger height
    see (Calibrate the Z probe trigger height)
    https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • I've done that and on Duet Web Control it works as intended, if I send a G1 Z0 command it lowers the nozzle to the right distance but only when I'm trying to print it stays in the air.



  • In the Simplify3D process, click Show Advanced and select the GCodes tab. Make sure that the Global G-Code Offsets are all 0.00.

    If that doesn't work, grab the first 200 lines or so (down to the first G1 Zn.nnn Fnnnn line) of the gcode file and post them. That'll allow us to see exactly what the slicer is doing.



  • There are no offsets on the gcode tab and I copied the start of a gcode file
    0_1566219960032_Simplify 3d gcodes tab.PNG

    0_1566220035022_New Text Document.gcode



  • I have a Chiron with a Duet and I suffered this problem of "air printing" when using simplify3d, prusa slicer was worse.

    I cured my problem by playing with the homing files and setting up the Z probe properly. I initially cheated and used the rep rap config tool but that didnt generate what I needed properly.

    see my files for what im using with success.

    Any other help I can be just ask.

    DISCLAIMER.

    This setup WORKS FOR ME, it may not be the right or wrong way to do things, But on my Anycubic Chiron with a Duet and a titan/E3D V6 it works for me.

    Chiron Config G.txt

    Chiron Home All.txt

    Chiron Home Z.txt

    Chiron Home Y.txt

    Chiron Home X.txt

    Chiron Bed G.txt

    alt text

    Oh and I was getting Z banding artifacts showing up in my prints so I popped out the top bearings this got rid of the banding.

    alt text



  • Ok, thank you. Looking over your config file I've seen you have the Z axis minimum -1 and that made me curious, checked mine and I had it set to 2.25 so voila there has my offset I was getting in the slicer, I changed it to 0 and now it works as it should.
    Thank you guys, for all your help



  • @calvinx said in Mid air printinting:

    I have a Chiron with a Duet and I suffered this problem of "air printing" when using simplify3d, prusa slicer was worse.

    I cured my problem by playing with the homing files and setting up the Z probe properly. I initially cheated and used the rep rap config tool but that didnt generate what I needed properly.

    see my files for what im using with success.

    Any other help I can be just ask.

    DISCLAIMER.

    This setup WORKS FOR ME, it may not be the right or wrong way to do things, But on my Anycubic Chiron with a Duet and a titan/E3D V6 it works for me.

    Chiron Config G.txt

    Chiron Home All.txt

    Chiron Home Z.txt

    Chiron Home Y.txt

    Chiron Home X.txt

    Chiron Bed G.txt

    alt text

    Oh and I was getting Z banding artifacts showing up in my prints so I popped out the top bearings this got rid of the banding.

    alt text

    It doesn't give problems on tall prints because you removed the Z bearings? Nice setup by the way!



  • @corauten

    The reason for -1 in my config is if i want to play with baby stepping to get the correct "squish" up or down the negative number allows me to to that.

    As for tall prints its not an issue, these printers will never have perfectly straight lead screws and contraining them at the top means any bend has to show up somewhere and thats in the print. if you allow the lead screw to move about on the X,Y planes it doesnt matter, all that matters is the Z axis which is lift up or down and the weight of the carriage keeps the lead screw nuts where the are supposed to be and the carriage wheels on the X gantry keep everything where it is supposed to be, I even have the leadsrew nuts loosened off a tiny amount on X carriage mounts to allow the nuts to float around on the X,Y planes.



  • @CaLviNx can you confirm with me these configs are still valid for a Chiron ? Im about to tackle mine with a Duet ethernet



  • @dingo007

    I am running a duet 2 WiFi with a titan direct drive, the files I posted haven't been changed but will represent a WiFi with a titan and e3d v6.



  • @CaLviNx great im using a Titan Aero / Volcano combo only change for wifi to ethernet is ip configuration. Can i ask how did you wire your Z ?? repurposed E1 ?



  • @dingo007

    Yes for the second Z I remapped E1 I did away with the two z optical end stops and used an IR sensor you can see all this from looking at the config.g
    Using independent motor/drivers allow you to use compensation too.



  • @CaLviNx ok seriously confused, if there 2 Z connectors on the board why does one need to remap E1 ? guess im not understanding the why it needs remapoping and you cant just use the 2 Z connectors



  • @dingo007
    The two z connectors are powered from one driver. This results in half the amps available for each z motor.

    Remapping one z motor to E1 allows for independent motor control. You can then use your z probe to level your X carriage to your bed.



  • @jay_s_uk ahhhh got it... now it all makes sense! Thanks



  • @jay_s_uk said in Mid air printinting:

    This results in half the amps available for each z motor.

    Not correct. As Duet Z connectors are wired in series, not parallel, amps remaining same. What they need more is voltage, so when using 2 Zconnectors it is recommended to use 24V for VIN.



  • @aidar ah, ok. Thanks


Log in to reply